Bramha
Contributor
Contributor

Snapshots for Fault Tolerant VMs

Jump to solution

The VSphere availability guide says that you cannot Snapshot fault tolerant VMs . How else would one backup such VMs ?

1 Solution

Accepted Solutions
AndreTheGiant
Immortal
Immortal

If you need snap to do backup, you can stop FT, make the snap, make the backup, remove the snap and reactivate FT.

You cannot directly schedule (in task section), but there are some useful scripts that can enable/disable FT from CLI.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro

View solution in original post

0 Kudos
6 Replies
mlubinski
Expert
Expert

snapshot from storage system, or within guest OS

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

[I]If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points[/I]
TobiasKracht
Expert
Expert

Throuhght VM`s backup software; if you are using SAN/NAS - make snapshot of target device, or Veeam Backup. Or make new LUN (again, if you use NFS or SAN), import it to VM and make backups on this disk.

StarWind Software R&D

StarWind Software R&D http://www.starwindsoftware.com
0 Kudos
AndreTheGiant
Immortal
Immortal

If you need snap to do backup, you can stop FT, make the snap, make the backup, remove the snap and reactivate FT.

You cannot directly schedule (in task section), but there are some useful scripts that can enable/disable FT from CLI.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
Bramha
Contributor
Contributor

Andre,Thanks for the suggestion. I am trying it out and found that Snapshots are not allowed even after I disabled FT using using the Webservice API disableSecondaryVM (Its the same thats used in the scripts here http://communities.vmware.com/docs/DOC-10279 .

It is allowed after I "Turned off FT" using TurnOffFaultToleranceForVM_Task . However I did not see any API to turn it back on again once I have taken the snapshot. Any idea how I can turn it back on again.

thanks,

Parag

0 Kudos
AndreTheGiant
Immortal
Immortal

Seems that you must remove FT to enable snapshot.

If you simply disable it, snap does not working.

Maybe in next version FT...

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
lamw
Community Manager
Community Manager

Please take a look at ftCLI script, if you've turned off FT all together, then you need to use create and then enable operation. The API calls are CreateSecondaryVM_Task() and EnableSecondaryVM_Task() which can be seen by looking at the script source.

=========================================================================

William Lam

VMware vExpert 2009

VMware ESX/ESXi scripts and resources at:

VMware Code Central - Scripts/Sample code for Developers and Administrators

VMware Developer Comuunity

Twitter: @lamw

If you find this information useful, please award points for "correct" or "helpful".