GabriMWare
Contributor
Contributor

Misconfiguration in the host network setup? No more, please!

Hi everyone!

Yesterday, I came back to my job and first of all I went to review (as everyday) my vSphere system from vCenter and I noticed that a red alarm was waiting for me. HA was disabled because configuration had some error.

After read lots and lots of posts in Communities webpage, I tried to:

  • reconfigure every hosts HA (one by one)
  • enable/disable HA services (from the CLUSTER)
  • activate ports from firewall (2050-2250, 8042-8045)
  • review names and network configuration for VMKernel ports used for vMotion
  • add every hosts to /etc/hosts
  • try a nslookup with servers
  • ....everything.

The result was the same, I can only configure HA in one host, and the other two are unnable to Reconfigure HA.

Any idea???

Thank you in advance! Smiley Wink

0 Kudos
3 Replies
chriswahl
Virtuoso
Virtuoso

I saw that you added the hosts to /etc/hosts, but I would still check name resolution.

SSH into a host that is failing to configure HA, try doing

vmkping <dns name of other host>

Ensure that it can resolve the name.

Additionally I would tail the hostd.log file and see what is happening during an HA reconfiguration.

tail -f /var/log/vmware/hostd.log

And of course check the aam log (HA = AAM).

/var/log/vmware/aam/aam_config_util_monitornodes.log

VCDX #104 (DCV, NV) ஃ WahlNetwork.com ஃ @ChrisWahl ஃ Author, Networking for VMware Administrators
Troy_Clavell
Immortal
Immortal

this could also be a back record in your VCDB.  What I would try as well is to disconnect and then drag the affected Host(s) out of the cluster.  From there, one at a time, drag the Host(s) back into the cluster and "connect" See if the HA agent installs correctly.  If you have  bad record for the Host(s) you'll get a popup error in vCenter.

Worth a shot.....

GabriMWare
Contributor
Contributor

Solved!

After re-check every points of my list (first post) I disabled HA feature from Cluster I vMotioned every Vm's (from three Hosts) to one of them (doesn't matter which one). Then I entered the empty hosts in Manteinance mode and I rebooted them.

Second step, I created a new VmKernel port for vMotioning with the same Label, same ip range and same gateway for these two hosts.

Third step, I vMotioned every Vm's to these two hosts. Then I entered firts host to Manteinance mode and rebooted it.

Next step, I configured VmKernel like the other two hosts.

Finally I switched on HA feature and....Magic!! Done!

Process:

  1. Disable HA from Cluster
  2. Migrate all Vm's to the same host
  3. Put the other hosts out of the defined Cluster (where HA will be enabled)
  4. Reconfigure and check network parameters to ensure that Labels, ip ranges and gateways are working in the same way
  5. Reboot these hosts
  6. Put them into the CLUSTER
  7. Migrate all VM's to the hosts recently rebooted
  8. Put first host out of the CLUSTER (step 3)
  9. Reconfigure network....(step 4)
  10. Reboot...(step 5)
  11. Put it into the cluster (step 6)
  12. ENABLE HA in your Cluster and enjoy it !! Smiley Happy

Thank you for your advices.

vmkping => Very very useful !!

0 Kudos