jason_farrow
Hot Shot
Hot Shot

FT does not enable

Site Survey says my FT is good to go for both hosts and VMs.

When I enable FT for a VM it fails with "The Fault Tolerance configuration of the entitiy has an issue: The virtual machine's configuration does not support Fault Tolerance"

When I look in the VPXD.log on my vCenter I see this:

replay supported flag not found for primary VM

Got fault vim.fault.VmFaultToleranceOpIssuesList in creating SecondaryVM

There are other messages, much longer and less understandable, which also contain the replayNotSupported reason code.

What is causing this issue when VMware's own Site Survey tool says we are FT ready?

0 Kudos
21 Replies
paul_xtravirt
Hot Shot
Hot Shot

Have you seen this? http://communities.vmware.com/blogs/vmroyale/2009/05/18/vmware-fault-tolerance-requirements-and-limi...

For example,

VMs can’t have any non-replayable devices (USB, sounds, physical CD-ROM, physical floppy)






If you found this helpful, please consider awarding some points

If you found this helpful, please consider awarding some points
0 Kudos
vmroyale
Immortal
Immortal

Hello.

>This error occurs when you attempt to turn on FT for a powered-on virtual machine that does not meet all of the configuration requirements for FT. Power off the virtual machine, address the configuration issue, then Turn On Fault Tolerance. Potential configuration issues include:

>- Software virtualization with FT is unsupported.

>- FT is not supported for SMP virtual machines.

>- Paravirtualization (VMI) with FT is not supported.

>- VM has device that is not supported with FT.

>- Combination of guest operating system, CPU type and configuration options is incompatible with FT.

The above information was taken from Appendix: Fault Tolerance Error Messages in the Availability Guide.

Is it possible that something was changed on this virtual machine after, the Site Survey utility was used?

Good Luck!

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
mjpagan
Enthusiast
Enthusiast

Also make sure the your virtual CDs installed on local storage. It's probably not something that you're doing but it would also anger the FT feature.

Mike P

MCSE, VCP3/4, CCEA, CCSE, CCNA, A+

Mike Pagán MCITP:EA, MCSE, VCAP5-DCA, VCAP5-DCD,VCP 5, VCP5-DT, CCNA, A+
0 Kudos
jason_farrow
Hot Shot
Hot Shot

I have indeed read the availability manual. The VM in question has a "client" CD connection which is neither connected or connected at poweron.

The VM is a 1-vCPU with 1GB RAM a vmdk(thick) on a shared SAN. It is using the E1000 driver. OS Win2k3 32bit.

ESXi 4.0.0(u1) with vCenter 4.0.0(u1). IBM x3650.M2 servers with VT support enabled and NX/XD enabled. Intel 5530 processors.

I created a new VM with the box "Make this VM FT compatible" checked and that did enable for FT. So my environment is good!

My non-FT VM was not made with this checkbox enabled. However the vmx between the two has nothing significantly different. It also meets all the requirements as indicated in the availability doc. To compare the two VMs there is zero difference!

Site-Survey was done after the VM was built. Site-survey says go. VM says no!

0 Kudos
vmroyale
Immortal
Immortal

Can you post the .vmx for the "bad" one?

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
jason_farrow
Hot Shot
Hot Shot

Here is the "bad" non-FT .vmx

0 Kudos
jason_farrow
Hot Shot
Hot Shot

Try again. This time with the correct .vmx

0 Kudos
vmroyale
Immortal
Immortal

Do you have VMI (Paravirtualization) enabled? The line vmi.present = "true" would seem to suggest so. Try turning that off, as it is not supported in FT.

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
jason_farrow
Hot Shot
Hot Shot

I think I enable that as part of my "trying-to-get-it-to-work-but-having-no-success" attempts.

I have powered-off, unchecked paravirtualisation, powered-on.

No change. Same error message when enabling FT.

0 Kudos
vmroyale
Immortal
Immortal

At this point, it may be easier to create a new virtual machine and add the existing disks. This way a new .VMX will get created. It has to be something in that .VMX file.

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
Frank_Poelert
Contributor
Contributor

Hi,

Have you checked the CPU masking? Maybe the 'bad' VM has a setting that does not match with the other hosts.

You can check this quickly by trying a VMotion.

Regards,

Frank Poelert

0 Kudos
jason_farrow
Hot Shot
Hot Shot

VMotion works. Everything works except FT.

FT only appears to work on VMs that were built with the "Configure VM for Fault Tolerance" check box ticked.

Fail to tick that box and any post-build FT enablement does not work even if everything is at full compliance.

There is clearly something else we are missing. Something hidden and instigated by that check-box tick.

0 Kudos
paul_xtravirt
Hot Shot
Hot Shot

When you create a new VM and test fault tolerance on it, you stated this worked. Was the new VM that got created located on the same ESX host as the VM that will not successfully FT enable?






If you found this helpful, please consider awarding some points

If you found this helpful, please consider awarding some points
0 Kudos
jason_farrow
Hot Shot
Hot Shot

Yup, All my hosts are identical. It is the VM at fault. FT does work in my environment.

0 Kudos
paul_xtravirt
Hot Shot
Hot Shot

OK - I just wanted to qualify that the issue is reproducable on the same ESX host - just incase there was something about that particular host that was causing the issue (eg Virtualisation extensions not enabled in the BIOS)..






If you found this helpful, please consider awarding some points

If you found this helpful, please consider awarding some points
0 Kudos
jparnell
Hot Shot
Hot Shot

Hi,

Did you find out what the problem is? I'm also having trouble enabling FT on a VM. When i compare the config to a VM with FT enabled they look identical...!

0 Kudos
jason_farrow
Hot Shot
Hot Shot

Nope, never got to thebottome of this. Unless you create a VM, via the "New VM" wizard, and check the "Enable for FT" option the VM is just not going to enable for FT in the future. Clearly there is some underlying fundamental issue with a VM that prevents FT unless this option is checked during the initial build.

Does really put a spanner in the works if you import a physical server and then want to make this FT....

0 Kudos
jparnell
Hot Shot
Hot Shot

Thank you for the reply.

I think what i'll do is create a new blank VM and then attach the disks of the VM that I'm trying to enable FT on to the new VM. I would probably do this if i had a physical server that i needed to enable FT on.

James

0 Kudos
Frank_Poelert
Contributor
Contributor

Hi James,

Adding an existing disk does not give you the option to enable FT.

However, the following settings might do the trick:

ctkEnabled = "TRUE"

scsi0:0.ctkEnabled = "TRUE"

The second settings has to be made for every disk.

These settings can be made using the vCenter client: Shutdown VM - Edit settings - Tab Options - Advanced/general - Configuration parameters.

Add a row for each setting and set the value to True (without the quotes).

vCenter will create an additional file for each disk named -ctk.vmdk. This is the change tracking file vSphere uses for FT. If all other requirements are met, you should be able to make the VM FT now.

Regards,

Frank

0 Kudos