GSS344
Enthusiast
Enthusiast

com.integrien.alive.common.security.notyetvalidcertificateexception

Hi,

I am deploying vCOPS 5.8.4 on an ESXi 5.5 environment, but get this error in the configuration:

com.integrien.alive.common.security.notyetvalidcertificateexception

Please advise? Do I need to replace a certificate?

Thanks

10 Replies
vuzzini
Enthusiast
Enthusiast

Hello GSS344,

Check whether the date in the virtual appliance is before the notBefore date/time in the Certificate validity period. You may use the "date" command and get the VA date/time.


Also this issue can occur if the date on both the appliances are incorrect.

If you found this or any other answer useful please consider the use of the Helpful or Correct buttons to award points. Sandeep Vuzzini Sr. DevOps Engineer
0 Kudos
GSS344
Enthusiast
Enthusiast

Could you provide steps on how to check this?

Thanks

0 Kudos
GSS344
Enthusiast
Enthusiast

If anyone can help with this, that would be appreciated! Need to know exactly what commands to run!

0 Kudos
mark_j
Virtuoso
Virtuoso

Log in to the console of the vR Ops appliance. Typically, you'll log in as the "root" user.

Run the command "date". It'll show you the date.

If you find this or any other answer useful please mark the answer as correct or helpful.
0 Kudos
GSS344
Enthusiast
Enthusiast

Hi,

The date on the  Analytics VM goes back to August  2014. How can I adjust this to today's date?

Also, this is vcops 5.8.4, not the newer vrops, if that is of significance. Smiley Happy

0 Kudos
gradinka
VMware Employee
VMware Employee

you do it as with any other Linux OS, there is no difference

use the same "date" command, but type the current date after it in the specific format (type date --help) for usage.

note: it is very important to have dates on both vc ops VMs and the virtual center synchronized!
      This is mentioned in the install admin guide as well.

So once you fix the dates, make sure you have NTP enabled on the ESX hosts (or the VMs) to sync the time correctly from now onwards

0 Kudos
GSS344
Enthusiast
Enthusiast

Hi Guys,

I will check NTP settings. My understanding was that NTP only syncs time, not date, so I will recheck all components.

I have also found this:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=205029...

0 Kudos
mark_j
Virtuoso
Virtuoso

The VM Tools on the vR Ops VAs will sync the time with the host, so I'm expecting your host time to be the root cause of the problem. If you want to switch to NTP, though, that would also work. I would still fix the host time and get NTP configured for it.

If you find this or any other answer useful please mark the answer as correct or helpful.
gradinka
VMware Employee
VMware Employee

fixing time on the host AND enabling NTP on it (host) seems like the better approach, as it will fix the same issue with all other VMs on the host Smiley Happy

0 Kudos
mark_j
Virtuoso
Virtuoso

Some history.. enabling NTP on the vR Ops VA was a big requirement in v5.x for customer looking to get their solution compliant with STIG standards. if you've got VM Tools sync'ing, you don't need NTP configured on the VA directly, however if you've got gov't standard or other levels of compliance/certification it's necessary.

If you find this or any other answer useful please mark the answer as correct or helpful.
0 Kudos