balawiz
Enthusiast
Enthusiast

External vRO Control center HTML5 Client Configuration Issue

Jump to solution

I am unable to access html5 client with vRO 7.6 cluster configuration. We are using F5 load balancer and the monitoring of pool members shows down with the following monitoring configuration for the port 8283

Send String: GET /vco-controlcenter/docs/

Receive string: HTTP/1\.(0|1) (200)

The error which we get for cluster URL is  "ERR_CONNECTION_REFUSED"

For individual vRO server we get the error like { "error": "invalid_request", "error_description": "Must provide a matching redirect uri." }

Any help appreciated and I followed the following document for vRO LB config

https://docs.vmware.com/en/vRealize-Orchestrator/7.3/vRealize_Orchestrator_Load_Balancing.pdf

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
balawiz
Enthusiast
Enthusiast

Seems, we can't access the HTML5 client with Cluster URL. So, I performed the following steps to correct the login issue and connected to one of the vRO server HTML5 client. However, please note that vRO control center is working fine with cluster URL.

  1. Log in to the vRealize Orchestrator appliance using SSH or console.
    Reset the
    authentication provider by running this command:
  2. /var/lib/vco/tools/configuration-cli/bin/vro-configure.sh reset-authentication
  3. Unregister and Re-register the vRA from vRO control center authentication provider
  4. Restart the orchestrator configurator service by running this command.

     service vco-configurator restart

---------------------------------------------------------------------------------------------------------

Was it helpful? Let us know by completing this short survey here.

View solution in original post

0 Kudos
3 Replies
daphnissov
Immortal
Immortal

Not sure why you're using an older version of the load balancing guide when there's a more recent one here. I haven't compared the two with regard to the health check for control center, at least have a read.

0 Kudos
balawiz
Enthusiast
Enthusiast

Have checked this latest link as well and the configuration is same. VMware is suggesting this KB VMware Knowledge Base to check and will check the same and update here.

0 Kudos
balawiz
Enthusiast
Enthusiast

Seems, we can't access the HTML5 client with Cluster URL. So, I performed the following steps to correct the login issue and connected to one of the vRO server HTML5 client. However, please note that vRO control center is working fine with cluster URL.

  1. Log in to the vRealize Orchestrator appliance using SSH or console.
    Reset the
    authentication provider by running this command:
  2. /var/lib/vco/tools/configuration-cli/bin/vro-configure.sh reset-authentication
  3. Unregister and Re-register the vRA from vRO control center authentication provider
  4. Restart the orchestrator configurator service by running this command.

     service vco-configurator restart

---------------------------------------------------------------------------------------------------------

Was it helpful? Let us know by completing this short survey here.

0 Kudos