Matrix_1970
Enthusiast
Enthusiast

"Job error: Audit VMs #<Thread:0xa15380> can't convert nil into String" Error

Hi guys,

in System Messages I have the records, periodically generated "Job error: Audit VMs #<Thread:0xa15380> can't convert nil into String"

In my logs I have these lines:

[2016-10-18 09:33:47 UTC] P4976DJ53102 DEBUGVmAudit: Looking for AppVolumes volumes matching "[DataDisksRM01] itvdiws11-n833-vdm-user-disk-Z-56cea5ed-3856-4947-8f25-2a815440dacc.vmdk"
[2016-10-18 09:33:47 UTC] P4976DJ53102 ERROR    Cvo: Job error: Audit VMs #<Thread:0xa05378> can't convert nil into String
[2016-10-18 09:33:47 UTC] P4976DJ53102 DEBUG    Cvo: Finished job: Audit VMs #<Thread:0xa05378>
[2016-10-18 09:33:47 UTC] P4976DJ53102 DEBUG    Cvo: Rejecting temporary adapters under "temporary#<Thread:0xa05378>" reserved from "#<Thread:0xa05378>"
[2016-10-18 09:33:47 UTC] P4976DJ53102 DEBUG    Cvo: Releasing 2 adapters from 2 pools reserved from "#<Thread:0xa05378>"
[2016-10-18 09:33:47 UTC] P4976DJ53102 DEBUG    Cvo: There are now 3 pools with 3 total items
[2016-10-18 09:33:47 UTC] P4976DJ53102 DEBUG    Cvo: Worker will be shutdown for restart in 3049 seconds #<Thread:0xa05378>
[2016-10-18 09:33:47 UTC] P4976DJ53102 DEBUG    Cvo: Failed job: Audit VMs #<Thread:0xa05378>

[2016-10-18 09:33:49 UTC]   P3572PW630 DEBUG   RvSphere: Monitor::VmPowerWatcher #<Thread:0x43b2bb0>: WaitForUpdatesEx for version "676" took 213860ms

[2016-10-18 09:33:49 UTC]   P3572PW631 DEBUG    SQL:   Machine Load (0.0ms)  EXEC sp_executesql N'SELECT TOP (1) [machines].* FROM [machines] WHERE [machines].[identifier] = N''5014c009-ade1-6749-771d-39e9bba64347'''
 

In Pending Actions log I see:

Oct 18 2016 11:46AM

Audit VMs

Audit VM state and ensure attachments are in sync - Failed 5 times

Failed

Have you ideas?

Thank you to all

Matrix

0 Kudos
4 Replies
Ray_handels
Virtuoso
Virtuoso

What Appvolumes does is check if the database information is still correct with the actual situation. It just does a call to the VCenter then to confirm the information in the database.

It seem as if the information is not in sync. I would suggest raising a ticket with VMWare to check and see the reasoning behind it. What verion of Appvolumes are you using btw??

0 Kudos
Matrix_1970
Enthusiast
Enthusiast

Hi Ray,

thank you very much. My AppVolumes ver. is 2.11

Best regards

Matrix

0 Kudos
Ray_handels
Virtuoso
Virtuoso

Okay. The older version of Appvolumes (I believe version older than 2.10) still from time to time had this issue. It should be resolved in 2.11.

As said, I would raise a call with VMWare. .

0 Kudos
Matrix_1970
Enthusiast
Enthusiast

Hi,

I have upgraded to 2.11, but the error still persists. I have found this file, audit_vms_job.rb that I think is the script/job that AppVolumes uses, but is protected.

Anyone can help me? Thank you@

Matrix

0 Kudos