Highlighted
Enthusiast
Enthusiast

Visual Studio - what actually works ?

Jump to solution

we are on 4.1 app vol.. Win 10 Enterprise .

Sounds like from the forums this is a beast of an app to get working ?

Just to save whats the rest of my hair - Could someone that has got it working chime in please as to what process worked ?

im gonna go ahead and assume a Layer wont work .. ( correct ? ) .

What we want to do is DEdicated Instant Clones .. and put Visual Studio on the Gold Image for our programmers Pool .

Has anyone got it to work that way ?

If not - could you please chare what Has worked for you ?.. ( if Anything ) .

thank you very much !

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Virtuoso
Virtuoso

Installing on the GI always works for as far as I can tell. There is one forum post here in which is stated that you can reset the PidCode with an exe and reset the license hash with an application. If you add Visual Studio in an appstack that's the only way I have seen it working.

 

Installaing Visual Studio is extrmeley straightforward, just as you would when installing in normally on a machine.

View solution in original post

0 Kudos
3 Replies
Highlighted
Virtuoso
Virtuoso

Installing on the GI always works for as far as I can tell. There is one forum post here in which is stated that you can reset the PidCode with an exe and reset the license hash with an application. If you add Visual Studio in an appstack that's the only way I have seen it working.

 

Installaing Visual Studio is extrmeley straightforward, just as you would when installing in normally on a machine.

View solution in original post

0 Kudos
Highlighted
Hot Shot
Hot Shot

I'm going through this nightmare right now.

Adding to base image isn't an option for us due to the small# of users and the amount of effort involved.  Originally I was hoping to have it working as an AppStack and manage the custom settings with DEM.  This worked with the first installer I was provided and somehow was licensing OK - as in no steps were required to license is on the machines the AppStacks was deployed to.  The team that provides me the installer updated it a few months ago and the license key stopped working, the floating desktops were coming up with that pre-release unlicensed software error.  I was unable to get the license to activate automatically using the ddconfigca/storepid commands as either part of app volumes startup.bat or as an elevated app / post-import task with DEM (although they did work if you manually ran them from the command line, but this wasn't an option, I suspect this is related to UAC)

I wanted to avoid writable volumes, as they don't fit into our multiple datacenter design, but I did manage to get VS 2019 Pro to work correctly with a writable volume (custom 50gb UIA only template) along with DEM to manage the user settings.  In theory the writable volume shouldn't bloat or degrade over time since the users don't have admin rights, they were only granted during the install of VS 2019.  It looks like the writable volume is the supported method from VMware.

 

2149369

0 Kudos
Highlighted
Enthusiast
Enthusiast

thanks for the help everyone !

0 Kudos