Nick_A671
Contributor
Contributor

Unable to install apps within Provisioning Mode

Hello all,

Currently trying to implement App Volumes for the first time in our environment. After quite a few hiccups, was able to install App Volumes Manager, created a provisioning machine (cloned from VDI golden image), installed the App Volumes Agent on the provisioning machine, as well as created our first Appstack (for testing purposes).

As of now, we are at a standstill when trying to install any applications within provisioning mode.

When installing the latest version of Firefox, on the "Where do you want to place this file" screen, the default is the C:\ProgramData folder. We leave the default in place and click Next, but receive an error immediately after showing, "You don't have access to write to the installation directory. Click OK to select a different directory." We are able to continue the install by selecting the personal "My Documents" folder of the admin account, but that wouldn't follow VMware best practices in capturing applications.

When attempting to install Notepad++, after choosing a language, we receive a pop-up showing, "Error opening file for writing: C:\Program Files (x86)\Notepad++\plugins\NPPExport\NPPExport.dll."

Note*:

     -We are able to perform both of these installs flawlessly on the provisioning machine outside of provisioning mode, but only during provisioning mode, are we experiencing these issues.

     -Removed the Horizon View Agent as well as McAfee Agent. Was unable to remove McAfee DLP Endpoint, McAfee Endpoint Security Platform, and McAfee Endpoint Security Threat Prevention         due to password/key requirements to uninstall (would have to request those from separate IT shop.

      Seeing as how we were able to install the programs outside of provisioning mode, I'll assume that these McAfee products are not involved with the issues inside of provisioning mode (could very         well be wrong though)

Any thoughts? Thank you in advance!

-Nick

0 Kudos
3 Replies
sjesse
Leadership
Leadership

Remove the AV, that will mess with the appvolumes agent. Also are you installing as a local admin account, if not add a local administrator account and try that.

Nick_A671
Contributor
Contributor

sjesse,

Thank you for your response.

I did try creating a local admin and used it to install with no luck. I feel like McAfee might be the issue here.

Unfortunately, the environment I'm in falls in line with DoD network policies so trying to remove McAfee from the machine will definitely be a challenge seeing as how I don't have permissions to completely remove McAfee and having to get approval from a bunch of "big wigs" will be a hard sell. I was able to remove the Agent if that means anything.

If there's no other implementation besides removing the AV, I'll just give my people the "take it or leave it" speech.

Thank you again for your help!

0 Kudos
sujayg15
VMware Employee
VMware Employee

Hi this is the App Volumes Deployment Considerations document which states AV could create problems during provisioning.

https://techzone.vmware.com/sites/default/files/resource/app_volumes_deployment_considerations.pdf

- last line on page 26

pastedImage_1.png

0 Kudos