moto316
Enthusiast
Enthusiast

Unable to configure vROPS on AV 3.0

Jump to solution

Unable to configure vrops on av 3.0 -

  • fresh install
  • logged into console and ran /etc/wemi/utils/disable_ssl_validation.sh
  • rebooted
  • configured AD bind and roles and permissions step
  • input FQDN for vrops appliance, AD username with admin permissions and password

Get this error: Internal Server Error. Server encountered internal error and was unable to complete your request. Please try again later. If this issue persists contact your service provider.

Nothing relevant is indicated in the logs. Anyone else run into this problem?

1 Solution

Accepted Solutions
moto316
Enthusiast
Enthusiast

Apparently it doesn't like my FQDN despite being able to ping the vrops appliance from within the AVM console using FQDN. Works using https://VROPS_IP_ADDRESS or https://VROPS_HOSTNAME

View solution in original post

0 Kudos
11 Replies
Jason_Marshall
VMware Employee
VMware Employee

‌Might be a silly question but you do have vROps installed correct?

Try to also disable the firewall on the OVA.

0 Kudos
moto316
Enthusiast
Enthusiast

Yep vrops is deployed and configured,, can verify that each appliance can ping each other as well. And regarding disabling the firewall are you talking about the firewall on the vrops or av appliance?

0 Kudos
moto316
Enthusiast
Enthusiast

Apparently it doesn't like my FQDN despite being able to ping the vrops appliance from within the AVM console using FQDN. Works using https://VROPS_IP_ADDRESS or https://VROPS_HOSTNAME

0 Kudos
Atul_gen
Enthusiast
Enthusiast

Could you please check the below things.

1.) Ping the FQDN hostname in OVA machine, if you are trying to add vrops uisng FQDN. If it is not pinging as an entry in hosts file to get resolved the fqdn.

2.) Accept all cert as "No" then you need to upload vrops certs otherwise select option as "Yes"

If you need how to upload vrops certs let me know i will help you

If you find this or any other answer useful please mark the answer as correct or helpful.
0 Kudos
jeniferslabaugh
Enthusiast
Enthusiast

I'm having this same issue and have tried all of the suggestions listed in this thread.  I've also adjusted my AD configuration since that made a difference elsewhere when configuring AppVols 3.  Does anyone else have any suggestions?  Thanks!

0 Kudos
ARuvVD11
Enthusiast
Enthusiast

I'm getting this as well. This IS still setup like the old one right? Where the username/password is what was used to setup the horizon adaptor in vrops?

I've got my vrops instance using SSO, no mention has been made as to wether or not this is supported.... I know the orchestrator connector is STILL broken in this regard.

0 Kudos
Ray_handels
Virtuoso
Virtuoso

No, you need to use the admin password you use to log into the vROPS, not the Horizon adapter account. This is only used for connecting the adapter with the broker on the connection server.

jeniferslabaugh
Enthusiast
Enthusiast

Yes, I am using  the admin password used to log in to vROPS, and it's not working.  I verified it works to log in to vROPS.

0 Kudos
ARuvVD11
Enthusiast
Enthusiast

Using the local admin account for vrops, and pointing it to the https://IP_ADDRESS and selecting ACCEPT ALL CERTIFICATES was the magic combination. Seems I need to add my rootca to the certificate store, I'm betting the vcenter connection wont work either.

Adding a rootca should not be a task I need to drop into command line to do VMWARE. Please add it to the wizard -_-

0 Kudos
ETAVIS_GNS_AG
Contributor
Contributor

It looks like the username has a character limitation. I can only put 20 charachters for a username.

But if my username is longer than 20 character its impossible to use this user. Why is this so?

0 Kudos
danielmgrinnell
Enthusiast
Enthusiast

Hey Guys,

Im getting the following error, i tried FQDN, ShortName , IP Address, vROPS Admin account, my service account and my Ad account i setup in vrops, Any ideas?

Capture15.JPG

0 Kudos