LukaszDziwisz
Hot Shot
Hot Shot

Snagit 2018

HEllo Everyone,

Did anyone have any experience with installing Snagit 2018 on appstack. When I build an appstack, everything works great including on a packaging machine however once pushed to users when I try to launch the application I'm getting the following error:

pastedImage_0.png

Any advise would be greatly appreciated,

Tags (2)
0 Kudos
9 Replies
Ray_handels
Virtuoso
Virtuoso

Could it be that the datastore path of SnagIt (we are not using 2018, but do have an older version running) is hardcoded?

Also keep in mind that anything in user context (so info in C:\USers and HKCU) is NOT stored in an appstack. If you do want to record this info use either UEM or a writable volume

0 Kudos
LukaszDziwisz
Hot Shot
Hot Shot

We are using writable volumes however I don't want to install it on each user manually. Hardcoding the datastore location is very possible. I have tried to create a folder on the root of the C and pointed the datastore location there but it still keeps using the path in the screenshot. If I put it on gold image it appears to be working properly. Any suggestions on how to resolve it?

0 Kudos
Ray_handels
Virtuoso
Virtuoso

If it does use hardcoded paths unfortunately no. I would suggest asking Snagit how to change it.

Normally they set these kinds of parameters in the registry. You could try and find that parameter and change the name of the user to %username%, it might just work..

0 Kudos
LukaszDziwisz
Hot Shot
Hot Shot

OK thank you Ray. I will keep this thread as un-answered and post solution once I hear back from them

0 Kudos
techguy129
Expert
Expert

We have Snagit 2018 as an Appstack don't have this problem. Is it possible you have another snagit appstack mounting or you're capturing this with UEM?

However

You can use the TechSmith Deployment Tool to customize the automatic store path. I would input a path to a location outside of user profiles so the Appstack captures it.

TSC_DATA_ STORE_ LOCATION Enter the path to save the automatically stored files.

https://assets.techsmith.com/Docs/pdf-snagit/Snagit-2018-MSI-Installation-Guide.pdf

0 Kudos
LukaszDziwisz
Hot Shot
Hot Shot

We don't have another Snagit Appstack. That is the only one we have. I have tried to customize the msi using Deployment tool where I created a folder on the Root of C and gave users Modify permissions and pointed all three locations to custom folder located on C, however it didn't seem to take it. Is this what you did in your case? If not, can you please share where are you pointing those files to?

0 Kudos
techguy129
Expert
Expert

I installed it out of the box without any changes. I am not capturing the datastore file with UEM for persistence so that may be the reason I'm not seeing the error. Its recreats the folder under %localappdata% whenever I open up the app.

0 Kudos
LukaszDziwisz
Hot Shot
Hot Shot

OK thank you. I will  attempt it once again and post results. Here is the article I found. It does appear that if I'm doing a profile redirection including AppData then it will be a problem with Snagit, see below:

Snagit (Windows): Error: Failed to initialize the SnagIt datastore.... – TechSmith Support

0 Kudos
zhornsby221
Contributor
Contributor

Has anyone resolved this? I am receiving the same error. all the settings are saved but the stored files will not persist 

0 Kudos