cdickerson75
Enthusiast
Enthusiast

Registry Permissions

Can I not set registry permission and this be captured in a App Stack?  I've tested this and doesn't appear to be the case.  How can I set specific registry permissions so a program will launch correctly?

Thanks

-Craig

11 Replies
Ray_handels
Virtuoso
Virtuoso

File permissions are retained so my guess is registry permissions will also be retained. Just for the record, which key are you setting these permissions to and are you sure these keys are not excluded from the appstack?

techguy129
Expert
Expert

You can edit permissions by using the command line utility: regini.exe

https://support.microsoft.com/en-us/help/264584/how-to-change-registry-values-or-permissions-from-a-...

Put whatever command you will use to change permission in one of the bat files that runs as system if the user doesn't have permissions

Cloning AppStacks and Modifying Scripts - VMware Consulting Blog - VMware Blogs

OR

if you use UEM, you could always do a privileges escalation on that program so it has rights.

Sravan_k
Expert
Expert

Hi Cdickerson75,

On registry permissions and app stack, during the process of creating/updating app stack it will capture only HKLM hive and out-side of user profile [i.e it will not capture inside c:\users]

If you are using UEM 9.2.x version you can user Admin Privileged for particular application  

Please provide us your feedback/update regarding this request

Thank you,

Vkmr.

LukaszDziwisz
Hot Shot
Hot Shot

Has this ever been resolved? I'm trying to modify permissions in appstack while provisining. THe key I need to add users permissions to modify is Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Once I modify permissions it just disappears like it's not sticking at all?

0 Kudos
Ray_handels
Virtuoso
Virtuoso

Could be that this specific location is being excluded. Just check the snapvol.cfg file on the appstack that you are changing the permissions on. If you can find that specific location with an exclude it is not retained within the appstack.

Seems that with version 4.0 this specific location is not being excluded,.

LukaszDziwisz
Hot Shot
Hot Shot

@Ray,

So it is not beeing exlcuded but I also don't see it being included. Meaning that there is no virtualize_registry= command for that path either. Would this be the case?

Also, I was able to kind of resolve my problem by simply changing the Registry permission for that key on my packaging machine and then provisioning appstack on that .

0 Kudos
mambo785
Contributor
Contributor

Hello LukaszDziwisz

I am having exactly the same issue, but for another registry key. Could you be more specific how you have resolved it, please?

"by simply changing the Registry permission for that key on my packaging machine" = do you mean changing the permission for that key on the packaging machine, before starting the packaging?

By the way, I cannot find snapvol.cfg in my appstacks since Appvolumes v4. Do you see this file in your appstacks?


Thanks a lot!

Best,

Martin

0 Kudos
LukaszDziwisz
Hot Shot
Hot Shot

mambo785    

So we have 2 packaging machines that are clones of Master images minus almost all apps and horizon agent. I powered it on, consoled in and changed the desired key permissions. Then powered it off and took a snapshot. Next, created new appstack, powered on that packaging machine and started provisioning on it. Once app was installed rebooted and completed provisioning process. Then assigned the appstack and had no more issues with modifying that key by script.

0 Kudos
mambo785
Contributor
Contributor

LukaszDziwisz

thanks a lot for the fast reply. I will try to do it like this as well and will let you know the result.

0 Kudos
mambo785
Contributor
Contributor

LukaszDziwisz

it has worked - thanks a lot! much appreciated.

LukaszDziwisz
Hot Shot
Hot Shot

Great glad it worked out for you

0 Kudos