burgerking68
Enthusiast
Enthusiast

Migrate Writeable Volumes from 2.x to 4.x

Hello, we recently migrated our AppStacks from version 2.18 to 4.0 using the FlingTool (https://flings.vmware.com/app-volumes-migration-utility).

Can someone tell me how to migrate the existing 2.18 "writeables" to 4.x?

Unfortunately, this way is not provided via the FlingTool ...


Thank you for your support.

VMWare 8.4, DEM 2106
15 Replies
Ray_handels
Virtuoso
Virtuoso

To be honest I don't think you can migrate them.

What you could try is create 1 writable on 4.0, it will then create a new folder on the datastore which is called Appvolumes\writable.

You could then try and move (or copy, that might be a better idea) from Cloudvolumes\writables to that folder and import the writables in 4.0.

To be honest I have no idea if this is actually supported.. But you woul have to ask GSS for that info.

0 Kudos
medvmwadm
Enthusiast
Enthusiast

I am going through the exact same process right now as well.  The fling does work for AppStacks, which we have confirmed here.  But, we need a way to migrate Writable Volumes as well.  I combed through the documentation and I see no mention of this anywhere!

I have tried copying over a Writable from 2.x to 4.x and placed in to the new "writables" directory on the datastore and clicked Import in the new AV 4.0 Manager, however it does not see it and does not show up in the Manager.

Looks like we may need to get ahold of support on this one, can't see how this is done.  Hopefully there's a way so that we don't have to manage existing Writables in two separate places (in the new Inventory tab AND Volumes 2.x tab).

dbrutus
Enthusiast
Enthusiast

This is a big problem for me if I can't migrate my 2.18 wrtiables to 4. I'm going to put a feature request for this.

gzlebir
Contributor
Contributor

We are having the same issue now. So as far as i understand you cannot migrate a writable volume from 2.x version to 4.x is that correct? So the only option is to create a new writable for users?

0 Kudos
Ray_handels
Virtuoso
Virtuoso

Yes and yes.

Don't get your hopes on on this one, even when you create a support ticket.

The way the 4.0 version works with writables is different than the 2.x version does. I don't think it will be possible in near future.

julatoski
VMware Employee
VMware Employee

We are looking into guidance for migrating Writable Volumes.  At this time we recommend customers upgrade their Manager to App Volumes 4 and continue using 2.18 agents until we are able to address the Writable Volumes migration challenges.

Thank you for your understanding.


Jeff Ulatoski
Product Line Manager, App Volumes
dbrutus
Enthusiast
Enthusiast

Thank you, hopefully something could be worked out because we would like to fully migrate to 4. It is kind of a deal breaker for us if we have create new writables for our existing customers. I also reached out to our TAM about the writable migration situation from 2.x to 4.x.

0 Kudos
dbrutus
Enthusiast
Enthusiast

Wanted to share this blog with everyone. VMware is aware and is working on something to help migrate from 2.18 to 4. I also heard the same from our TAM today too. Hope this helps.

 

https://blogs.vmware.com/euc/2021/03/announcing-extended-support-for-vmware-app-volumes-2-18.html

0 Kudos
Stefan21
Contributor
Contributor

Hello @julatoski 

It's been a year now and I think many customers, us included, would like to be able to migrate the writable volumes with a fling instead of recreating everything or copying files manually.

Support for Agent 2.18 expires in September, will VMware provide a fling for migrating writable volumes by then?

0 Kudos
Stansfield
Enthusiast
Enthusiast

2.19 gets till 2023-12-21

You have to use an app volumes 4 manager for it

 

https://lifecycle.vmware.com/#/

0 Kudos
Stefan21
Contributor
Contributor

Don't understand. How can the agent migrate writable volumes?

0 Kudos
Stansfield
Enthusiast
Enthusiast

just buys time

0 Kudos
julatoski
VMware Employee
VMware Employee

Thank you for your patience. 2.19 is there to address updates without updating the App Volumes manager. To stay current on functional and security updates we ask all customers use the App Volumes 4 manager server.  

Our team is in the final steps of building the command-line migration tools for 2.x Writables. Just a little longer as we work out the last bits before release.


Jeff Ulatoski
Product Line Manager, App Volumes
0 Kudos
richiefez
Enthusiast
Enthusiast

Any update on the utility?

0 Kudos
dbrutus
Enthusiast
Enthusiast

A fling was recently release to address that exact problem. Here's the link:

https://flings.vmware.com/app-volumes-migration-utility#instructions