Hot Shot
Hot Shot

Jabber Outlook Integration

We use Jabber 12.8 and Office 2016 O365. If I install both directly on the image Jabber integration with Outlook works fine, but if you put them in appstacks Jabber throws a warning the Outlook integration failed.  Everything within Jabber works fine, but Outlook itself will not show Jabber statuses.  This happens even if you capture Office and Jabber in the same appstack, Jabber on a machine with Office installed or separately.  Anyone have any ideas how to get the integration to actually work when using app volumes?

0 Kudos
3 Replies
Virtuoso
Virtuoso

I would suggest installing Office on the GI and Jabber as an appstack.

I have seen Outlook integration working with Jabber in this situation.

Do make sure that your packaging machine has Office installed when you package Jabber.

Also, it could be that the Outlook integration of Jabber is being created in the HKCU key, Appstacks do not add that infomation into the appstack. If so, use a tool like DEM to add the Add-in load behaviour registry key.

0 Kudos
Hot Shot
Hot Shot

Installing office is not an option.  We have Office, Visio and Project and that would mean we would have to have four separate images and 4 different pools for people based upon what Office they get.  We just aren't going to do that.

Also, Jabber Outlook Integration actually works it just throws an error

Jabber_Integration_error.png

This only happens in 12.x version of Jabber.  11.x it works fine. The keys needed are there since it actually works, but it throws the error.

0 Kudos
Hot Shot
Hot Shot

So we found the solution.  There are two things that need to be done.  First you need to reboot the provisioning machine after install of Jabber and before finishing the provisioning or possibly creating the following registry key by hand:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Call Integration]

"IMApplication"="CiscoJabber.exe"

Next you also have to make sure you have these keys set/captured via DEM

[HKEY_CURRENT_USER\Software\IM Providers]

"DefaultIMApp"="Cisco Jabber"

[HKEY_CURRENT_USER\Software\IM Providers\Cisco Jabber]

"UpAndRunning"=dword:00000002