robsisk1972
Enthusiast
Enthusiast

Best way to upgrade from 2.18 to 4 2009?

Greetings all...Hope this finds you well.

I have been kicking around the idea of moving to App Volumes 4 2009 since I have a little bit of time right now?    Has anyone used this new "New coexistence capability" feature they have now described below to upgrade?

New coexistence capability:

Another highlight for App Volumes 4 is the fact that you can now run your 2.x implementations from the new App Volumes 4 admin console. This is called coexistence. You can upgrade to App Volumes 4 and start playing with the new features, while still managing your 2.x environment from a separate “tab” in the App Volumes Manager console. This means it is possible for you to migrate slowly and gradually, instead of conducting a major overhaul of the tool and admin workflows.

I was really planning to just build new servers and DB and do this on it's own but if this way works (As it Claims) this seems like a no brainer.

  1. So my question is does this upgrade work as planned?
  2. Has anyone tried upgrading and how did it go?
  3. If I just do the upgrade on my 2.18 server, will all of my 2.18 volumes still work until I can start creating in 4?

 

Thanks for the look....Any info here can help.

 

Resource:  What's New in VMware App Volumes 4 | VMware

 

 

 

 

 

 

0 Kudos
4 Replies
LarryBlanco2
Expert
Expert

The coexistence works as advertised.   I use it today.  Do upgrade to the latest appvols 2 and then do the appvols 4 upgrade in place.  

LarryBlanco2_0-1608068970674.png

Here is a tools that allows u to migrate your app stacks.

 

https://flings.vmware.com/app-volumes-migration-utility#instructions

 

Hope that helps.

 

PS.  as a precaution and as a rule of thumb.  Take snapshots and have backups..   One never knows.

 

 

 

 

Ray_handels
Virtuoso
Virtuoso

  1. So my question is does this upgrade work as planned?

As stated before, yes the upgrade works. Within the advanced setttings you toggle te use of version 2.x in Appvolumes. Do keep in mind that you have 2 tabs with appstacks and writables. They do cross exist but you need to have a 2.x and a 4.x appstack, every version has it's own appstacks.

  1. Has anyone tried upgrading and how did it go?

Yes, easy peasy lemon squeezie 🙂 

  1. If I just do the upgrade on my 2.18 server, will all of my 2.18 volumes still work until I can start creating in 4?

Yes but they only cooexist, use a 2.18 agent to get the 2.18 stacks and use the 4 agent to use the 4 appstacks.

praviview
Enthusiast
Enthusiast

Yeah you can upgrade directly from 2.18 to 2009, as per my experience its a smooth process. 

 

After you upgraded enabled the option in advanced tab for supporting 2.X version. later slowly you can upgrade your appstacks to 4.X

 

Point to remember - Capturing machines for 2.x application should have the 2.x AppVolume agents.

Praveen C
L3admins.com
Tags (1)
robsisk1972
Enthusiast
Enthusiast

Thanks all for sharing your experience.    Much appreciated.    Going to schedule my maintenance window soo.

0 Kudos