Suman1209
Enthusiast
Enthusiast

Appvolume 2.12.1 +office 2016 +visio+project -

Hi We are in a process of implementing Office 216 + Appstacks (2.12.1) , Installing the core office application in one appstack and project and visio on other appstack

when user logs in and lauches the projectc or visio , the office start the " Office configuration windows" Post that application work fine.

  • Would like to know is core office is suggest to put in the base (master Image)?
  • I have followed the ( Installing and using Microsoft Office Products with VMware App Volumes 2.x (2146035) | VMware KB ) to capture the Appstack.
  • Capture process is completed successfully with out any error and KMS Activation happens with out any issue.
  • We have notices some times when user logs in we see a "svoffice" pop up window.
  • We have notices if use only office appstack 2016 without visio or project works fine , with out  any error.
  • Users Starts to see the configuration windows as soon as visio and project appstacks are atached.

Does any one faced this issue and is there any solution for this. (We are uding the office 2016 Pro Plus ) and not office 365 2016.

Regards Sumanth VCP7-DTM7 , DCV , NV, VCAP7-DTM Design If you found my answers useful please consider marking them as Correct OR Helpful
35 Replies
jmatz135
Hot Shot
Hot Shot

Yes, we are.  Office 2016 licenses just fine if we use the Click-To-Run install.  It does not if you use the DVD.  Regardless it doesn't work with the dvd anyway.

0 Kudos
dimich34
Contributor
Contributor

I am receiving the same error message. Did anyone try to open a case with VMWare? We have our Office Click 2 Run in the base image as well and would like to use appstack for visio and project. is this supported?

0 Kudos
dimich34
Contributor
Contributor

The same error message as above

pastedImage_0.png

0 Kudos
Sravan_k
Expert
Expert

Umm..

It was interesting, I did same as you did and we don't have any issues...

one thing, please use parent image [which contain office and also keep/revert to clean snag as much as possible while doing packaging] as your packaging machine.

Regards.

dimich34
Contributor
Contributor

are you using C2R Office 365 version of office and it is part of the windows 10 image? I ran setup.exe /configure nameofthexml.xml file when i was provisioning MS project C2R version. Appvol reports  that Appstack is created however it messes up Office 365 entirely on the instant clone.

0 Kudos
Sravan_k
Expert
Expert

I am using office 2013 and planning to go office 2016, I am not sure on one click to run because it been so long that i worked on it

0 Kudos
jmatz135
Hot Shot
Hot Shot

You did what the same?  Here you say you did the same, but later you say you are using Office 2013 and not Click-To-Run.  That is definitely not the same.  In fact even the dvd option from the msdn site for office 2016 looks to just be a pre-packaged Click-to-Run package.

Oh, and yes I took the base image and captured the Visio install on that and then reverted snapshot.  This is what I always do.

0 Kudos
Skmr
Enthusiast
Enthusiast

I think Vkmr is saying that he worked on C2R in past but currently vkmr is working on office 2013 and planning to go office 2016.

but I am not familiar with C2R is it different from regular setup installation? if yes, I would try to reach Microsoft for setup file for office Smiley Happy

Thank you.  

Sravan_k
Expert
Expert

Hi jmatz,

I am sorry if my communication is confusing you.

Pkmr is correct, let me refresh, in past I used C2R on dedicated pools [are you using dedicated pool type?]

currently I am with office 2013 and planning to move office 2016, and you are not able to download setup.exe from MSDN? it was interesting even i have to figure it out with Microsoft for setup.exe [legacy installer].

Thank you

jmatz135
Hot Shot
Hot Shot

No we use floating pools.   There is a setup.exe but it isn't a standard msi package that Office used to be.  It is a click-to-run package which is built using different technology.  They are not the same.  And like I said I don't think you can actually download the msi package at all.  If you have an install package from when Office 2016 first came out you may still be able to get a setup.exe that uses msi installer technology, but I don't think you currently can.

0 Kudos
Sravan_k
Expert
Expert

Ohh, got you

have you reached Microsoft for setup.exe [legacy installer/ MSI]? this is a real problem because I saw some where saying we don't support multiple C2R in app volumes.

please reach Microsoft and get legacy installer 

Sravan_k
Expert
Expert

Hi Jmatz,

sorry it been a while, do you have any update on this issue?

I just went through all this thread conversation, please work with our VMware support if this is still a open issue

please let me know if you have any other questions

Regards,

Vkmr.

0 Kudos
jmatz135
Hot Shot
Hot Shot

As far as I can tell this will not work.  I've tried every different combination possible.  We will probably have to move to having Office within an appstack unless App Volumes actually fixes the issue.

0 Kudos
Ray_handels
Virtuoso
Virtuoso

2.13 is released and there is word of something being fixed in the Visio / Project / Office department.

Might be worth a shot??

Sravan_k
Expert
Expert

sorry to hear about moving office to app stack, have you tried reaching VMware support?

I installed my core office on parent image and used it as a packaging machine for project and Visio which was working fine for me again it is totally use case based, I agree with you. 

tombollig12
Contributor
Contributor

I have just struggled through this issue.

What makes it work and what breaks it....

What breaks it:

When you install office o365 with anther Product ---Visio or Project you are needing to accept more than one EULA. You will notice in the ODT config.xml it gives the option to set accept EULA to True. It seems this is ignored and the EULA continues to pop up.

What fixed it

A GPO to add registry keys that states when office registers to accept "EULAs"

I attached the policy config

So what I had was a base Appvolume server 2.13.1. Did not modify any writable volumes. Created a o365 appstack with vcr_redist 2013 and 2015 , Added GPO, logged into non-persist desktop and configured office, logged off , singed into a new desktop and no setup/EULA prompts

I hope this can help someone.