VMware Horizon Community
danielkrause
Enthusiast
Enthusiast
Jump to solution

App Volumes 4.0, 1909, VMware Horizon 4.12 and Ivanti UWM (Startmenu Missing when no AppStack Attached)

Hi Community,

we have under Windows 10 1909 the following issue if NO  AppStack is connected.

The Startmenu appears empty.

Environment

- Windows 10 - 1909 x64

- VMware Horizon 4.12

- Ivanti UWM (Former AppSense)

- App Volumes 4.0

Workaround:

The user needs to refresh explorer

Is there any exclusion, that we can do to avoid this issue?

Reply
0 Kudos
1 Solution

Accepted Solutions
danielkrause
Enthusiast
Enthusiast
Jump to solution

The flexengine.exe will not help in my case, because i cannot use it without a manager.

i found a good workaround.

It would be to restart the "StartmenuExperienceHost.exe".

This will refresh the startmenu.

CMD

taskkill /f /im StartMenuExperienceHost.exe

Powershell

Stop-Process -Name "StartMenuExperienceHost" -Force

The Full artikel:

https://www.tenforums.com/tutorials/133178-restart-start-menu-windows-10-a.html

Question:

Now i need to know, whats the right Postaction script, if no appstack is connected? Any ideas?

View solution in original post

Reply
0 Kudos
3 Replies
Ray_handels
Virtuoso
Virtuoso
Jump to solution

Ivanti and Appvolumes don't like eachother I'm afraid.

It also depends on what conditions you are setting on the shortcut creation. Does it check if the file actually exists and only then creates the shortcut? If so, try to not set that option and let it create the shortcut anyway.

Thing is that not all files are there when shortcuts are being created because Appvolumes wants logon time to be as short as possible, merging of the appstacks still happens when logging in. UEM/DEM (i hate rebranding Smiley Wink) has an option to check for an Allvolumesattached value and refreshes the startmenu automatically after that. If Ivanti has the same option that might be worth a try.

danielkrause
Enthusiast
Enthusiast
Jump to solution

mhm... not sure what you mean with shortcuts.

Interesting if an appvolume is connected everything is good but users without App Volumes but Agent installed run into this problem.

I will install DEM also and look if there is a refresh afterwards.

Or do you know the command i can run after App Volume Login Process finish to set an DEM refresh?

Reply
0 Kudos
danielkrause
Enthusiast
Enthusiast
Jump to solution

The flexengine.exe will not help in my case, because i cannot use it without a manager.

i found a good workaround.

It would be to restart the "StartmenuExperienceHost.exe".

This will refresh the startmenu.

CMD

taskkill /f /im StartMenuExperienceHost.exe

Powershell

Stop-Process -Name "StartMenuExperienceHost" -Force

The Full artikel:

https://www.tenforums.com/tutorials/133178-restart-start-menu-windows-10-a.html

Question:

Now i need to know, whats the right Postaction script, if no appstack is connected? Any ideas?

Reply
0 Kudos