JHT_Seattle
Hot Shot
Hot Shot

App Stack (Toad for Oracle) causes VM to black screen and disconnect?

Jump to solution

When we assign our Toad for Oracle (12.6.0.53) stack the user will get see the VM connected, but before getting to the desktop will get a black screen and disconnect.

Now, if unassigned, the user can log in just fine.  When we assign the stack, apply immediately, the app shows up and works completely fine.  So the app itself is not a problem, but something is happening when trying to attach it that is.  How do I investigate what is happening?

0 Kudos
1 Solution

Accepted Solutions
JHT_Seattle
Hot Shot
Hot Shot

So I temporarily set up a 2.5.0 environment and recreated the Toad for Oracle stack with the 2.5.0 template.  Lo and behold, it works!  I imported the stack into my 2.5.2 environment and it attaches at user logon without any disconnect issues.  I think this note made it into the SR as well.

View solution in original post

0 Kudos
5 Replies
JHT_Seattle
Hot Shot
Hot Shot

One further bit of information - this stack was built on template 2.5.1.  I *did* have this app working with no issues, but it would have been with template 2.5.0.  I'm going to re-upload that template (slightly renamed so as to not overwrite the newer one) and try again.

0 Kudos
JHT_Seattle
Hot Shot
Hot Shot

As it turns out, I guess you can't have multiple versions of the apps_template uploaded to the manager.  I can see where the vmdk files exist on the manager, I just can't seem to figure out how to get from the .vhd file included with the 2.5.0 iso to another .vmdk file.  Even if I could, I'm not sure the Manager would "see" it, anyways.

So it looks like I can only ever move forward with templates, not back, nor have multiple versions.  I know it sounds crazy to think that a newer version would work any worse than the old one in this case, but it's the only thing I could think of.  Your move, devs.

0 Kudos
Jason_Marshall
VMware Employee
VMware Employee

Not entirely true. you can rename it and it will show you the different templates in the default storage location but yes only one of the same name, can't change file naming physics, yet Smiley Happy. You can also create your own....Smiley Wink

0 Kudos
JHT_Seattle
Hot Shot
Hot Shot

Is there any documentation that'll help me get the template from 2.5.0 into my 2.5.2 manager?  I'd still like to try with the older template just to rule it out, but I'm not sure how to get from A to B.

0 Kudos
JHT_Seattle
Hot Shot
Hot Shot

So I temporarily set up a 2.5.0 environment and recreated the Toad for Oracle stack with the 2.5.0 template.  Lo and behold, it works!  I imported the stack into my 2.5.2 environment and it attaches at user logon without any disconnect issues.  I think this note made it into the SR as well.

0 Kudos