network-down

Some time it happens that NIC is not coming up automatically if it flap multiple times on ESXi . For example during the code upgrade of network switches which generally up and down the link connection more than three times. Some NIC card status not come up in these situations as ESXi mark them disabled due to multiple flaps.

And even The esxcli network nic down/up commands fail to restart a NIC.

Errors that will be reported in the vmkernel.log file:

2013-10-23T05:41:42.588Z cpu36:10220)Uplink: 8603: Setting link down on physical adapter vmnic7.

2013-10-23T05:41:42.588Z cpu36:10220)Uplink: 8634: Requested link speed/duplex 0x9c4/0x2 is not valid.

Solution

Login to the ESXi via SSH & Use these commands only with the network cards running auto negotiation 10Mb /100Mb /1000Mb/10000Mb speeds.

  • To change the link state of the physical interface to down:esxcli network nic down -n vmnicX

 

  • To auto-negotiate the speed of an adapter:esxcli network nic set -n vmnicX -a
  • To change the link state of the physical interface to up:esxcli network nic up -n vmnicX

While Doing this in the above mentioned sequence the NIC Link will come UP.

 

Harjit Singh

vmwars.wordpress.com