5 Replies Latest reply on Apr 8, 2008 6:28 AM by MikeAT
      • 1. Re: New HP Managment Agents: hpmgmt-8.0.0
        vmroyale Guru

        I have installed the 8.0.0 agents on a BL20p G4 running ESX 3.5 - So far so good.  This box was for a test setup, and didn't have a HBA installed.  Therefore, I can't really speak to the Emulex and Qlogic libraries being split out in this version.

        • 2. Re: New HP Managment Agents: hpmgmt-8.0.0
          KazO Novice

           

          The newest SMH (2.1.11.197) is included with the 8.0.0 agents.

           

           

          I do, however, want to add a caution.  This applies to folks who upgraded to 3.5 from 3.0.x, but left an earlier (7.7 or before, I'm guessing; mine was 7.6) version of hpmgmt, and are now looking to upgrade to 8.0.

           

           

          Do not use the old "installvmnnn.sh --uninstall" to uninstall the old version.  Use "installvm800.sh --uninstall" instead.

           

           

          First, running the old script should error with "Installer does not support the VMWare ESX Server version." It's been sugested elsewhere (such as http://communities.vmware.com/message/842003 and also at HP's support forums) to modify the script to add the new version to the SUPPORTED_VERSIONS line.  This will uninstall the old version.  However, the older versions of the agents (the ones that support 2.5.x and 3.0.x) do another level of checks that (un)installs other packages in 2.5.x that 3.0.x already include.  The affected package is "expat."  If SUPPORTED_VERSIONS is the only line edited, "expat" will get uninstalled, and your ESX installation will be broken.  The first sign I saw was when I attempted to install 8.0.0 immediately after removing 7.6.0, esxcfg-firewall failed while the install tried making firewall changes, stating "libexpat.so.0: cannot open shared object file"

           

           

          Being a linux/shell script noob, I rebooted the host and was greeted with lots of the above error.  EPIC FAIL, as the kids say.

           

           

          After a little help from a coworker, I used the --uninstall from 8.0.0 to remove 7.6.0 first, and was successfully able to then install 8.0.0 on, so far, 4 other similarly upgraded hosts.

           

           

          Be careful out there!

           

           

          Kazuto Okayasu

          Administrative Computing Services

          University of California, Irvine

           

           

          • 3. Re: New HP Managment Agents: hpmgmt-8.0.0
            JRink Hot Shot

            I've been running 8.0 agents on my ESX 3.5 host now for 2 weeks without issue.  So far so good.

            • 4. Re: New HP Managment Agents: hpmgmt-8.0.0
              Jae Ellers Master

               

              Anyone tested their nic link failure reporting:

               

               

              http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1218259

               

               

              -=-=-=-=-=-=-=-=-=-=-=-=-=-=-

              http://blog.mr-vm.com/

              http://www.vmprofessional.com/

              -=-=-=-=-=-=-=-=-=-=-=-=-=-=-

               

               

              • 5. Re: New HP Managment Agents: hpmgmt-8.0.0
                MikeAT Novice

                Hi!

                 

                We have problems with the HBAs and the lib files which aren't included anymore. The Qlogic work fine with the procedure in the readme of the HP SIM Agent but the Emulex doesnt - see my other post.

                http://communities.vmware.com/message/908784

                 

                Michael