1 4 5 6 7 8 Previous Next 342 Replies Latest reply on Jun 2, 2009 3:35 PM by AlbertChurba Go to original post
      • 75. Re: SATA Support Clear as Mud!?
        rpartmann Expert

        Hi Dave,

         

        hiace   (here is a controller entry)      

        Promise  SATA300 TX4 (pci 32bit)  works like a charm.

         

        kind regards,

        Reinhard

         

        ps: Award points if you find answers helpful. Thanks.

        • 76. Re: SATA Support Clear as Mud!?
          excelsi Novice

           

          Hello mpxipix,

           

           

          unfortunatly your workarround to get the script working doens't work with me.

           

           

          The workarrund for itself works. But when i execute the script for the ml115 (which i have) the same errors like "command not found" or "directory not found" come up again.

           

           

          Its strange because other people with the same hardware say that it works.

           

           

           

           

           

          I hope that somebody knows what I can try anymore...

           

           

           

           

           

          Regards

           

           

          • 77. Re: SATA Support Clear as Mud!?
            rpartmann Expert

            Hi,

            boot your server in the troubleshoting mode. Transfer the file to your ESX box and run it.

            I tested it and hopefully it works also for you. (but i assume the is always one more bug )

             

            hth

            reinhard.

             

             

             

            ps: Award points if you find answers helpful. Thanks.

            • 78. Re: SATA Support Clear as Mud!?
              jims_tx Lurker

               

              Hm, I'm not positive, but I was looking through the script and it seems that "umount $BOOT_PREFIX" and "umount $ROOT_PREFIX" are commented out. So I was hesitant to run it because as written, the script may wipe your ESX install ... I'll leave it to someone else to verify

               

               

              • 79. Re: SATA Support Clear as Mud!?
                rpartmann Expert

                Hi,

                 

                to which version to you refer?

                You probably may be right..  commented in the unmout code back.

                But when you run the scrip from the

                troubleshooting mode it should be no problem. (as that was the inteded use!)

                 

                But when youre are runing from a live cd, this

                might happen. Didn´t test that way recently.

                 

                thanks

                reinhard.

                 

                 

                >Reinhard Partmann,

                >A new message was posted in the thread "SATA Support Clear as Mud!?":

                >http://communities.vmware.com/message/861480

                >Author  : jims_tx

                >Profile : http://communities.vmware.com/people/jims_tx

                >Message:

                • 80. Re: SATA Support Clear as Mud!?
                  rpartmann Expert

                  Hi,

                   

                  many thanks for the hint!

                   

                  Tried it and yes you were right. Cleaned up my / and /boot.

                   

                  Commented out these two lines (rm -r -f ...) so you have to delete these subdirs manually, leave them or change the script.

                  Fortunately i have kickstart in place for my devel server, so if it crashes it does no harm...

                   

                  thanks again,

                  Reinhard.

                   

                   

                  ps: Award points if you find answers helpful. Thanks.

                  • 81. Re: SATA Support Clear as Mud!?
                    rpartmann Expert

                    Forgot to attach the new version (0.6).

                     

                    reinhard.

                     

                     

                    ps: Award points if you find answers helpful. Thanks.

                    • 82. Re: SATA Support Clear as Mud!?
                      jims_tx Lurker

                       

                      I have the ASUS P5BV-E / SAS motherboard, which as anyone who has read up on SAS/SATA support knows, works great with VMware ESX v3.5. But, what has me scratching my head is that 3.5 installs, allows me to create a VMFS and deploy VMs even though I only have 1 SATA drive connected to the ICH7R controller (I'm not even using the SAS controller!). In the dmesg output below, you can see that the SAS controller is scsi5 and has no devices attached. While scsi4 is my AHCI Intel controller with a lone disk attached. Am I the only one that did not expect this to work? Does this mean that any ICH7R board w/ a support NIC will run ESX? That would let you pick up $80 motherboards and run ESX.

                       

                       

                      scsi4 : ahci

                        Vendor: ATA       Model: ST380013AS        Rev: 3.43

                        Type:   Direct-Access                      ANSI SCSI revision: 05

                      VMWARE SCSI Id: Supported VPD pages for sda : 0x0 0x80 0x83

                      VMWARE SCSI Id: Device id info for sda: 0x2 0x0 0x0 0x18 0x4c 0x69 0x6e 0x75 0x7

                      8 0x20 0x41 0x54 0x41 0x2d 0x53 0x43 0x53 0x49 0x20 0x73 0x69 0x6d 0x75 0x6c 0x6

                      1 0x74 0x6f 0x72

                      VMWARE SCSI Id: Id for sda 0x20 0x20 0x20 0x20 0x20 0x20 0x20 0x20 0x20 0x20 0x2

                      0 0x20 0x34 0x4d 0x52 0x31 0x5a 0x41 0x37 0x42 0x53 0x54 0x33 0x38 0x30 0x30

                      VMWARE: Unique Device attached as scsi disk sda at scsi4, channel 0, id 0, lun 0

                      Attached scsi disk sda at scsi4, channel 0, id 0, lun 0

                      SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)

                      sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 >

                      scsi5 : mptscsi_2xx

                       

                       

                      • 83. Re: SATA Support Clear as Mud!?
                        rpartmann Expert

                        Basically you are right. But i´n not 100% sure if any ICH7 controller will work correctly.

                         

                         

                         

                        Your SAS controller is detected an driven by the driver mptscsi_2xx.

                        Your SATA controller is driven by ata_piix and these drives are recognized as /dev/sd[a|b|c|d].

                        So your SATA drive is being seen as an SCSI device.

                         

                        And you can only  format SCSI disks and SAN LUNS with VMFS.

                        here we go.....

                         

                         

                        hth,

                        Reinhard.

                         

                        (can´t let you scatch you head until it bleeds.... )

                         

                         

                         

                         

                        ps: Award points if you find answers helpful. Thanks.

                        • 84. Re: SATA Support Clear as Mud!?
                          DArndt Enthusiast

                           

                          Jaap,

                           

                           

                          I am running a Sun Ultra 40 M2, but I was not able to get it working with the onboard sata controllers.  I also have a LSI1068E as my SAS/SATA controller which is a VMware supported controller.  I have tried it with both SAS and SATA disks and it works fine.  The LSI1068E also works in raid mode, although only supports raid 0,1 and 10.

                           

                           

                          Two things to keep in mind with the Ultra 40, one there is a multimedia timer setting in the bios that must be disabled for VMware to work.  Secondly if you are running with multi processors using both sockets, you will either need to have the same amount of memory on both sockets, or turn on memory interleaving to disable NUMA.  If you are only using one socket then it won't matter, but with both sockets you will need that set.

                           

                           

                          Dave

                           

                           

                           

                           

                           

                          • 85. Re: SATA Support Clear as Mud!?
                            oluvido Lurker

                             

                            Hello All,

                             

                             

                            I have read all these post with interest and I must first say that even though i'm a specialist in Windows, I'm a newbie in Linux. I have a Dell Inspiron 531. As usual, the installation of ESX 3.5 works but the get the Mounting root error. I have tried using the script from a ubumtu live CD but it does not seem to work as it complains about a patrticular line. I will preferr to run it in the troubleshooting mode but would like to know how to navigate to the USB drive, copy it to the ESX installation and then run the script. Can you also please confirm that the gosata.sh version 0.6 will work for me?

                             

                             

                            I believe my controller is the NVIDIA MCP61 Sata controller. Can you please help as I bought this machine some weeks back for this ESX and haven't been able to use it since. Incidentally, I have a Dell Dimension E521 which works without any problem but I would rather use the new Inspiron which is dual core with 5600 processor.

                             

                             

                            Thanks in advance,

                             

                             

                            Vido.

                             

                             

                             

                             

                             

                             

                             

                             

                             

                             

                             

                             

                             

                             

                            • 86. Re: SATA Support Clear as Mud!?
                              jaapr Lurker

                               

                              Hi Dave,

                               

                               

                              Thanks for the reply. I gave up on the U40M2 and indeed ordered the SAS controller (which did not arrive yet). I will keep your other suggestions in mind.

                               

                               

                              I also tried Ultra20M2 and it had the same "mount of root failed" problem. On this box the fix worked: boot in service console mode, changed sata_nv.xml and run esxcfg-pciid.

                               

                               

                              Thanks,

                               

                               

                              Jaap

                               

                               

                              • 87. Re: SATA Support Clear as Mud!?
                                blackforce Novice

                                 

                                I ran your last script posted on my ML115. Had to put a larger disk in.

                                 

                                 

                                I boot into troubleshooting mode and then copy it across using winscp. However this is what happens

                                 

                                 

                                ./gosata.sh

                                 

                                 

                                SATA BootFix for VMware ESX Server by Reinhard Partmann

                                check ifrunning on an ESX host :

                                isESX: 1

                                isESXfailsafe: 1

                                DEBUG: BOOT_MOUNTED 1

                                DEBUG: 1==BOOT_MOUNTED 1

                                 

                                 

                                Thats it.

                                 

                                 

                                Can anyone help?

                                 

                                 

                                • 88. Re: SATA Support Clear as Mud!?
                                  rpartmann Expert

                                  Hi blackforce,

                                  use v0.61. (bug fixed)

                                     

                                   

                                   

                                  hth Reinhard.

                                   

                                   

                                   

                                   

                                  ps: Award points if you find answers helpful. Thanks.

                                  • 89. Re: SATA Support Clear as Mud!?
                                    blackforce Novice

                                    already have worked a treat. Cheers

                                    1 4 5 6 7 8 Previous Next