4 Replies Latest reply on Dec 26, 2007 2:24 AM by hvdkooij

    fedora 8 wont start vm server, I'm stumped

    phingers Novice

      I'm new to VM Server, so I apologize if it is an easy one. I have the latest beta release of vmware downloaded and installed and configured on my machine.


      /sbin/service vmware restart



      Shows everything starts up, all come back as OK nice and green.



      If I then go to http://localhost:8222/ and login with root, it takes a VERY long time and comes back with the message of: "Web service not available"



      If I type "vmware-server-console &" on the command line, it brings up the vmware server console window, I then choose localhost, it says "The local VMware Server is not installed, or is not currently running. Make sure that the server is properly installed and try again."



      The server-console command does report a few errors when starting: libpng12.so.0: no version information available (required by /usr/lib/libgdk_pixbuf-2.0.so.0) and ~ (required by libcairo.so.2)



      So I'm at a loss, is there something else that needs to be started?



      Any help is appreciated.



        • 1. Re: fedora 8 wont start vm server, I'm stumped

          The old (a.k.a. Server 1.0) console is not supported in Server 2.0. It won't work, and you can't connect it to a Server 2.0 instance.


          The problem you're experiencing is likely because vmware-hostd (the "VMware Host Agent") failed to start up on the machine. It would be helpful if you could post the content of /var/log/vmware/hostd.log.


          Also, you should note that Fedora 8 is an unsupported host.

          • 2. Re: fedora 8 wont start vm server, I'm stumped
            phingers Novice

            thanks, I've uninstalled the beta version, and installed 1.0, once I added the any any update from the internet, all worked well.

            • 3. Re: fedora 8 wont start vm server, I'm stumped
              WolfC Enthusiast

              It's because of hangup in PAM somewhere.


              When I check the process list there is a unix_chkpwd which is defunct. It has been started by vmware-hostd.




              If you change /etc/pam.d/vmware-authd to use pam_permit.so (instead of pam_unix.so) you can get into the console.  Without a passwd, check pam_permit manual page!




              So do 'Aaah' and 'Oooh' and change it back.




              When I test the vmware-authd pam setting in a simple program they appear to work. My guess is that some setting is causing vmware-hostd to become unable to detect the death of unix_chkpwd, thus won't read it's exit status and hangs around a bit.

              1 person found this helpful
              • 4. Re: fedora 8 wont start vm server, I'm stumped
                hvdkooij Novice


                One should not run virtual machines as root. Just login as a normal user and then create your virtual machines.



                If you did allready create virtual machines as root then go to the directory containing the virtual machines (aka: /var/lib/vmware/Virtual Machines/). Check with `ls -la` who owns the virtual machines. If they are owned by root you need to become root temporarely. (You did not login as root untill now, did you?)



                Then change ownership of the directory and included files to your normal user account. In my case I would have to do this in the directory of the virtual machines with `chown -R hvdkooij:hvdkooij *`.



                Now I can do everything as my normal user 'hvdkooij' and I have reduced the risk of my machine taken over by a fault in vmware.



                If one runs a system one should learn not to work with admin priviliges untill you actually need them. This holds true for each and every operating system.