8 Replies Latest reply on May 31, 2007 4:03 AM by feklee

    "sleep 1" takes up to about 15 seconds!

    feklee Novice

      Problem: When I execute "sleep 1" in the guest, then it takes roughly between 8 and 15 seconds to execute.  Also, time in general runs slowly, but it's not too far off the mark, probably thanks to time synchronization done by VMware tools.

       

      What I tried:

       

      I updated "/etc/vmware/config" according to the knowledge base article 1591.  Before making the changes, I shut down the virtual machine.  Afterwards, I restarted the vmware infrastructure (/etc/rc.d/rc.vmware stop, then start), and I started the guest.  However: "sleep 1" takes still awfully long.

       

      In addition to using the updated "/etc/vmware/config" I fixed processor speed in the host (scaling_governor = performance).  Again: No improvements, or only minor improvements (the last time I gauged it, "sleep 1" took 8 seconds).

       

      Host:

       

        Slackware Linux 10.2

        Kernel 2.6.16.5 (vanilla)

        VMware Player 1.0.3

        CPU: Pentium M 750 1.86GHz

       

        The updated "/etc/vmware/config":

       

          control.fullpath = "/usr/bin/vmware-cmd"

          loop.fullpath = "/usr/bin/vmware-loop"

          dhcpd.fullpath = "/usr/bin/vmnet-dhcpd"

          libdir = "/usr/lib/vmware"

          vmware.fullpath = "/usr/bin/vmware"

          vmplayer.searchbar = "FALSE"

          vmnet1.hostonlyaddress = "192.168.1.1"

          vmnet1.hostonlynetmask = "255.255.255.0"

          host.cpukHz = 1866000

          host.noTSC = TRUE

          ptsc.noTSC = TRUE

       

      Guest:

       

        SUSE Linux 8.2

        Kernel 2.4.20-4GB

        VMware tools installed

        Time synchronization is enabled

       

      So, what can I do?  Any suggestions?  Is the problem unique to VMware Player, i.e. do you expect it to also happen with VMware Workstation (which would be overkill for the given usage scenario)?

        • 1. Re: "sleep 1" takes up to about 15 seconds!
          feklee Novice

          Problem: When I execute "sleep 1" in the guest, then

          it takes roughly between 8 and 15 seconds to execute.

           

          I just tried out the Browsing Appliance provided by VMware: Same problem ("sleep 1" took between 2 to 4 seconds).   It happened with the CPU in fixed speed mode (scaling governor: performance) and in variable speed mode (scaling governor: on demand).  Of course, after changing the scaling governor, I started the virtual machine anew, i.e. I did not resume it.

           

          Any idea what may be the cause?

           

          Also: Is it possible to get commercial support for VMware Player?  I'd really like to get this problem solved.

          • 2. Re: "sleep 1" takes up to about 15 seconds!
            feklee Novice

            Guest:

             

              SUSE Linux 8.2

              Kernel 2.4.20-4GB

              VMware tools installed

              Time synchronization is enabled

             

            I now copied that virtual machine to a host with the following specifications:

             

            Slackware Linux 10.2

            Kernel 2.6.14.4

            VMware Player 1.0.3

            CPU: Pentium M 705 1.6GHz

             

            On this host, the virtual machine ran fine.  I was \*not* experiencing any time dilation in the virtual machine: "sleep 10" really took 10 seconds.

             

            Now, what could be the reason for the time dilation of the virtual machines running on the original host?  Could the CPU be the source of the trouble, or could it be the kernel?  How do I find out which component of the host is to blame?

            • 3. Re: "sleep 1" takes up to about 15 seconds!
              KevinG Guru

              On your Linux host, look for a system daemon or applet called cpufreqd, cpuspeed, powernowd, cpudyn, speedy, or cpufreq, and disable it.

               

              You may also what to look look any power management in your BIOS and make sure that it is disbaled. (Like SpeedStep)

              • 4. Re: "sleep 1" takes up to about 15 seconds!
                feklee Novice

                On your Linux host, look for a system daemon or

                applet called cpufreqd, cpuspeed, powernowd, cpudyn,

                speedy, or cpufreq, and disable it.

                 

                There is no such tool.  The host is running with kernel 2.6.16.5 which has frequency scaling built in.  But - as said before - even if I disable frequency scaling, then the timing problem in the guest does persist.

                 

                You may also what to look look any power management

                in your BIOS and make sure that it is disbaled. (Like

                SpeedStep)

                 

                There are various power management settings in the BIOS but they're not relevant since the host OS is using ACPI, not APM.

                 

                Any more ideas what to do or where to get (professional) support?

                • 5. Re: "sleep 1" takes up to about 15 seconds!
                  mazed Novice

                  I have problem like these too.

                   

                  My hardware is HP Blade with 2 Dual Opteron 280 64bit.

                   

                  Host OS is Scientific Linux x86_64, that is like Centos, a "recompilation" of RHEL.

                   

                  Guest is the same.

                   

                  The clock is MAD!

                   

                  If I try a simple bash like "while date; do sleep .5; done" on 4 VM one goes slow, one fast, one right... and randomly stops at all until i press a key on the keyboard.

                   

                  The guest has 1 cpu assigned, if I try to assign 2 the OS locks at kernel boot.

                   

                  Also tried (on the guest) with clock=pit notsc noapic nolapic nosmp, recompiled the kernel with HZ 100, disabled cpuspeed... in all possible combinations.

                   

                  On the Host tried to change /proc/sys/dev/rtc/max-user-freq to 1000, 1024, 2000... stopped cpuspeed acpid...

                   

                  The behavior is always the same: IT DOESN'T WORK AT ALL \!!!

                   

                  So, it is possible that VMware is a hoax?!?!?!?

                  • 6. Re: "sleep 1" takes up to about 15 seconds!
                    RDPetruska Guru
                    User ModeratorsvExpert

                    >So, it is possible that VMware is a hoax?!?!?!?

                    Well, I can tell you that all VMware products which I have ever tried have worked \*flawlessly* on every single computer I have ever tried them on.  I can also tell you this --> I only use Windows-based hosts, all of them on the supported OS list; and I only use Intel CPU boxes - none of that knock-off cheap AMD crap.  If you stick with known, proven hardware, and an OS which is supported, all will work smoothly.  If you choose to run an unsupported OS and cheap out on the hardware, then you are on your own.

                    Just my 2¢.

                    • 7. Re: "sleep 1" takes up to about 15 seconds!
                      mazed Novice

                      VMware should be a virtualization software and should run the OS as physical, this is what they sell.

                       

                      AMD is not cheap, if you have experience in Hight Performance Computing (I work in Scientific Research area) you should know that before Intel Dual Core Xeon, AMD was the lowest in consumption and the highest in pure computing performance.

                       

                      About "supported OS"... what could make difference for VMware is the kernel.

                      Scientific Linux kernel is EXACTLY the same as RHEL, also EMC considered supported that kernel!!!

                       

                      So, NO WAY! VMware has some problem derived by the fact that a single computer was not designed to be more of one, they can try... but...

                       

                      I will try with the new Intel VT, but remains the feeling that we can't trust if in VERY production environment.

                       

                      I'm waiting for a VMware reply.

                      • 8. Re: "sleep 1" takes up to about 15 seconds!
                        feklee Novice

                        Unfortunately, the problem persists with VMware Player 2.0 as can be seen when executing "sleep 1" which runs for many seconds.  I wonder whether VMware Player will ever be usable on certain Intel Centrino platform CPUs.  Should we try VMware Workstation (would be quite cumbersome)?