1 2 3 4 5 6 Previous Next 118 Replies Latest reply on Nov 19, 2011 8:09 AM by !Real Go to original post
      • 45. Re: ESVA 1.6
        Ken.Cline Champion

        Same here.  I have tried changing permissions on the

        lock file to 777 and still no good.  Not sure why it

        says it can't access that lock file.

         

        If I were to hazzard a guess, I'd say it's becaues postgrey is running. Try stopping/killing postgrey and the lock file should be modifiable

        • 46. Re: ESVA 1.6
          bchau1 Lurker

          Hmm. tried the manual process to start postgrey and got the same error too.

           

          Binding to TCP port 60000 on host localhost

          Setting gid to "99 99"

          Setting uid to "95"

          ERROR: can't open lock file: /var/spool/postfix/postgrey/postgrey.lock

           

          Thanks in advance for all the help again.

          • 47. Re: ESVA 1.6
            rooter_c Novice

            Got it going, excuse my Linux ignorance if this is all wrong, I changed the postgrey service to start up as root by adding it as an option

             

            I used webmin interface  System....Bootup and Shutdown.....postgrey.

             

            .

            .

            prog=postgrey

            postgrey=/usr/sbin/$prog

            DBPATH=/var/spool/postfix/postgrey

            SOCKET=$DBPATH/socket

            OPTIONS="--inet=127.0.0.1:60000 --user root"

            .

            .

             

            and it starts the service ok.  Something to do with permissions.

            • 48. Re: ESVA 1.6
              bchau1 Lurker

              Hi got it working with running postgrey as user root.  Thanks rooter_c for the suggestion!

              • 49. Re: ESVA 1.6
                bchau1 Lurker

                Also, not sure why this is occuring but my incoming emails get the mailscanner headers appended in the content of the message.  How do I not have it appended here.  Here's a snippet of what gets appended:

                 

                X-dimension web-MailScanner-ESVA-Information: Please contact the ISP for more information X-dimension web-MailScanner-ESVA: Found to be clean

                X-Spam-Status: No

                 

                 

                This is in the body of the message at the beginning of incoming emails.

                 

                Thanks again!

                • 50. Re: ESVA 1.6
                  LogIQ Novice

                  Ok, thx!

                   

                  I will follow your development closely, you are man!

                   

                  Also I have a suggestion, although I have no idea how to accomplish it. It would be great if you could publish a patch or an upgrade for easy upgrade of existing users.

                   

                  I have another issue also, may be a bug...

                   

                  When releasing a message with MailWatch, it is possible to report to Pyzor and Razor network, but I get the following error:

                  SpamAssassin: \[10419] warn: reporter: pyzor report failed: reporter: exited with non-zero exit code 1, \[10419] warn: reporter: razor2 report failed: No such file or directory report requires authentication

                   

                  \- Ulrich

                  • 51. Re: ESVA 1.6
                    andy.mac Hot Shot

                    I can't be sure, but I think you need to register your ESVA VM with Razor etc. I will make a note and try to get some procedure together at some stage - I am super busy at the moment...

                     

                    -Andy

                    • 52. Re: ESVA 1.6
                      andy.mac Hot Shot

                      Ouch... Not keen on running as root...

                       

                      One other thing that I did to get it working on the gold VM was:

                       

                      chown postgrey:nobody /var/spool/postfix/postgrey/postgrey.lock

                       

                      then set the user back to postgrey

                       

                      You could also try deleting the lockfile and restarting postgrey... Let me know how you get on - it could save me some bandwidth from re-downloads...

                       

                      Andy

                       

                      Message was edited by:

                              andy.mac

                      • 53. Re: ESVA 1.6
                        griff158 Novice

                        Andy,

                         

                        the root solution worked for me to, but i  share your concern.

                         

                        chown postgrey:nobody of the postgrey.lock didn't resolve the issue alse deleting postgery.lock didn't resolve it.

                         

                        Have you got any more thoughts?

                        • 54. Re: ESVA 1.6
                          LogIQ Novice

                          I share griff158's experience

                           

                          \- Ulrich

                          • 55. Re: ESVA 1.6
                            andy.mac Hot Shot

                            OK - Then the sensible solution is to re-download. The new version on the website is working - I set all the permissions to the same as 1.5 and it all starts up OK as service as well as interactively.

                             

                            Sorry if a re-download is a hassle...

                             

                            The new version should be 1.6.4.6 and should display this on the console when it boots as well as the VM name being set to this.

                             

                            I'll update the website tonight to reflect the change and to explain the problem (permissions).

                             

                            -Andy

                             

                            Message was edited by:

                                    andy.mac

                            • 56. Re: ESVA 1.6
                              robert.perry Lurker

                              Andy,

                              This product is awesome.  I have downloaded the new build and it works as expected.  I have a question about outbound traffic from the ESVA system.  I have it installed behind a firewall that is blocking all traffic, unless explicitly allowed.  This said, can you tell me ALL the ports that will need to be allowed, and what they are used for?  I have yet to configure the outbound email, but assume that will only need smtp allowed.  I have internal DNS servers for name resolution. 

                               

                              Once again.  Great job on this project.

                               

                              bob

                              • 57. Re: ESVA 1.6
                                llastr1 Lurker

                                Andy,

                                 

                                Great job on this!!  I love the new mailwatch features.  This is a great product!!  I am downloading the latest build I was just wondering if anyone could tell me how to export/import settings to go from one build to the next.  My linux knowledge is very limited so any help is greatly appreciated.

                                 

                                Lee

                                • 58. Re: ESVA 1.6
                                  LogIQ Novice

                                  I would like to know that too...

                                   

                                  I know that I need the MailScanner and the Postfix configuration files, and also the rules folder and the mapping file.

                                  Actually I think you could just copy the entire MailScanner and Postfix folders which are in /etc/ and then replace those in the new installation, is that correct?

                                   

                                  But what about the Mailwatch configuration, that is stored in a database somewhere, how to export/import that.

                                   

                                  \- Ulrich

                                  • 59. Re: ESVA 1.6
                                    llastr1 Lurker

                                    Ulrich

                                     

                                    What is the easiest way to get those files out of there and import them to the new setup?  Im a real Linux newbie so if you can give me some specific step by step instructions I would really appreciate it.

                                     

                                    Thanks

                                     

                                    Lee

                                    1 2 3 4 5 6 Previous Next