9 Replies Latest reply on Nov 24, 2005 5:48 AM by moenster

    Cisco switch port config - 802.3ad teaming?

    moenster Master
    VMware Employees

      Hi

       

      I'm not a networking guy, and I need to provide the networking dep. with info on how to configure two switch ports for 802.3ad teaming, Etherchannel, LACP or what ever the most appropriate description is.

       

      I have this information from the switch:

      sh ver

      Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(25)SEB1[/i]

       

      I've been searching the forum and found a bunch of information, but I do not have enough knowledge on switch configuration to pin point the right solution.

       

      Can someone post their port configurations here?

       

      Thanks.

      Regards Henrik

        • 1. Re: Cisco switch port config - 802.3ad teaming?
          MR-T Champion

          Read the next post, doubled up.

          • 3. Re: Cisco switch port config - 802.3ad teaming?
            moenster Master
            VMware Employees

            Hi

             

            Thanks, but I've already been through thid document, and it doesn't really provide any detailed information about how to configure the switch.

             

            The problem is that the switchports can be configured in a bunch of ways (pagp, lacp, etherchannel - on, off, active, passive, dst-ip, src-dst-ip and so on.....). What happens, is that the switchports goes into suspended mode, as if they are unable to see the coherrence between the nics in the bond.

             

            Regards Henrik

            • 4. Re: Cisco switch port config - 802.3ad teaming?
              MR-T Champion

              So are you looking for Cisco specific documentation?

              • 5. Re: Cisco switch port config - 802.3ad teaming?
                moenster Master
                VMware Employees

                I'm looking for information on how to configure a Cisco switch to work with ESX server - what needs to be set to work with ESX server bonds.

                 

                So if some one are using out-ip LB with ESX server, I would like to see the port configuration on the switch.

                 

                Regards Henrik

                • 6. Re: Cisco switch port config - 802.3ad teaming?
                  MR-T Champion

                  OK, I'm not a Cisco expert, but once I'm in the office, I'll speak with our network guys and feedback what they say.

                  • 7. Re: Cisco switch port config - 802.3ad teaming?
                    moenster Master
                    VMware Employees

                    That sound very good! ;o)

                     

                    By the way, what is your opinion on using out-ip instead of out-mac when using gigabit connections, that are not at all fully utilised just using onr connection? I'm thinking about the CPU penalty you get when using out-ip, and if out-mac should be used, when all we really need is fail over.

                     

                    I still would be happy to know the correct configuration ;o)

                     

                    Regards Henrik

                    • 8. Re: Cisco switch port config - 802.3ad teaming?
                      MR-T Champion

                      Personally I just use out-mac with all the bonds in my servers.

                       

                      I don't need any closer management.

                       

                      It works really well and I have the fault tollerance,

                      • 9. Re: Cisco switch port config - 802.3ad teaming?
                        moenster Master
                        VMware Employees

                        Hi

                         

                        My networking guy fixed it by reading some threads from this forum. Obviously he got more out of it, than I did ;o)

                         

                        Regards Henrik

                         

                        Here's the setup he configured:

                         

                         

                        !

                        port-channel load-balance dst-ip

                        !

                        interface Port-channel1

                        switchport access vlan 55

                        switchport mode access

                        !

                        !

                        interface GigabitEthernet1/0/17

                        switchport access vlan 55

                        switchport mode access

                        duplex full

                        speed 1000

                        channel-group 1 mode on

                        spanning-tree portfast

                        !

                        !

                        interface GigabitEthernet1/0/21

                        switchport access vlan 55

                        switchport mode access

                        duplex full

                        speed 1000

                        channel-group 1 mode on

                        spanning-tree portfast

                        !

                         

                         

                        show etherchannel 1 detail

                         

                        Group state = L2

                        Ports: 2   Maxports = 8

                        Port-channels: 1 Max Port-channels = 1

                        Protocol:    -

                                        Ports in the group:

                                        \----


                        Port: Gi1/0/17

                        \----


                         

                        Port state    = Up Mstr In-Bndl

                        Channel group = 1           Mode = On/FEC          Gcchange = -

                        Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1

                        Port index    = 0           Load = 0x00            Protocol =    -

                         

                        Age of the port in the current state: 00d:01h:35m:52s

                         

                        Port: Gi1/0/21

                        \----


                         

                        Port state    = Up Mstr In-Bndl

                        Channel group = 1           Mode = On/FEC          Gcchange = -

                        Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1

                        Port index    = 0           Load = 0x00            Protocol =    -

                         

                        Age of the port in the current state: 00d:01h:35m:48s

                         

                                        Port-channels in the group:

                                        \----


                         

                        Port-channel: Po1

                        \----


                         

                        Age of the Port-channel   = 00d:02h:11m:15s

                        Logical slot/port   = 10/1          Number of ports = 2

                        GC                  = 0x00000000      HotStandBy port = null

                        Port state          = Port-channel Ag-Inuse

                        Protocol            =    -

                         

                        Ports in the Port-channel:

                         

                        Index   Load   Port     EC state        No of bits

                        -


                        ----------+


                        +--


                          0     00     Gi1/0/17 On/FEC             0

                          0     00     Gi1/0/21 On/FEC             0

                         

                        Time since last port bundled:    00d:01h:35m:48s    Gi1/0/21