5 Replies Latest reply on Oct 2, 2020 1:13 PM by Mikero

    Error on building docker image

    jmellander Lurker

      I'm trying to build an image using vctl, but it seems I'm getting an error from the builder itself.

      I run:

       

      [username@hostname] [current directory] % vctl build -f /Users/[path masked]/Downloads/image-docker-64/Dockerfile -t [masked tag] /Users/[home of user]/.vctl/storage/

      Password:

      INFO building image [masked tag] with jobId 15dade5d-2184-411b-a696-bd97a37bcd25 using internal builder instance...

      INFO preparing base images...                    

      INFO done preparing cache for images: []         

      INFO builder image vctl.local/vctl-builder:0.14.0 is ready

      INFO preparing builder: vctl-builder-15dade5d    

      INFO starting builder: vctl-builder-15dade5d     

      INFO container vctl-builder-15dade5d started     

      ERROR image build failed, please review above build logs for details

            if you are seeing 'no space left on device' error, retry 'vctl build' with the '--builder-mem' option to allocate more memory

      [username@hostname] [current directory] %

       

      When I look at containerd.log, it says:

       

      time="2020-09-25T13:29:44.271869000+02:00" level=info msg="starting signal loop namespace=vctl-internal path=/Users/[masked path]/.vctl/storage/containerd/state/io.containerd.runtime.v2.task/vctl-internal/vctl-b" namespace=vctl pid=18995

       

      time="2020-09-25T13:29:44.768813000+02:00" level=error msg="failed to find the container or sandbox cri annotations" module=libcrx package=ociruntimespec

       

       

       

      time="2020-09-25T13:29:53.591203000+02:00" level=warning msg="container :vctl-builder-15dade5d does not have port mapping, ignore" module=libcrx package=ocicontainer

      time="2020-09-25T13:29:53.599622000+02:00" level=info msg="shim disconnected" id=vctl-builder-15dade5d

      time="2020-09-25T13:29:53.599685000+02:00" level=warning msg="cleaning up after shim disconnected" id=vctl-builder-15dade5d namespace=vctl-internal

      time="2020-09-25T13:29:53.599702000+02:00" level=info msg="cleaning up dead shim"

       

      To me it looks like it's the builder container itself that is struggling. What could I be doing wrong?

      Any hint appreciated.

       

      This is when using Fusion Pro 11.5.6.