1 2 Previous Next 15 Replies Latest reply on Sep 30, 2020 1:43 AM by thisisme

    VMware-Player-15.5.6 fails to load on Linux

    lostagain Novice

      After I did a Kernel update VMware-Player had to do a reinstall and it didn't.

      Thank someone for "Timeshift". I managed to roll back to working installation.

       

      Then downloaded and tried the latest version of VmWare player ... no joy:

      =============

      $ cd /home/XXXXX/Downloads

      $ sudo ./VMware-Player-15.5.6-16341506.x86_64.bundle

      [sudo] password for XXXXX:       

      Extracting VMware Installer...done.

      /tmp/tmpbxds2o8v.vmis.env:4: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses

        import imp

      /tmp/vmis.iAlRZf/install/vmware-installer/vmis-launcher: error while loading shared libraries: libcrypto.so.1.0.2: cannot open shared object file: No such file or directory

      =============

      Working system is running on:

        Linux Mint 19.2 Tina 64-bit

        Kernel Linux 5.3.0.-53-generic x86_64

        MATE 1.22.0

        • 1. Re: VMware-Player-15.5.6 fails to load on Linux
          Mits2020 Hot Shot

          Similar problems reported lately in other threads, e.g. VMWare Workstation Player installation failure in Ubuntu 18.04.4 host (still not answered).

           

          It seems to be a transition from Python 2 to Python 3 problem (see for example https://stackoverflow.com/questions/43964166/imp-module-is-deprecated-in-favour-of-importlib )

           

          Please wait for some linux guy to help.

          • 2. Re: VMware-Player-15.5.6 fails to load on Linux
            a.p. Guru
            vExpertUser ModeratorsCommunity Warriors

            Not exactly the same error message, but maybe worth a try -> Re: VMWare Worstation Pro 15.5.5 installation fails on Debian stable

             

            André

            • 3. Re: VMware-Player-15.5.6 fails to load on Linux
              lostagain Novice

              Additional information:

               

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f59da6cf000)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_set_read_fn, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_sig_cmp, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_set_strip_alpha, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_create_read_struct, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_destroy_read_struct, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_read_end, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_create_info_struct, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_set_filter, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_read_update_info, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              2020-06-11T10:06:18.968-05:00| appLoader| I125+ undefined symbol: png_set_compression_level, version PNG12_0 (/usr/lib/vmware/lib/libvmwarebase.so/libvmwarebase.so)

              ....

               

              log file attached

              .....

               

              $ sudo locate libcrypto.so

              /usr/lib/vmware/lib/libcrypto.so.1.0.2

              /usr/lib/vmware/lib/libcrypto.so.1.0.2/libcrypto.so.1.0.2

              /usr/lib/vmware-ovftool/libcrypto.so.1.0.2

              /usr/lib/vmware-tools/lib32/libcrypto.so.1.0.2

              /usr/lib/vmware-tools/lib32/libcrypto.so.1.0.2/libcrypto.so.1.0.2

              /usr/lib/vmware-tools/lib64/libcrypto.so.1.0.2

              /usr/lib/vmware-tools/lib64/libcrypto.so.1.0.2/libcrypto.so.1.0.2

              /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0

              /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1

              /usr/lib/x86_64-linux-gnu/android/libcrypto.so.0

              • 4. Re: VMware-Player-15.5.6 fails to load on Linux
                lostagain Novice

                even worse with VMware-Workstation-Full-15.5.6-16341506.x86_64.bundle

                 

                Even Worse.png

                • 5. Re: VMware-Player-15.5.6 fails to load on Linux
                  alansecker Novice

                  After wasting several hours I uninstalled and installed v 15.5.1.

                  Still no joy.

                  The a brainwave.

                  I rebooted into an earlier kernel.

                  Success!

                  HTH

                  • 6. Re: VMware-Player-15.5.6 fails to load on Linux
                    lostagain Novice

                    Well I ma on version 5.4.0-37 at the moment.

                    The next lowest version I currently show is 5.3.0-53.

                    It is no longer supported after August 2020

                    • 7. Re: VMware-Player-15.5.6 fails to load on Linux
                      pbneves Novice

                      I've managed to upgrade my VMPlayer to version 15.5.6

                      That's what I did:

                      1. with the old version installed run vmware-installer  -i VMware-Player-15.5.6-16341506.x86_64.bundle and it uninstalled VMPlayer;
                      2. run ./VMware-Player-15.5.6-16341506.x86_64.bundle --console --ignore-errors for installing the new version.

                       

                      • 8. Re: VMware-Player-15.5.6 fails to load on Linux
                        lostagain Novice

                        Well I tried backing off the kernel now the error I am getting isis:

                         

                        $ cd /home/lewis/Downloads/vmware

                        $ ls

                        VMware-Player-15.5.6-16341506.x86_64.bundle

                        $ sudo ./VMware-Player-15.5.6-16341506.x86_64.bundle

                        [sudo] password for lewis:      

                        Extracting VMware Installer...done.

                        /tmp/tmpleb0_rdo.vmis.env:4: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses

                          import imp

                        /tmp/vmis.wk91Vb/install/vmware-installer/vmis-launcher: error while loading shared libraries: libcrypto.so.1.0.2: cannot open shared object file: No such file or directory

                        $ sudo ./VMware-Player-15.5.6-16341506.x86_64.bundle --console --ignore-errors

                        Extracting VMware Installer...done.

                        /tmp/tmpcuzezyfb.vmis.env:4: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses

                          import imp

                        /tmp/vmis.OtjnAF/install/vmware-installer/vmis-launcher: error while loading shared libraries: libcrypto.so.1.0.2: cannot open shared object file: No such file or directory

                        $

                        Current Linux Version.png

                        The only thing Google found was: https://www.reddit.com/r/vmware/comments/gvr02a/vmware_player_broke_in_my_ubuntu_2004_system_help/

                        That recommended the commend: sudo vmware-installer -i VMware-Player-15.5.5-16285975.x86\_64.bundle

                         

                        That implies being able to extract the files from the "bundle" ... which I do not seem to be able to do.

                         

                        This really playing havoc on my system.

                         

                         

                        Apparently I am going to have to build a another physical machine with an outdated OS and dedicate it to Vmware.

                        Sort of defeats the purpose of virtual machines to begin with.

                        • 9. Re: VMware-Player-15.5.6 fails to load on Linux
                          Mits2020 Hot Shot

                          From recent posts in the Community it seems there are still unresolved problems in the installation of latest Workstation versions to recent Linux hosts. Apparently things are progressing too fast for VMware to catch up and resolve the problems. On the one hand Linux distributions (especially Ubuntu and therefore all ubuntu-based distros) are too hasty to incorporate new versions of crucial to WS packages like Python (which leads to 'the imp module is deprecated in favour of importlib' warnings, very frequent lately in this forum) and on the other, the new versions of the kernel seem to break other things. Therefore, I predict that the time will come soon that the Workstation host (and guest) compatibility requirements will be explicitly stated in terms of specific versions of packages and kernels (not just distribution versions like "Mint 19.2" in your case).

                           

                          Therefore, your conclusion that a dedicated PC is needed with an LTS version of linux (and one that is explicitly listed as supported by Workstation) and an older WS version (e.g. 15.5.2 seems to be very stable) is very valid, especially if you need it in a production environment. Your last sentence however ("Sort of defeats the purpose of virtual machines to begin with"), is not warranted, because no virtualisation solution is able to cope with the latest and greatest linux distributions, simply because the latter evolve much faster than the former.

                          • 10. Re: VMware-Player-15.5.6 fails to load on Linux
                            lostagain Novice

                            ("Sort of defeats the purpose of virtual machines to begin with"), is not warranted

                             

                            A mobile user would thus have to always carry two machines with them. I used to travel internationally and I always had a VM of the three corporate installations we used on my laptop with a large hard disk. Of course in those days I also had VMWare Workstation (Pro as they now call it) and corporate VmWare support.

                             

                            H'mmmm ... If I recall the license correctly, the non-commercial user is only authorized to run one VM on Workstation Player unless they purchase a license for Workstation Pro. That can also be accomplished in hardware via swapping disks, active partitions, etc. The VM advantage is one can switch between VM machines with different images without needing to manipulate the hardware.

                             

                            Two caveats:

                            1) It has been a long time since I sat down and went through the entire user agreement with a fine tooth comb.

                            2) I seem to recall that running two separate instances of VmWare Player on a single Host was successfully (on linux).

                            Both of statements should be tempered with the fact that I am also getting old and senile.

                            The memory cells do not always fire in the correct order any more.

                             

                            For my purposes I have a laptop that I no longer use. It just happens to have a valid Windows 10 license on it. Vmware Workstation Player 15.5.6 installed on it without any problems. So I am transfering all my legacy Microsoft VM's to that machine. I rarely run Windows OS anyway but when I do it is because I really need it to access to software or historical data that can only be accessed via Windows (MS-Outlook proprietary archive files being the classical example).

                             

                            I will remove VMWare from my Linux Workstation and replace it with Oracle Virtualbox. Then I will migrate my one active Linux VM to Virtualbox and any new Vms will be created under Virtualbox.

                             

                            EDIT:

                            I did try running two instances of VMware Workstation Player under Windows and that worked.

                            • 11. Re: VMware-Player-15.5.6 fails to load on Linux
                              Mits2020 Hot Shot

                              Before moving all your VMs to a new machine, it is generally recommended in this forum to completely shut them down and remove all snapshots. So keep these VMs backed up somewhere else too.

                              To my knowledge current Player uses a tabbed interface and is able to run several guests concurrently (as long as you have enough RAM and cpu cores available. At least in the What is VMware Workstation Player? | FAQs there are no limitations listed on the number of guests you can use.

                              • 12. Re: VMware-Player-15.5.6 fails to load on Linux
                                lostagain Novice

                                You are referring to the commercial version of Workstation Player Pro.

                                I am/was currently running the non-commercial version of Workstation Player.

                                 

                                I never use snapshots and I always completely shutdown my VMs.

                                • 13. Re: VMware-Player-15.5.6 fails to load on Linux
                                  marle Lurker

                                  I just hit the same problem and found this thread. I wanted to upgrade VMWare Workstation Pro on Ubuntu 20.04 from 15.5.2 to 15.5.6. After some googling and fiddling around I found that the following command worked for me:

                                   

                                  sudo vmware-installer -i VMware-Workstation-Full-15.5.6-16341506.x86_64.bundle

                                   

                                  I have no idea what vmware-installer does differently. Obviously you have to have vmware-installer installed, which seems to be the case when you had a working older version of VMWare at some point. Hope this works for you too.

                                  • 14. Re: VMware-Player-15.5.6 fails to load on Linux
                                    chavalot Lurker

                                    I'm having problems with VMware-Player 15.5.6 too but in OpenSuse Leap 15.2.

                                     

                                    When I install it, it tells me that,  "Before you can run VMware, several modules must be compiled and loaded into the running kernel"; and this is the error that occurs:

                                        

                                         Unable to install all modules. See log /temp/vmware-xxxx/vmware-4736.log for details

                                     

                                         This is the error in the log:

                                     

                                          host-4736| I005: /tmp/modconfig-fB4h9q/vmnet-only/userif.c:85:39: error: ‘skb_frag_t {aka const struct bio_vec}’ has no member named ‘page_offset’; did you mean ‘bv_offset’?

                                          host-4736| I005:  #   define skb_frag_off(frag) (frag)->page_offset

                                          host-4736| I005:                                        ^

                                          host-4736| I005: /tmp/modconfig-fB4h9q/vmnet-only/userif.c:576:43: note: in expansion of macro ‘skb_frag_off’

                                          host-4736| I005:    tmpCsum = csum_and_copy_to_user(vaddr + skb_frag_off(frag),

                                          host-4736| I005:                                            ^~~~~~~~~~~~

                                          host-4736| I005: make[3]: *** [/usr/src/linux-5.3.18-lp152.19/scripts/Makefile.build:282: /tmp/modconfig-fB4h9q/vmnet-only/userif.o] Error 1

                                    1 2 Previous Next