6 Replies Latest reply on May 6, 2020 7:33 AM by DEMdev

    Slow login 10 minutes

    PRimmer_London Lurker

      Experiencing slow login times of 10-15 minutes with DEM, bit new to using DEM so seeking some advice

       

      Looking at the flexengine log there is a huge 10 minute gap but what is happening during this time?

       

      2020-04-28 08:25:36.742 [DEBUG] Running as Group Policy client-side extension -- skipping all refresh-related actions

      2020-04-28 08:25:37.073 [DEBUG] Started injection (330 ms)

      2020-04-28 08:25:37.077 [DEBUG] Launched FlexEngine in DirectFlex mode

      2020-04-28 08:25:37.079 [INFO ] Done (7086 ms) [<<IFP#eb0a9813-T5]

      2020-04-28 08:25:42.852 [DEBUG] Called with '-OfflineImport' switch, but import has already taken place

      2020-04-28 09:11:08.014 [INFO ] Starting FlexEngine v9.10.0.921 [IFP#5fd0da84-1062fd6>>]

      2020-04-28 09:11:08.014 [INFO ] Performing path-based export

       

      I know User Policy isn't to blame, that last applied in 15s

        • 1. Re: Slow login 10 minutes
          DEMdev Master
          VMware Employees

          Hi PRimmer_London,

          2020-04-28 08:25:36.742 [DEBUG] Running as Group Policy client-side extension -- skipping all refresh-related actions

          2020-04-28 08:25:37.073 [DEBUG] Started injection (330 ms)

          2020-04-28 08:25:37.077 [DEBUG] Launched FlexEngine in DirectFlex mode

          2020-04-28 08:25:37.079 [INFO ] Done (7086 ms) [<<IFP#eb0a9813-T5]

          DEM's processing during logon (while running as Group Policy client-side extension) took just over 7 seconds.

           

          2020-04-28 08:25:42.852 [DEBUG] Called with '-OfflineImport' switch, but import has already taken place

          This is (most probably) the FlexEngine.exe -OfflineImport invocation that you have configured as a logon script, as a fallback? That's perfectly fine, and seems to be working as expected (i.e. not doing anything, as the import was already performed successfully via the extension.)

           

          2020-04-28 09:11:08.014 [INFO ] Starting FlexEngine v9.10.0.921 [IFP#5fd0da84-1062fd6>>]

          2020-04-28 09:11:08.014 [INFO ] Performing path-based export

          This is the start of the export that takes place at logoff.

           

          I don't see a "huge 10 minute gap" in the log fragment you provided. Do you have any additional information we could use to try and troubleshoot your slow logons?

          1 person found this helpful
          • 2. Re: Slow login 10 minutes
            PRimmer_London Lurker

            Helps if i post the right log I was looking at

             

            2020-05-05 08:21:04.540 [INFO ] <<< FlexRepository Flag Files synchronization ended (took 266 ms)

            2020-05-05 08:21:04.540 [INFO ] Sync ended (took 4953 ms)

            2020-05-05 08:21:04.540 [INFO ] ----------------------------------------------------------------------------

            2020-05-05 08:21:04.540 [INFO ] LOGON mode ended (Group Policy client-side extension)

            2020-05-05 08:21:05.242 [INFO ] Local configuration folder is protected

            2020-05-05 08:21:05.242 [INFO ] ----------------------------------------------------------------------------

            2020-05-05 08:34:41.241 [INFO ] ----------------------------------------------------------------------------

            2020-05-05 08:34:41.241 [INFO ] RESIDENT mode started

            2020-05-05 08:34:41.241 [INFO ] ----------------------------------------------------------------------------

            2020-05-05 08:34:41.241 [INFO ]           VMware DEM SyncTool version: 9.9.0.718

            2020-05-05 08:34:41.241 [INFO ]           FlexEngine refresh: DirectFlex configuration, ADMX-based settings, Application blocking settings, Environment variables, File type associations, Horizon Smart Policies settings, Privilege elevation settings, Shortcuts, Triggered task settings

            2020-05-05 08:34:41.241 [DEBUG]        Environment Info: User: XXX\XXX, Computer: LON-WIN-01, OS: x64-win10 (BuildNumber 17763, SuiteMask 100, ProductType 1, Lang 0809, IE 9.11.17763.0, ProcInfo 1/2/4/4), PTS: 2488/840/C

            2020-05-05 08:34:41.241 [INFO ]           Local sync path: C:\Users\XXX\AppData\Local\VMware UEM

            2020-05-05 08:34:41.241 [INFO ]           Watch local profile archive changes: Enabled

            2020-05-05 08:34:41.241 [INFO ]           Flex config sync interval: 900 seconds; Retry 300 seconds

            2020-05-05 08:34:41.241 [INFO ]           Profile archives sync interval: 900 seconds; Retry 300 seconds

            2020-05-05 08:34:41.241 [INFO ]           FlexRepository sync interval: 900 seconds; Retry 300 seconds

            2020-05-05 08:34:41.241 [INFO ]           DEM SyncTool log file: Enabled; Size: 1024 kbytes; Maximum # of log lines in UI: 500

            • 3. Re: Slow login 10 minutes
              DEMdev Master
              VMware Employees

              Hi PRimmer_London,

              2020-05-05 08:21:04.540 [INFO ] <<< FlexRepository Flag Files synchronization ended (took 266 ms)

              2020-05-05 08:21:04.540 [INFO ] Sync ended (took 4953 ms)

              2020-05-05 08:21:04.540 [INFO ] ----------------------------------------------------------------------------

              2020-05-05 08:21:04.540 [INFO ] LOGON mode ended (Group Policy client-side extension)

              2020-05-05 08:21:05.242 [INFO ] Local configuration folder is protected

              2020-05-05 08:21:05.242 [INFO ] ----------------------------------------------------------------------------

              This log fragment indicates that the SyncTool's processing at logon took just under 5 seconds.

               

              2020-05-05 08:34:41.241 [INFO ] ----------------------------------------------------------------------------

              2020-05-05 08:34:41.241 [INFO ] RESIDENT mode started

              2020-05-05 08:34:41.241 [INFO ] ----------------------------------------------------------------------------

              The thirteen minute gap between 08:21:05.242 and 08:34:41.241 does not affect logon performance. Running the SyncTool in resident mode just makes sure that certain changes are synced within the session, rather than having them "wait" until logoff, but this won't slow down logon.

              • 4. Re: Slow login 10 minutes
                PRimmer_London Lurker

                Unfortunately it is affecting logon, that is the "gap" where the computer sits with "preparing windows" and the user is held up

                • 5. Re: Slow login 10 minutes
                  sjesse Master
                  vExpertUser Moderators

                  So I've seen other things slow this down, we have a login script that runs that used to be hiddent behind the prepairing windows screen. If you set

                   

                  [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]

                  "DelayedDesktopSwitchTimeout"=dword:00000002

                   

                  This will lower the time that screen shows, it won't make it quicker, but it may both seem quicker, and let you know whats going on.

                  1 person found this helpful
                  • 6. Re: Slow login 10 minutes
                    DEMdev Master
                    VMware Employees

                    Hi PRimmer_London,

                    Unfortunately it is affecting logon, that is the "gap" where the computer sits with "preparing windows" and the user is held up

                    Can you provide a set of matching logs for FlexEngine itself and the SyncTool for such a slow logon, with a few "manual" timestamps like "Entered credentials at hh:mm:ss" and "Saw desktop at hh:mm:ss"?

                     

                    (Either here in the forum, or via DM?)