4 Replies Latest reply on Feb 11, 2020 9:15 AM by nirmalgnair

    Upgrade from VCSA 6.0 U3j to VCSA 6.7 pre-upgrade checks failing (stage 2)

    padavjer Lurker

      Hello Community

       

      Reading through websites and community pages for a few days now. I am trying to upgrade a VCSA 6.0U3 to the latest 6.7U3.

       

      Stage 1 is fine (deploying vCenter Server Appliance with Embedded PSC)

       

      But the pre-upgrade checks at stage 2 are failing. None of the discussions I have found yet are dealing with the errors I have so far (according to what I have seen).

       

      Any hints are highly appreciated. Thanks in advance.

       

      Jerry

        • 1. Re: Upgrade from VCSA 6.0 U3j to VCSA 6.7 pre-upgrade checks failing (stage 2)
          bewe Hot Shot

          looks like problems with update manager.

          maybe clean up repository of the source can help - i will look tomorrow when iḿ not too busy

          • 2. Re: Upgrade from VCSA 6.0 U3j to VCSA 6.7 pre-upgrade checks failing (stage 2)
            nirmalgnair Enthusiast
            VMware Employees

            Hi Jerry,

             

            From the logs, this is what I see.

             

            bootstrap.log :

             

            2020-02-10T22:00:48.10Z ERROR upgrade_commands Pre-upgrade checks errors:

            2020-02-10T22:00:48.10Z ERROR upgrade_commands {'text': {'id': 'ur.requirements.component.internal.text', 'args': ['vSphere ESX Agent Manager'], 'translatable': 'Internal error occurs during %(0)s pre-upgrade checks.', 'localized': 'Internal error occurs during vSphere ESX Agent Manager pre-upgrade checks.'}, 'description': None, 'problemId': None, 'resolution': {'id': 'ur.internal.resolution', 'translatable': 'Please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request.', 'localized': 'Please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request.'}}

            2020-02-10T22:00:48.11Z ERROR upgrade_commands Pre-upgrade checks failed on source host. Check upgrade-source-requirements.log log for  details.

             

            Looking at CollectRequirements_com.vmware.eam_2020_02_10_22_00.log, it seems like the EAM service is stopped on the source machine.

             

            I would suggest you to login to the VCSA 6.0 and check the status of EAM service by running the following command.

             

            service-control --status vmware-eam

             

            If the status is stopped, check the eam.properties file under /etc/vmware-eam/ and check the size of the file. If it's 0KB then we need to re-create the eam.properties file.

             

            You can refer VMware KB : VMware Knowledge Base to perform the steps. Once the file is re-created, you can start the EAM service by running service-control --start vmware-eam. Initiate the upgrade from Stage 2 again.

             

            Do let me know if you have any further queries or assistance needed in re-creating the file.

             

            Regards,

            Nirmal Nair

            1 person found this helpful
            • 3. Re: Upgrade from VCSA 6.0 U3j to VCSA 6.7 pre-upgrade checks failing (stage 2)
              padavjer Lurker

              Hi Nirmal

               

              Thanks for your hint. That did the trick!

               

              For whatever reason eam.properties only had "eam.web.root=/usr/lib/vmware-eam/web" in it.

               

              Modified the file according to the VMware KB and started EAM Service again. Status running.

               

              Just performed another pre-ugprade check and it was successful. Upgrading VCSA later but for me this item is solved.

               

              Thank you very much!


              Jerry

              • 4. Re: Upgrade from VCSA 6.0 U3j to VCSA 6.7 pre-upgrade checks failing (stage 2)
                nirmalgnair Enthusiast
                VMware Employees

                Good to know that it worked, Jerry :-)

                 

                Have a good day.

                 

                Regards,

                Nirmal Nair