0 Replies Latest reply on Dec 1, 2019 2:56 AM by bobbyccie

    Issue setting 'options kvm ignore_msrs=1' for nested 64-bit VMs

    bobbyccie Novice



      I am having issues running 64-bit VMs on a nested ESXi 6.7 host running on KVM (Ubuntu 16.04.6 EVE-NG).


      I believe the fix is to enable 'options kvm ignore_msrs=1' on the main Ubuntu machine.


      I have tried adding 'options kvm ignore_msrs=1' in various places, including:






      But after a reboot I still see:


      root@eve-ng:~# cat /sys/module/kvm/parameters/ignore_msrs



      I can set it to 'Y' with:


      root@eve-ng:~# echo 1 > /sys/module/kvm/parameters/ignore_msrs


      root@eve-ng:~# cat /sys/module/kvm/parameters/ignore_msrs



      But it doesn't survive a reboot.


      Any suggestions? Thanks


      P.S. I am running KVM on Ubuntu 16.04.6 LTS.