4 Replies Latest reply on Oct 18, 2019 9:58 AM by johnnyBob

    VMware Player just stopped working, when I close it says vm is busy

    johnnyBob Novice

      This is a real head scratcher. I have been using this vm for weeks. All day.

      Today I installed a new router. So now I have a gateway device and a router. This should not matter.

       

       

      I am using VMware-player-3.1.5-491717 on Windows XP host.

      I have 4 vm's. It doesn't matter which one I touch with the mouse. Once I touch/click one of them, Player will put a lock

      file in the vm's directory.Once it does, I cannot close the vm. It will say "The Virtual Machine is busy". If I start

      vmWare Player, and then quit, that works.

      It is just if I touch/click a vm, then Player cannot close except by task manager.

       

      These are the contents of the lock files from 2 different vm's.

       

      uuid=40-1f-ac-83-e0-1d-b2-11-80-00-f6-78-f7-b4-f4-a3 3620 1 X 132157595591250000 lc=4253191359

       

      uuid=40-1f-ac-83-e0-1d-b2-11-80-00-f6-78-f7-b4-f4-a3 4156 1 X 132157610237968750 lc=3973341819

       

      It doesn't create a vmware.log file, if I move the log files elsewhere.

      I see nothing in the windows logs...

      I uninstalled it, reinstalled it. Same thing is happening.

      I need some help on this one.

       

        • 1. Re: VMware Player just stopped working, when I close it says vm is busy
          wila Guru
          vExpertCommunity WarriorsUser Moderators

          Windows XP, player 3? I guess that matches...

           

          It is normal for the VM once it is in use to put a lock file in there. That part is most likely a red herring as it is correct behavior.

           

          What I wonder about if I see this is:

          - failing hardware, like a disk that is misbehaving.

          - an antivirus / antimalware product that is causing trouble.

           

          --

          Wil

          | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
          | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
          | More info at https://www.vimalin.com
          | Twitter @wilva
          | VMware Wiki at http://www.vi-toolkit.com
          • 2. Re: VMware Player just stopped working, when I close it says vm is busy
            johnnyBob Novice

            I had given my antivirus a thought, but I have had it installed for a few weeks with no problem. BUT, i had nothing to lose, so I disabled everything I could until a system restart... and viola!!! It worked this time! Thank You for the nudge.  I now know who to call to get this fixed permanently. I lost a whole day on this.

            • 3. Re: VMware Player just stopped working, when I close it says vm is busy
              wila Guru
              vExpertCommunity WarriorsUser Moderators

              Hi,

               

              You're not mentioning which antivirus product you are using..

              It is probably still a good idea to have one. It might be possible to change some settings.

              Have a look at this thread:

              XP VM suddenly slow, Win 7 fine

               

              --

              Wil

              | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
              | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
              | More info at https://www.vimalin.com
              | Twitter @wilva
              | VMware Wiki at http://www.vi-toolkit.com
              • 4. Re: VMware Player just stopped working, when I close it says vm is busy
                johnnyBob Novice

                You are right. Here are the exact steps I had to take, in my Security software. Avast Premier.

                 

                Avast Main Interface->pick top right corner item Menu->then Settings->then Components on the left hand side of the settings window.

                Once in Components, pick File Shield->then the Customize option.

                Once in Custom options... select Scan When Opening. Once that is opened... Uncheck the "Scan All Files" check box.

                 

                That fixed my problem.

                I have attached a screenshot of the exact version information of my Avast that I am using on Windows XP SP3.