1 Reply Latest reply on Oct 22, 2019 7:37 AM by msripada

    Is it possible to update latest VCSA 6.0 Update 3j with embedded Postgres DB to vCenter VCSA 6.7 (Update 1 or never) ???

    vmwaresbrf Lurker

      Is it possible to update latest vCenter Server 6.0 Update 3j Appliance with embedded Postgres DB to vCenter Server 6.7 Appliance (Update 1 or never) ???

       

      In Upgrade Notes from release notes for vCenter Server 6.0 Update 3j i found that : "Important: Upgrade and migration paths from vCenter Server 6.0 Update 3j to vCenter Server 6.5 and 6.7 are not supported." :

      https://docs.vmware.com/en/VMware-vSphere/6.0/rn/vsphere-vcenter-server-60u3j-release-notes.html#upgrading

      Is It only applies to vCenter Server 6.5 GA - 6.5U2 and 6.7 GA, or 6.5 any Update and 6.7 any Update too ???

       

      I did not find necessary information about it in VMware Product Interoperability Matrices:

      https://www.vmware.com/resources/compatibility/sim/interop_matrix.php#upgrade&solution=2

      But i found in it that for 6.5 U2 and previous updates, 6.7 GA : "Upgrade and migration paths from vCenter Server 6.0 Update 3g deployed with embedded Postgres DB to vCenter Server 6.5 and 6.7 are not supported.

      For more details refer to the following KB article : https://kb.vmware.com/s/article/57738"

       

      In KB57738 stated that:

      Upgrading from vCenter Server 6.0 U3g/U3h deployed with embedded Postgres DB to vCenter Server 6.5 U2b/U2c (vPostgres DB) fails.

      Upgrading from vCenter Server 6.0 U3g/U3h deployed with embedded Postgres DB to vCenter Server 6.7a/6.7b/6.7c/6.7d (vPostgres DB) fails.

      And that this issue is resolved in vSphere 6.5 Update 2d and 6.7 Update 1

      This is confirmed in Release notes for Update 3g, Update 3h:

      "Upgrade and migration paths from vCenter Server 6.0 Update 3h deployed with embedded Postgres DB to vCenter Server 6.5 Update 2d and 6.7 Update 1 are supported."

      https://docs.vmware.com/en/VMware-vSphere/6.0/rn/vsphere-vcenter-server-60u3g-release-notes.html#upgrading

      https://docs.vmware.com/en/VMware-vSphere/6.0/rn/vsphere-vcenter-server-60u3h-release-notes.html#upgrading

       

      My current configuration now:

      vCenter Server 6.0 Update 3i deployed with embedded Postgres DB, initially it was deployed on Update 3g, than updated to 3h, than to 3i.

       

      In future (early in the next year) i plan to upgrade it to 6.7 latest Update. And now i decide to update now or not to update now it from 6.0 3i to 6.0 3j, because i not sure that it can update to 6.7* from 6.0 3j

       

      So:

      Can i Upgrade in future to 6.7 Latest Update, if my current 6.0 U3i deployed with embedded Postgres DB will be updated now to 6.0 U3j?