1 2 3 4 Previous Next 49 Replies Latest reply on Nov 25, 2019 6:08 PM by dtbrigh Go to original post
      • 30. Re: Could not open /dev/vmmon: Broken pipe.
        Uxian Lurker

        I've tried all of these solutions.  Enabling full disk access worked for me for a single boot and then next time I boot from cold the problem comes back.

         

        If I try to load the driver using kextload I get the following in dmesg:

        vmmon: Loaded com.vmware.kext.vmx86 Version 1366.85.89 Build 13668589 (May 12 2019 14:05:51)

        vmmon: Warning: Failed to register the major device number.

        Kext com.vmware.kext.vmx86 start failed (result 0x5).

        Kext com.vmware.kext.vmx86 failed to load (0xdc008017).

        Failed to load kext com.vmware.kext.vmx86 (error 0xdc008017).

         

        Turns out I just had too many third-party kexts loaded and after I removed a few (SoundFlower, tun and tap VPN drivers) I was then able to load vmmon.

        • 31. Re: Could not open /dev/vmmon: Broken pipe.
          brbaus Lurker

          One tip for folks on Mojave.

           

          Look on the General tab in the Security and Privacy settings. There was a button on that tab that enables vmWare to run. Then it works like a charm.

          • 32. Re: Could not open /dev/vmmon: Broken pipe.
            lurch999 Lurker

            This solution works for cases where the "Allow" button does not appear in Security & Privacy > General:

             

            Using Terminal, get the TeamIdentifier value from the VMWare Fusion version you're using (the % is the prompt, so omit that):

             

               % codesign -dv --verbose=4 /Applications/VMware\ Fusion.app

             

            From the results of that command, find the "TeamIdentifier" value, for example:

             

               TeamIdentifier=EG7KH642X6

             

            Write that down, and note this is case-sensitive.

             

            Reboot your Mac into Recovery Mode (hold down Command + R at boot)

             

            In Recovery Mode, open Terminal, then:

             

              % /usr/sbin/spctl kext-consent add EG7KH642X6

             

            Reboot, and you should be good to go now.

            • 33. Re: Could not open /dev/vmmon: Broken pipe.
              mastlonda Lurker

              SOLVED

              This a complete video tutorial for fix of this error

              You can find it right here:-

              VMware Could not open dev/vmmon | Unable to open kernel device | Failed to initialize monitor device - YouTube

              He has some good and awesome stuff

              • 34. Re: Could not open /dev/vmmon: Broken pipe.
                AndrewBurkhart9W Lurker

                I tried all the other responses I saw in here (Allow in Security & Privacy, allow full disk access, try different things in recovery terminal, etc.) but my issue turned out to be maxing out the number of kernel extensions that can be loaded (at least this is my understanding). I ran 'kextstat' and found some to remove (all virtualbox kext's in my case). As soon as I freed up some slots, all my VM's began working again in VMware.

                 

                Again, this is a little outside my expertise so I'm paraphrasing assistance I got, but essentially they told me there are only a certain number of slots for kext's to be running and VMware needed more slots than what I had available on my machine.

                 

                 

                To check (in a terminal):

                - run 'kextstat | grep vmware'

                - if you only see 2 or less kext's, run 'sudo kextutil /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext'

                - if you see something like 'Failed to load /Library/StagedExtensions/Applications/VMware Fusion.app/Contents/Library/kexts/vmmon.kext - (libkern/kext) kext (kmod) start/stop routine failed.', this is probably your fix

                 

                My Steps to fix (again in a terminal):

                - run 'kextstat' to see a list of kext's

                - run 'sudo kextunload -b /whatever/kext/you/can/remove' (i.e. 'sudo kextunload -b org.virtualbox.kext.VBoxDrv')

                - I did that for 4 kext's

                - run vm in VMware again

                - all good

                 

                 

                Hopefully that helps someone.

                • 35. Re: Could not open /dev/vmmon: Broken pipe.
                  CharlieSMF Novice

                  I am still having a problem running VMware Fusion on Mojave 10.14.6. Is there any fix for this problem?  I could not follow the following as I got a very long list from kextstat

                  Ater 3 hours on this problem I am getting very desperate...

                  ..........

                   

                  I tried all the other responses I saw in here (Allow in Security & Privacy, allow full disk access, try different things in recovery terminal, etc.) but my issue turned out to be maxing out the number of kernel extensions that can be loaded (at least this is my understanding). I ran 'kextstat' and found some to remove (all virtualbox kext's in my case). As soon as I freed up some slots, all my VM's began working again in VMware.

                   

                  Again, this is a little outside my expertise so I'm paraphrasing assistance I got, but essentially they told me there are only a certain number of slots for kext's to be running and VMware needed more slots than what I had available on my machine.

                   

                   

                  To check (in a terminal):

                  - run 'kextstat | grep vmware'

                  - if you only see 2 or less kext's, run 'sudo kextutil /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext'

                  - if you see something like 'Failed to load /Library/StagedExtensions/Applications/VMware Fusion.app/Contents/Library/kexts/vmmon.kext - (libkern/kext) kext (kmod) start/stop routine failed.', this is probably your fix

                   

                  My Steps to fix (again in a terminal):

                  - run 'kextstat' to see a list of kext's

                  - run 'sudo kextunload -b /whatever/kext/you/can/remove' (i.e. 'sudo kextunload -b org.virtualbox.kext.VBoxDrv')

                  - I did that for 4 kext's

                  - run vm in VMware again

                  - all good

                  • 36. Re: Could not open /dev/vmmon: Broken pipe.
                    AndrewBurkhart9W Lurker

                    CharlieSMF My best guess would be to try running something like

                     

                    kextstat | grep -v com.apple

                     

                    That way kextstat will just show you things that are third-party (more or less). That might help you find some kexts that you may be able to unload.

                     

                    Hopefully that helps.

                    • 37. Re: Could not open /dev/vmmon: Broken pipe.
                      CharlieSMF Novice

                      Thanks or the quick response:

                       

                      I ran that in the terminal and did not get anything.

                      grep -v com.apple

                      Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>

                      • 38. Re: Could not open /dev/vmmon: Broken pipe.
                        AndrewBurkhart9W Lurker

                        And if you run "kextstat" by itself, scroll to the bottom, do you see any line items whose name doesn't start with com.apple (i.e. com.vmware, com.sophos, etc.)?

                         

                        If not, you may be dealing with a different issue than I had, unfortunately.

                        • 39. Re: Could not open /dev/vmmon: Broken pipe.
                          CharlieSMF Novice

                          Problem Solved:

                          From Lurch999 (32)

                          This solution works for cases where the "Allow" button does not appear in Security & Privacy > General:

                           

                          Using Terminal, get the TeamIdentifier value from the VMWare Fusion version you're using (the % is the prompt, so omit that):

                           

                             % codesign -dv --verbose=4 /Applications/VMware\ Fusion.app

                           

                          From the results of that command, find the "TeamIdentifier" value, for example:

                           

                             TeamIdentifier=EG7KH642X6

                           

                          Write that down, and note this is case-sensitive.

                           

                          Reboot your Mac into Recovery Mode (hold down Command + R at boot)

                           

                          In Recovery Mode, open Terminal, then:

                           

                            % /usr/sbin/spctl kext-consent add EG7KH642X6

                           

                          Reboot, and you should be good to go now.

                           

                          Thanks for all the help

                          1 person found this helpful
                          • 40. Re: Could not open /dev/vmmon: Broken pipe.
                            benau_99 Lurker

                            That did the trick for me. Thanks for taking the time to reply.

                            • 41. Re: Could not open /dev/vmmon: Broken pipe.
                              imikem Lurker

                              Thanks much @CharlieSMF,  your solution did the trick for me at last!  Of course along the way I lost a pretty extensive configuration from doing a full-on kill-it-with-fire VMware Fusion removal.

                               

                              Mike

                              • 42. Re: Could not open /dev/vmmon: Broken pipe.
                                esac5555 Lurker

                                I am on Catalina 10.15 Beta, and even have the issue. So whatever it is, it is still there I presume in newer Mac OS's coming out. I have enabled everything I can in System Prefs, upgraded to VMWare Fusion 11.1.1 yesterday. Deleted some VM's I used, and need, and still no luck. This was an upgrade but I had uninstalled Fusion 8.5 earlier, then re-installed. I am getting the 'broken-pipe' error.

                                • 43. Re: Could not open /dev/vmmon: Broken pipe.
                                  nathanatbyc Lurker
                                  THIS WORKED FOR ME.  I wasn't getting the security notice button in preferences.  I did have the full disk access option either.  My Mac Pro on can go up to High Sierra 10.13.  I was on HS 10.13.5 and did an update to 10.13.6.  After the update installed, I started have the issue on Fusion 11.4 Pro.  I upgraded fusion to 11.5 Pro and it was still a problem.  Below is the only option I had available to me.
                                  32. Re: Could not open /dev/vmmon: Broken pipe.

                                  lurch999Lurker

                                  This solution works for cases where the "Allow" button does not appear in Security & Privacy > General:

                                   

                                  Using Terminal, get the TeamIdentifier value from the VMWare Fusion version you're using (the % is the prompt, so omit that):

                                   

                                     % codesign -dv --verbose=4 /Applications/VMware\ Fusion.app

                                   

                                  From the results of that command, find the "TeamIdentifier" value, for example:

                                   

                                     TeamIdentifier=EG7KH642X6

                                   

                                  Write that down, and note this is case-sensitive.

                                   

                                  Reboot your Mac into Recovery Mode (hold down Command + R at boot)

                                   

                                  In Recovery Mode, open Terminal, then:

                                   

                                    % /usr/sbin/spctl kext-consent add EG7KH642X6

                                   

                                  Reboot, and you should be good to go now.

                                   

                                   

                                  • 44. Re: Could not open /dev/vmmon: Broken pipe.
                                    Virtual Dan Lurker

                                    For me this issue was because fusion was not licensed (i.e. in Trial mode).

                                     

                                    The Security and Privacy window showed the message "System Software from Developer "VMware, Inc." was blocked from loading".  However pressing 'Allow' did nothing and the button just remained there.  I couldn't believe it but I was only able to press 'Allow' and something happen once I'd added a licence key to Fusion!

                                     

                                    How do VMware expect users to trial their product if it doesn't actually work until you've paid for it?   I've already flagged this with the pleasant chap at VMware support who unfortunately advised he couldn't help me as it was for a trial version (even though I'm a paying customer using a different machine).  Fortunately in my case I was able to use my licence key on this other machine to discover that being a trial prevented the 'Allow' button from working.  Hopefully it helps others with this crazy situation and saves someone some time, though in lieu of a licence perhaps the other suggested steps in this thread are the only way to resolve this while in trial mode.