5 Replies Latest reply on Aug 2, 2019 8:49 AM by iiliev

    vCloud Director plugin 9.5 - unable to set API version

    sorenemig Novice

      I have upgraded the vCloud Plugin in VRO 7.5 to vCloud Director plugin 9.5 (from 8.10). However I am unable to set the API version

       

      I don't have this drop-down box. If I add a connection it will use API version 20 (8.10)

       

      What am I missing here? Thanks you

        • 1. Re: vCloud Director plugin 9.5 - unable to set API version
          iiliev Champion
          Community WarriorsVMware Employees

          Could you check the build number of the plug-in and the version of this workflow?

           

          Looking at commit history for this workflow, it seems the Api Version field has been introduced at some point, but version of the workflow hasn't been updated as part of the same commit, so there was a period during which the changed workflow would be properly picked up only by new vRO deployments (not upgrades).

          • 2. Re: vCloud Director plugin 9.5 - unable to set API version
            sorenemig Novice

            I have not worked with VRO that much so please forgive my ignorance. What is the relationship between the workflow version and plugin version? Should the workflow be upgraded and how do I do that?

             

            This is the plugin version

             

             

            Also if I install this plugin on a new VRO (test) the workflow does have the API field.

             

            Is this the workflow version?

             

            • 3. Re: vCloud Director plugin 9.5 - unable to set API version
              iiliev Champion
              Community WarriorsVMware Employees

              Yes, these 3 numbers represent the plug-in version.

               

              As for relationship between plug-in version and workflow version - each plug-in usually has 2 components. One is the plug-in code written in Java, the other is the plug-in content (workflows/actions/resource elements/etc). when someone tries to upgrade a plug-in by uploading a new plug-in build, the code part of the new plug-in overrides the code of the currently installed plug-in, and the content of the new plug-in 'updates' the currently installed content.

               

              Now, there are several update scenarios, but in most common case if the new plug-in content contains a workflow X with version Y, and the vRO setup being upgraded contains the same workflow X but with version Z, then the workflow will be updated if Y > Z; that is, if the new build of the plug-in contains a newer version of the given workflow.

               

              In your case, the vCloud plug-in build# 9.5.0.10198325 contains the workflow 'Add a connection' with version 0.0.30. The screenshot shows that you already have version 1.0.0 of this workflow, that is, the new plug-in build contains a lower version. And that's why the existing version of the workflow is not updated.

               

              I'm not sure where this version 1.0.0 of the workflow is coming from. What is the build number of the plug-in you already had before upgrading it with build 9.5.0.10198325?

               

              To mitigate this issue, you have several options. Probably the easiest one is to completely remove existing vCloud plug-in before installing the new one. This is a bit tricky because vRO does not provide a single 'uninstall-a-plugin' command. There should be a KB article out there showing the steps to perform in order to uninstall a plug-in; just google for it.

              • 4. Re: vCloud Director plugin 9.5 - unable to set API version
                sorenemig Novice

                Thanks for explaining this

                 

                I have tried to remove the plugin using this kb VMware Knowledge Base

                 

                It successfully removed the plugin and I installed it again. However, the problem remains.

                 

                The API drop-down is not showing. And as you can see it uses API version 20 instead of the 31

                 

                • 5. Re: vCloud Director plugin 9.5 - unable to set API version
                  iiliev Champion
                  VMware EmployeesCommunity Warriors

                  OK, after you removed the plug-in, have you checked whether its content is removed (that is, that you don't have this workflow anymore)?

                   

                  Its also possible that you had the version 1.0.0 this workflow deployed by some other mean, ie. manually imported in the client, without going through plug-in installation.