7 Replies Latest reply on Jul 30, 2019 8:59 AM by Crackwall

    Problem mit vCenter und Arcserve + diverse Fragen

    DomenikM Lurker

      Sehr geehrte Damen und Herren,

      bei der Installation von vCenter und Arcserve, hänge ich an folgedem Punkt fest:

       

      Beim Verbinden des Arcserve-Agenten mit VMWare bekomme ich folgende Fehlermeldung:

      error.png

       

      Meine Vermutung dabei ist, dass das Zertifikat meines vCenter probleme hat.

      Kennt jemand diese Fehlermeldung?

       

      Zudem habe ich noch eine Frage zur Aufteilung der Kerne.

      Mein vCenter sagt mit, dass ich 16 Logischen Prozessoren, 1 Socket und 8 Kerne pro Socket zur Verfügung habe.

      Wie viele Kerne kann ich insgesamt den einzelnen VMs zuweisen?

       

      error2.png

       

      Abschließend noch eine Frage zu einer Warnung im ESXi-Server.

      Laut dem ESXi, soll ich VMWare Photon OS als Gastbetriebssystems des vCenters angeben. Dies steht aber nicht zur Auswahl.

      Gibt es einer alternative um die Warnung zu beheben?

       

      error3.png

       

      Vielen Dank

      Domenik

        • 1. Re: Problem mit vCenter und Arcserve + diverse Fragen
          a.p. Guru
          vExpertUser ModeratorsCommunity Warriors

          Willkommen im Forum,

           

          zu Deinen Fragen:

           

          1. Ich habte mit ArcServe Backup bisher noch nichts zu tun. Der Meldung am unteren Bildrand würde ich jedoch entnehmen, dass das Tool erwartet, dass die vCenter Server Zertifikate vertrauenswürdig sind. Was Du machen kannst, ist im Browser auf die Startseite des vCenter Server's zu gehen. Dort ist unten rechts ein Link zum Download der Zertifikate. Nach dem Entpacken der Zip-Datei sind die Zertifikate in den Computer-Speicher unter Vertrauenswürdige Stammzertifikate zu importieren. Danach solltest Du im Browser keine Warnmeldung mehr bekommen, wenn Du die vCenter Server Seite aufrufst, d.h. dem Zertifikat wird nun vertraut. Wenn dem so ist, sollte m.E. auch das ArcServer Tool wie erwartet funktionieren.
          2. Im Prinzip können einer VM so viele vCPUs zugewiesen werden, wie die Hardware hergibt, sofern das Gastbetriebssystem dies unterstützt. Jedoch empfehle ich nicht vorgefertigte Appliances anzupassen, da könnte der Schuss schnell nach hinten losgehen.
          3. Auch hier gilt, bitte keine Anpassung in der Einstellungen bzgl.Gastbetriebssystem vornehmen. Die Meldung kann ignoriert werden.


          André

          • 2. Re: Problem mit vCenter und Arcserve + diverse Fragen
            DomenikM Lurker

            Hallo Andre,

            vielen Dank für dein Hilfe.

             

            1. Das selbe denke ich auch. Bei den Zertifikaten aus dem vCenter habe ich das Problem, dass nur der Hostname im Zertifikat hinterlegt ist (vcenter.domain.tld). Sobald ich das vCenter im Browser dann über den DNS auflösen lasse, wird mir das Zertifikat auch richtig angezeigt. Sobald ich aber direkt über die IP-Adresse auf das vCenter zugreife, bekomme ich die Meldung, dass das Zertifikat nicht vertrauenswürdig ist. Ich denke, dass Arcserve ebenfalls versucht über die IP-Adresse auf das vCenter zuzugreifen. Gibt es eine Möglichkeit die IP-Adresse manuell im Zertifikat zu hinterlegen?
            2. In der Verwaltungsoberfläche ist aufgelistet, dass ich 16 logische Prozessoren, 1 Socket und 8 Kerne pro Socket habe. Kann ich meinen VMs dann insgesamt 16 oder 8 Kerne zuteilen? Was bedeuten die logischen Prozessoren?
            3. Vielen Dank, dann werde ich die Warnung stehen lassen

             

            Vielen Dank für deine Hilfe und viele Grüße

            Domenik

            • 3. Re: Problem mit vCenter und Arcserve + diverse Fragen
              a.p. Guru
              vExpertUser ModeratorsCommunity Warriors
              1. Das Verhalten ist schon richtig so. Nur wenn der eingegebene FQDN mit dem im Zertifikat hinterlegten Namen übereinstimmt, wird das Zertifikat als gültig erkannt. In Zertifikaten, die über eine CA beantragt und erstellt werden kann ein zusätzlicher SAN (Subject Alternative Name) mit z.B. der IP-Adresse hinterlegt werden. Dies ist bei dem vCenter selfsigned Zertifikat leider nicht der Fall. Jedoch gehe ich davon aus, dass wenn der FQDN im Arcserve Tool eingegeben wird, dieser auch benutzt wird. Laut Doku kann durch Aktivieren von "Debug" eine Logdatei im Verzeichnis C:\Program Files\CA\ARCserve Backup Client Agent for Windows\LOG erzeugt werden. Mach das doch bitte mal und schau, ob die Einträge in der Logdatei Aufschluss auf das Problem geben.
              2. Logische Prozessoren sind die physikalischen Cores multipliziert mit 2, sofern HyperThreading aktiviert ist. Prinzipiell kann jeder VM die volle Anzahl an vCPUs (entspricht den logischen Prozessoren) zugewiesen werden. Bei Überbuchung - d.h. alle VMs zusammen haben mehr vCPUs zugewiesen, als vorhanden - müssen sich die VMs natürlich die Resourcen teilen (Bitte auch daran denken, dass der ESXi Host selbst auch CPU Zeit benötigt!). Das CPU-Scheduling in ESXi funktioniert hier sehr gut, nur sollte natürlich nicht so viel überbucht werden, dass das System zum Erliegen kommt.

               

              André

              • 4. Re: Problem mit vCenter und Arcserve + diverse Fragen
                DomenikM Lurker

                Hallo Andre,

                nochmal vielen Dank für deine Antwort.

                 

                1. Habe die Logdatei aus dem Debug-Modus nun vorliegen. Eventuell kannst du was mit der Fehlermeldung anfangen.

                 

                fehler_debug.png

                 

                Viele Grüße

                Domenik

                • 5. Re: Problem mit vCenter und Arcserve + diverse Fragen
                  Crackwall Lurker

                  Guten Morgen,

                   

                  ich hatte das gleiche Problem mit Arcserve. Ich gehe davon aus das vSphere 6.7 eingesetzt wird. Zur Sicherung der VMs in dieser vSphere Version mit Arcserve ist folgendes zu beachten.

                  Erst Arcserve 18 suported 6.7. Hinzu kommt das auf dem Arcserve Server / Proxyserver .NET 4.7 installiert werden muss. Dann müssen noch 4 Registry Einträge gemacht werden.

                  Path 1: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319

                  DWORD Key: SchUseStrongCrypto = 1

                  DWORD Key: SystemDefaultTlsVersions = 1

                   

                  Path 2: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319

                  DWORD Key: SchUseStrongCrypto = 1

                  DWORD Key: SystemDefaultTlsVersions = 1

                   

                  Wenn man im VMware Agent Dokument nach TLS sucht findet man diese Vorgaben für die Nutzung von Arcserve mit VMware 6.7.

                  Vsphere 6.7 nutzt nur TLS 1.2, alle vorhergehenden Version aber nur TLS 1.1/1.0.

                   

                  Nach diesen Änderungen auf dem Arcserve Server konnte ich das Backup durchführen.

                  Mit Arcserve 17.5 und ESX 6.5 sowie früherer Version besteht das Problem nicht.

                   

                  Gruß

                  Thomas

                  • 6. Re: Problem mit vCenter und Arcserve + diverse Fragen
                    DomenikM Lurker

                    Hallo Thomas,

                    vielen Dank!

                     

                    Darauf muss man auch erst einmal kommen.. Hat mit deiner Beschreibung soweit funktioniert!

                     

                    Folgende Probleme haben sich jetzt noch herausgestellt:

                     

                    1. Sobald ich das vCenter über den vSphere Web Client (Flex) aufrufen möchte, wird mir nicht mehr als eine leere, weiße Seite angezeigt. Ausprobiert habe ich das ganze mit dem aktuellen IE, Firefox und Google Chrome. Hat jemand eine Idee?
                    2. Zudem läuft die Sicherung mit Arcserve noch immer nicht, wie sie sollte. Scheinbar versucht VMWare ein Snapshot zu erstellen und damit das Dateisystem "still zu legen". Folgende Fehlermeldungen liegen vor (das erstellen des Snapshots funktioniert auch manuell im vCenter nicht):

                     

                    ausgang.PNG

                     

                    fehler 1.PNG

                    fehler 2.PNG

                    fehler 3.PNG

                     

                    Hat noch jemand eine Idee hierzu?

                     

                    Viele Grüße

                    Domenik

                    • 7. Re: Problem mit vCenter und Arcserve + diverse Fragen
                      Crackwall Lurker

                      Hallo Domenik,

                       

                      ich würde für das erste Problem das VCenter mal durchstarten. Dazu dann noch den Browsercache leeren.

                       

                      Das Problem 2 mit dem Snapshot scheint ernster zu sein.

                      Test1: Einen der ESX Server in Arcserve einbinden und dann ein Backup einer kleinen VM (Testmaschine) machen. Wenn das funktioniert, ist schon mal auf diesem ESX Server alles soweit in Ordnung.

                      Test2: Gleiche VM über das VCenter sichern. Fuktioniert? Nein, Problem in der Kommunikation VCenter/ESX Server??. Case bei VMware aufmachen.

                      Test3: Backup läuft ohne Probleme mit den Test VMs -> Dann eine VM in dieses Testbackup aufnehmen, die aktuell ein Problem hat. Backup erneut durchführen. Ergebnis? Backup läuft auf Fehler, Problem muss in der VM liegen. Fehleranalyse der VM. Reboot der VM/VMware Tools deinstallieren und neuinstallieren usw.

                       

                      Gruß

                      Thomas