1 2 Previous Next 26 Replies Latest reply on Jul 18, 2019 9:50 PM by vmwarejw Go to original post
      • 15. Re: Shared folders horrendously slow
        Brian Raynor Lurker

        Thanks for the info.  Actually I've never had a problem with corruption with the PSTs, either when using VMWare Shared Folders or when using standard network shares from the VM.

         

        Its just that Outlook would forget where they were. 

         

        Since I did the LMHOSTs thing at least for a few hours, everything seems to be fine using Shared Folders for the PSTs.  (other than the fact Outlook is still seeing my previous links to the PST folders - looks like an Outlook bug, it won't let me remove them nor will it let me open them).

        • 16. Re: Shared folders horrendously slow
          pm100 Novice

          yeehaa - fixed the problem for me.

           

          VMware needs to fix this (dont suppose they read these forums though )

          • 17. Re: Shared folders horrendously slow
            ramy8 Novice

            I put the "127.0.0.1" .host fix in my lmhosts file in WinXP.

             

            I'm on ubuntu 6.10 host with a WinXP guest.

             

            The sharing is just horrendously slow in the beginning. Like if I click on a folder, it just sits there for like 10 secs and then goes ahead to list the files.. It catches up speed after that, but if you do something esle for like 10 secs (other than browsing the share..) you will see the slow down again.

             

             

            Anyone know how I can fix this for sure??

            • 18. Re: Shared folders horrendously slow
              ramy8 Novice

              bump?

              • 19. Re: Shared folders horrendously slow
                luvr Novice

                I put the "127.0.0.1" .host fix in my lmhosts file in

                WinXP.

                 

                You did include the #PRE[/b] parameter on the line, didn't you?

                • 20. Re: Shared folders horrendously slow
                  Novice

                  For what it's worth, we believe we fixed something like this in the WS6 Tools. The problem we encountered had to do with Windows' concept of network providers. These are loaded into explorer via dlls and are responsible for translating the
                  stuff namespace into appropriate filesystem requests. Anyway, Windows likes to put LanmanWorkstation at the top of the list, which means it gets first crack to requests for
                  .host\Shared Folders.

                   

                  Unfortunately, LanmanWorkstation also takes a very long time to timeout, which makes the first access to any share take forever (because LanmanWorkstation must time out, and only then does the HGFS provider get to run). Note that this should only affect share discovery, not file transfers.

                   

                  For WS6, we worked around this by installing the HGFS provider at the top of the list. Check out HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order to see what I mean.

                   

                  More information here:

                  http://www-1.ibm.com/support/docview.wss?uid=swg21135684

                  http://msdn2.microsoft.com/en-us/library/aa378776.aspx

                  • 21. Re: Shared folders horrendously slow
                    dsoong Lurker

                    My guest OS is Linux. It is so slow it is unusable. This is on a new Dell D630 laptop. The same VM works fine on Dell D620 laptop. I It is still slow after restinalling the VMWare tools. It is copying a few KB about every 30 seconds.

                    • 22. Re: Shared folders horrendously slow
                      maj13205 Lurker

                       

                      Can you please tell me how to map a shared folder to a logical drive?

                       

                       

                       

                       

                       

                      Thanx in advance

                       

                       

                      • 23. Re: Shared folders horrendously slow
                        0xG Novice

                         

                        Still a problem with WS 6.1 at least.

                         

                         

                        Yeah, PST files die unless you just use plain old SMB share...

                         

                         

                        • 24. Re: Shared folders horrendously slow
                          nextech Hot Shot

                          Brian,

                           

                          I had a similar problem, I posted the solution to this problem here:

                           

                           

                          http://communities.vmware.com/message/1191790#1191790

                           

                           

                          I hope this helps, I believe this should solve your problem. Please

                          close this thread out, and mark it as "Answered" and If you find

                          this answer helpful, please do take the time to award me the "Correct Answer" points. 

                           

                           

                          Thank-you!

                           

                           

                          Mark

                          • 25. Re: Shared folders horrendously slow
                            Kadu123 Lurker

                            This has annoyed me for ages and I have finally found the proper cause/solution:

                             

                            This  slow performance, specially the 5-10 seconds delay between clicking on a  folder/file and actually getting it opened, happens because Widnows is  trying to access the share via NetBIOS protocol. Once the NBT attempt  fails windows reverts back to TCP, which then works OK.

                             

                            So the solution is to disable netbios over TCP/IP on all network interfaces inside the Windows client.

                             

                            Hope this helps more people out there.

                             

                            For Windows XP, Windows Server 2003, and Windows 2000

                            1. On the desktop, right-click My Network Places, and then click Properties.
                            2. Right-click Local Area Connection, and  then click Properties
                            3. In the Components checked are used by this connection list, double-click Internet Protocol (TCP/IP), click Advanced, and then click the WINS tab.

                              Note In Windows XP and in Windows Server 2003, you must double-click Internet Protocol (TCP/IP) in the This connection uses the following items list.
                            4. Click Disable NetBIOS over TCP/IP and then click OK three times.

                            For Windows Vista

                            1. On the desktop, right-click Network, and then click Properties.
                            2. Under Tasks, click Manage network connections.
                            3. Right-click Local Area Connection, and  then click Properties
                            4. In the This connection uses the following items list, double-click Internet Protocol Version 4 (TCP/IPv4), click Advanced, and then click the WINS tab.
                            5. Click Disable NetBIOS over TCP/IP, and then click OK three times.

                            For Windows 7

                            1. Click Start, and then click Control Panel.
                            2. Under Network and Internet, click View network status and tasks.
                            3. Click Change adapter settings.
                            4. Right-click Local Area Connection, and then click Properties.
                            5. In the This connection uses the following items list, double-click Internet Protocol Version 4 (TCP/IPv4), click           Advanced, and then click the WINS tab.
                            6. Click Disable NetBIOS over TCP/IP, and then click OK three times.
                            • 26. Re: Shared folders horrendously slow
                              vmwarejw Novice

                              This is really bad advice. Don't just take a sledgehammer and disable NetBIOS "on all network interfaces inside the Windows client". There are reason for keeping NetBIOS active and I have several VMs that have it enabled and that do not suffer from any performance degradation while browsing the guest file system as a share to the host.

                              1 2 Previous Next