1 Reply Latest reply on Jun 21, 2019 3:00 AM by MPGroup

    Datastore empty: VMware ESXi 6.5 and NFS Share on StoreOnce 4500

    MPGroup Lurker

      Hello guys,

       

      I have a problem that my Datastore which is mounted via NFS into my vCenter infrastructure is empty. We are using a HP StoreOnce 4500 and it's connected with two 10GB SFP modules configured as simple failover.

      We had to update our system software from 3.15.x to 3.18.x because we ran into a bug that the NFS connection is lost. I have talked to HP how to perform the update and everything went fine. After the update I had to upgrade all needed components to the appropriate firmware version. The system now runs like a charm, but since the last reboot I don't see any data within the browser of my vCenter. I have also tried to use SSH, but it always shows "Total 0" with "ls -la".

       

      The problem is, that there are virtual disks on the datastore and the VM can connect to it so it's starting like nothing happened. But when I want to move something TO the datastore it's not possible and the error I get doesn't say anything. But FROM the datastore to another datastore from another hardware it's working. We also have datastores connected which are placed on HP 3PAR Storage system. Every datastore I have here is working. I also can browser through the files. It doesn't matter if it's with SSH or the datastore browser in vCenter.

       

      I searched the community and found some articles about a master host through which the vCenter is connecting to browse the datastores. I have done all the steps in these articles, but nothing is getting better.

      All data on the NFS share seems to be available because on my management GUI of the StoreOnce system it shows me the used space. I have created a NFS share for testing, but it's the same problem. I connect the datastore, everything is going fine, but I cannot browse it. There are no files.

      I tried every host in my cluster, but none of my host shows me any files or folders. It doesn't matter if SSH or datastore browser.

       

      I hope someone can help me to figure out the problem and find a solution.

       

      Thank you very much.

       

      Best regards,

      Michael