6 Replies Latest reply on May 16, 2019 11:42 PM by abewong111

    Unable to login with "root" user after changing the password

    Virtual_ATG Lurker

      Hi All ,

       

      I have this problem :

       

      After logging in to the Esxi host web interface with the root user, I changed the password, logged out and then tried to log in again but I can't log in anymore, it tells me the password is wrong, although after changing it came out "password updated successfully".

       

      How i can solve this issue?

       

      Best regards

       

      Andrea

        • 1. Re: Unable to login with "root" user after changing the password
          continuum Guru
          Community WarriorsUser ModeratorsvExpert

          Most probable reason: you entered the password while assuming that the webinterface uses your regular keyboard layout when it actually uses US-layout.
          Try to enter the password like you would do it with US-layout - or the other way round.

          • 2. Re: Unable to login with "root" user after changing the password
            Virtual_ATG Lurker

            Hi Continuum ,

             

            In the Esxi web interface I don't see any possibility to change the keyboard layout, in any case I am logged in at this moment with another user who has administrator privileges, and when I change the root password I get the message that the password has been changed correctly, but it does not let me log in with the root user as it says that the credentials are wrong.

             

            Best regards

             

            Andrea

            • 3. Re: Unable to login with "root" user after changing the password
              continuum Guru
              User ModeratorsCommunity WarriorsvExpert

              I did not mean that you should change the keyboard layout - that option is not available as far as I know.
              My admin host for example uses german keyboard layout. In german and US-layout the letters Y and Z are exchanged.
              So if I thought my root password was set to ZZZ123456 I would try YYY123456 instead.
              In case you use a non US-keyboard layout - google for a US-keyboard map and check if you need to exchange characters.
              Just check it - this is by far the most probable - and harmless reason for your problem !

              • 4. Re: Unable to login with "root" user after changing the password
                VMwaretester001 Novice

                I have had a similar issue with my systems as well sometimes. For me I found leaving the system a while to allow it to propagate the change to all of the relevant services was the trick for me.

                 

                If that doesn't work, then I guess you only have a few options left to you. If you are running above 5.5 you wont be able to recover your password. 5.5 and below there is a KB on how to reset the password.

                 

                In the mean time though before you do anything else, plug a monitor and keyboard into the ESXi host and try both the old and new passwords at the root console. If the new password works then it's just a case of waiting for the system to refresh its self. Which is what I typically have to do sometimes, I typically try the next day. If either passwords fail then you going to have to re-install just the ESXi software onto the host. Lucky to can do this without having to wipe your datastore.

                 

                Massive pain in the backside, to have to re-install and set things back up but the only resort, which I have had to do.

                • 5. Re: Unable to login with "root" user after changing the password
                  Virtual_ATG Lurker

                  Hi All ,

                   

                  I inform you that I managed to solve the problem by resetting the password directly from the terminal via the KVM and then restarting the Management services, thanks to everyone for the help.

                   

                  Best regards

                   

                  Andrea

                  • 6. Re: Unable to login with "root" user after changing the password
                    abewong111 Lurker

                    Hello Continuum,

                                我是中国一家公司的职员,我在涉及VMware项目的实施中也遇到过类似的问题,我使用的是6.7版本,6.7U1和6.7U2暂时没有使用,担心其他问题。

                    我在第一次遇到类似问题时,差点以为自己手残了,多次输入密码都是提示我有错误,而同时配置同一群集8台设备,有3台存在这样的故障,另外几台正常,才考虑到会是ESXi软件问题。

                    但是一时不知道怎么解决,索性我就在正常群集中部署VCSA,当然,6.7及以后版本的VCSA还有DNS等新问题,这是另一个故事了。安装完VCSA之后,发现ESXi可以正常登陆了。

                    所以我建议遇到类似问题先不要着急处理,给ESXi一个喘息的时间。

                    当然,时后在分析原因的时候,我判断可能是因为本地登录认证服务没有在client-UI服务之前启动,而且发生了延迟启动,具体延迟多少秒没有测过,但是基本会超过10分钟。

                    另一种方案就是通过SSH连接到ESXi camand-line 模式,手动启动或重启相关服务。可能会解决这个问题。

                     

                    just wait 。