9 Replies Latest reply on Apr 19, 2019 9:06 AM by BillHudacek

    This may be because the root password is required to register your license.

    zzhao Lurker

      Today, I tried to install Workstation 10 on Ubuntu 14.04 x64. When I run vmware with root.

      It prompts me license dialog. But when I tried to use trial license, it warns me

      "Failed to register license. This may be because the root password is required to register your license. Please contact a system administrator with any questions."

       

      What's the problem, Do anyone can help me? Thank you!

        • 1. Re: This may be because the root password is required to register your license.
          raghavan14 Lurker

          Hi,

           

          I faced this issue when I was trying to install WS on Ubutnu 12.04 LTS. So, after playing

          around with many things, I installed one of the previous versions of WS which took the

          license entered and got fully installed. And then I was able to install and use WS 10.

           

          Hope this helps though the real issue is unclear.

           

          Cheers,

          Raghavan

          • 2. Re: This may be because the root password is required to register your license.
            rbarrett77 Novice

            I'm having the exact same problem.  I had a previously licensed version of workstation 9, have upgraded to 10 and getting error message when entering the license key OR trying to accept a trial.

            • 3. Re: This may be because the root password is required to register your license.
              BradCampbell Novice

              I bumped up against this sometime this morning. It's an annoying fault with a simple fix.

              VMware supply their own version of gksu and it can't find some of its dependencies.. I'm sure there is a better fix as the VMware bundle appears to have these libraries, but the quick and easy fix was

              apt-get install libstartup-notification0 libgtop2-7

               

              brad@cadbox:/usr/lib/vmware/bin$ ldd /usr/lib/vmware/lib/libgksu2.so.0/libgksu2.so.0
                  linux-vdso.so.1 =>  (0x00007fffa41ff000)
                  libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007f8013a03000)
                  libstartup-notification-1.so.0 => not found
                  libgtop-2.0.so.7 => not found
                  libgtk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0 (0x00007f80133c3000)
                  libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f8013039000

               

              I installed libgtop and libstartup-notification and the problem magically went away.

              1 person found this helpful
              • 4. Re: This may be because the root password is required to register your license.
                rbarrett77 Novice

                i also solved/got around it, but in a different way.  i uninstalled workstation.  removed old kernel header files

                 

                sudo apt-get remove linux-headers-

                sudo apt-get install linux-headers-$(uname -r)

                 

                reinstalled the same vmware image (10.0.3)

                entered key during install process

                 

                all good.

                2 people found this helpful
                • 5. Re: This may be because the root password is required to register your license.
                  zzhao Lurker

                  I gave up to install Workstation on my server, It added lots of iptable entries to ruin my original settings, but thank you all. I will give it a try when I get a new box.

                  • 6. Re: This may be because the root password is required to register your license.
                    bitdancer Lurker

                    I just worked my way through this.  The answer is twofold, at least with the current 12 pro installer.  There's a script (wrapper-gtk24.sh) that adds all the many directories containing the shared libs to the LD_LIBRARY_PATH.  But it doesn't have any entry for libgtop, even though that is shipped.  It doesn't have an entry for libstartup-notification, either, and that one is not shipped.  So your solution works, but you can get away with just installing startup-notification and doing "LD_LIBRARY_PATH=/usr/lib/vmware/libgtop-2.0.so.7 vmware".  Looks like they don't test this on a system without all those shipped libraries.

                    • 7. Re: This may be because the root password is required to register your license.
                      brianstock Novice

                      In my case, I was able to register Workstation in Trial mode by finding a product key in the vmware-apploader logs (/tmp/vmware-<non-root username>/vmware-apploader-<numeric ID>.log on my system) after running the VMware GUI and entering that key through a GUI accessed with "sudo /usr/lib/vmware/bin/vmware-enter-serial".

                       

                      The line containing the key is: Invocation: Invocation: "/usr/lib/vmware/bin/vmware-gksu --sudo-mode --message=Please enter your password to proceed. /usr/lib/vmware/bin/licenseTool enter ABCDE-12345-FGHIJ-67890-A1B2C   10.0+ VMware Workstation /usr/lib/vmware"

                       

                      where "ABCDE-12345-FGHIJ-67890-A1B2C"is the product key.

                      • 8. Re: This may be because the root password is required to register your license.
                        RonanM Lurker
                        VMware Employees

                        I hit this with an upgrade to workstation 15 on ubuntu

                         

                        open a terminal and run

                         

                        sudo vmware

                         

                        This will allow you to enter your license key. Then close and you can run vmware workstation as a normal user.

                         

                         

                        Here is the actual error:

                        Authentication is needed to run `/usr/lib/vmware/bin/licenseTool' as the super user

                         

                        I think there is some problem requesting permissions so just run in terminal as root as a once off to set the licence

                        • 9. Re: This may be because the root password is required to register your license.
                          BillHudacek Lurker

                          I'm running Fedora 29 now.  Kernel 5.0.6-200.fc29.x86_64.  Using Xfce4.  It's amazing to me that this bug (ok, this *symptom*) is still occurring FIVE years later.

                           

                          VMWare installed fine - Fedora 29 is officially supported now. But, on starting VMWare, you get the 'enter license key' dialog, and no matter what happens, you see: "Failed to register license. This may be because the root password is required to register your license. Please contact a system administrator with any questions."

                           

                          I am a linux master.  A guru.  I hacked at this for hours - scripting, hacking, symlinking vmware libraries (without trashing the rest of my system).

                           

                          In the end, the only thing that worked is uninstalling, and entering my (newly-received valid license key) during install.

                           

                          I just wanted google to find this so others can find this "solution" more quickly.

                           

                          N.B.  The vmware-supplied libraries are not configured correctly - they can't even find each other.  LD_LIBRARY_PATH was carefully (surgically!) configured by software I wrote, and that did not avoid this error message. So I never did identify root cause.