3 Replies Latest reply on Mar 29, 2019 5:20 AM by Texiwill

    I'm having trouble installing the vmware tools, version on 10.3.5 on a windows 10 machine

    gmknobl Lurker

      We keep getting the notice as soon as we start the installation "This installer requires you to restart your system to finish installing Microsoft VC Redistributable and then re-run the installer.  For details, refer to the following <A HREF="https://kb.vmware.com/kb/55798"> Knowledge Base article</A>.  Click Yes to restart now or No if you plan to manually restart later.

       

      The problem is this happens as soon as we run the installer.  When we reboot and run the installer again, the same thing happens.  We've tried this multiple times.

       

      We are installing this on a Windows Server 2016 unit with Visual C++ 2017 Redistributable installed.  I have tried to use the REBOOT=reallysuppress option - passing it on with the /v option also with no success though I may not have done that correctly.

       

      Is there a solution for this?

        • 1. Re: I'm having trouble installing the vmware tools, version on 10.3.5 on a windows 10 machine
          gmknobl Lurker

          I am not sure what I'm looking for but the first thing I see is:

           

          2019-03-13T11:38:15.932Z| vcpu-0| I125: GuestRpc: Reinitializing Channel 1(toolbox-dnd)

          2019-03-13T11:38:23.788Z| svga| I125: MKSScreenShotMgr: Taking a screenshot

          2019-03-13T11:39:14.390Z| vcpu-2| W115: GuestRpc: application toolbox-dnd, changing channel 65535 -> 1

          2019-03-13T11:39:14.396Z| vcpu-2| I125: GuestRpc: Channel 1, guest application toolbox-dnd.

          2019-03-13T11:39:24.444Z| svga| I125: MKSScreenShotMgr: Taking a screenshot

          2019-03-13T11:40:00.159Z| vcpu-1| I125: Guest: Command line: /s /v/qn REBOOT=ReallySuppress

          2019-03-13T11:40:00.170Z| vcpu-0| I125: Guest: Installing VMware Tools 10.3.5.7752 (build-10430147)

          2019-03-13T11:40:03.051Z| vcpu-3| I125: Guest: Reboot required by VC x86 Redist

           

          Which does not tell me anything other than what the pop up message said.

           

          I also see this:

           

          2019-03-13T11:44:39.392Z| vmx| I125: TOOLS installed legacy version 10309, available legacy version 10279

          2019-03-13T11:44:39.392Z| vmx| I125: TOOLS manifest update status is 4

          2019-03-13T11:44:39.392Z| vmx| I125: TOOLS can be autoupgraded.

          2019-03-13T11:44:39.396Z| vmx| I125: TOOLS autoupgrade protocol version 0

           

          Then a little later

           

          2019-03-13T11:45:00.037Z| vcpu-0| I125: Tools: Tools heartbeat timeout.

          2019-03-13T11:45:00.037Z| vcpu-0| I125: Tools: Running status rpc handler: 1 => 0.

          2019-03-13T11:45:00.037Z| vcpu-0| I125: Tools: Changing running status: 1 => 0.

           

          other lines

           

          2019-03-13T11:45:01.591Z| vcpu-0| I125: Tools: ToolsRunningStatus_Reset, delayedRequest is 0x0

           

          2019-03-13T11:45:16.037Z| vcpu-0| I125: Tools: Running status rpc handler: 0 => 1.

          2019-03-13T11:45:16.037Z| vcpu-0| I125: Tools: Changing running status: 0 => 1.

           

          2019-03-13T11:45:38.771Z| vmx| I125: TOOLS soft reset detected.

          2019-03-13T11:45:38.772Z| vmx| I125: TOOLS cleared guestinfo.toolsInstallErrCode.

          2019-03-13T11:45:38.772Z| vmx| I125: TOOLS autoupgrade protocol version 2

          2019-03-13T11:45:38.773Z| vmx| I125: Vix: [148672 mainDispatch.c:4151]: VMAutomationReportPowerStateChange: Reporting power state change (opcode=2, err=0).

          2019-03-13T11:45:38.774Z| vmx| I125: TOOLS Received tools.set.versiontype rpc call, version = 10309, type = 1

          2019-03-13T11:45:38.774Z| vmx| I125: Tools_SetVersionAndType did nothing; new tools version (10309) and type (1) match old Tools version and type

          2019-03-13T11:45:38.774Z| vmx| I125: TOOLS Setting autoupgrade-checked FALSE.

          2019-03-13T11:45:38.774Z| vmx| I125: Starting copy guest manifest.

          2019-03-13T11:45:38.790Z| vcpu-0| I125: HGFileCopyCreateSessionCB: Successfully created the session.

          2019-03-13T11:45:38.899Z| vcpu-2| I125: ToolsLoadManifestFileCB: Queuing a request to update the manifest information.

          2019-03-13T11:45:39.338Z| Worker#1| I125: ToolsISO: Selected Tools ISO 'windows.iso' for 'windows9srv-64' guest.

          2019-03-13T11:45:39.338Z| Worker#1| I125: GetHostManifests: Extracting the manifest file.

          2019-03-13T11:45:39.435Z| Worker#1| I125: GetHostManifests: Done extracting the manifest file.

          2019-03-13T11:45:39.477Z| Worker#1| I125: ToolsVersion: Status is supported new because this is status of monolithic version, and vnetflt_Win8 is missing from the guest.

          2019-03-13T11:45:39.477Z| Worker#1| I125: ToolsVersionGetStatusWorkerThread: Tools status 4 derived from environment

          2019-03-13T11:45:39.478Z| vmx| I125: ToolsUpdateManifestInfoWorkerThreadDone: Compared tools manifest from host and from the guest. Status = 4.

          2019-03-13T11:45:39.478Z| vmx| I125: ToolsUpdateManifestInfoWorkerThreadDone: Updating the manifest info.

          2019-03-13T11:45:39.478Z| vmx| I125: VMXVmdb_SetToolsVersionStatus: status value set to 'ok', 'supportedNew', install possible

          2019-03-13T11:45:39.478Z| vmx| I125: TOOLS installed legacy version 10309, available legacy version 10279

          2019-03-13T11:45:39.478Z| vmx| I125: TOOLS manifest update status is 4

          2019-03-13T11:45:39.478Z| vmx| I125: TOOLS can be autoupgraded.

          2019-03-13T11:45:39.478Z| vmx| I125: TOOLS Setting autoupgrade-checked TRUE.

           

          What should I be looking for?

          • 2. Re: I'm having trouble installing the vmware tools, version on 10.3.5 on a windows 10 machine
            vJoeG Hot Shot
            VMware Employees

            Good afternoon,

             

            What build of Windows 10 are you running? And have all the current updates applied?

             

            Before responding I just took a Windows 10 1803 gold image and manually applied 10.3.5 tools to it without this error as a test.

            • 3. Re: I'm having trouble installing the vmware tools, version on 10.3.5 on a windows 10 machine
              Texiwill Guru
              vExpertUser Moderators

              Hello,

               

              Can you provide three things? What VMware product are we discussing (vSphere, Fusion, Workstation)? and what version of Windows 10?

               

              I have yet to have an issue with upgrading tools on windows 10 within Fusion or vSphere. I do not use Workstation so do not know. The only issue I have is whether or not the automated approach works. When the automated approach fails, I use a manual approach and that tends to solve the issues. I do know that sometimes, the underlying Guest OS may need to be upgraded before some tools are applied.

               

              I would also remove any older tools, reboot, then apply new tools.

               

              Best regards,