2 Replies Latest reply on Feb 11, 2019 4:20 AM by JohnTwilley

    display and mouse issues after tools updates

    glassin Novice

      I have found alot to try but none of it is working for me at the moment.  We are on horizon 6.2.3, vmtools was 10.1.  I updated my parent image to vmtools 10.2.5 and my end users began reporting a problem at the disclaimer page where the mouse jumps to the right and they can't click 'ok'  (space bar works)  Found sometime later some other seemingly display issues so i rolled my image back to 10.1.  Recently i found after windows updates the tools got updated again so i figured i would look into this harder.  I've found some forums where the resolution is registry changes, these are the teridici forums for the zero clients ast well as vm forums for my windows boxes

       

      https://communities.teradici.com/questions/9104/horizon-74-mouse-pointer-effects-lost.html

      Windows 10: Fall Creators Build 1709 Experiences 

      1. For PCOIP/BLAST protocol, update the following in the View agent machine.
      2. - Go to HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware SVGA DevTap
      3. - Create a DWORD with name WDDMDevAPIversion and set it to 1.
      4. - Create key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\VMware, Inc.\VMware SVGA DevTap
      5. - Go to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\VMware, Inc.\VMware SVGA DevTap
      6. - Create a DWORD with name WDDMDevAPIversion and set it to 1.

       

      VMware Knowledge Base 

       

      1. n the View desktop, click Start > Run, type regedit, and click OK. The Registry Editor window opens.
      2. Go to HKEY_LOCAL_MACHINE\Software\Policies\Teradici\PCoIP\pcoip_admin_defaults.
      3. Set pcoip.disable_cursor_jumping to 1.

       

      None of this has worked and it seems to be all I am finding.  On my test i'm going to update the agent to 6.2.7 and try to repair tools but any further thoughts are appreciated.