7 Replies Latest reply on Feb 8, 2019 11:21 PM by JessieZhang

    Vagrant/Virtualbox Migrated machine doesn't work: Error: Unknown Error

    coogle Lurker

      Hello,

       

      We are evaluating using VMWare instead of Virtualbox for our development environments and have been in the process of migrating the VMs. For the most part, things have been going relatively smoothly however we've encountered a show-stopper that we really need to get resolved.

       

      The machine itself is one of our older dev environments we are migrating away from and runs an older guest (Ubuntu 16!). Our host environment is Mac OS X 10.13.6

       

      We've traced the error to VMWare specifically when Vagrant tries to run this command:

       

      $ /Applications/VMware\ Fusion.app/Contents/Library/vmrun enableSharedFolders "/Volumes/Dev/app/.vagrant/machines/default/vmware_fusion/5c75a125-2d9b-4e00-9807-81c3e6045102/app-v2.vmx"
      Error: Unknown Error

       

      We used the exact same process of migrating this VM as the other two we've done successfully, and we're stuck as we can acquire no more debugging information than simply "Unknown Error". Please help!

        • 1. Re: Vagrant/Virtualbox Migrated machine doesn't work: Error: Unknown Error
          continuum Guru
          Community WarriorsUser ModeratorsvExpert

          Edit the file app-v2.vmx and remove the lines that specify shared folders.

          Looks like at least one of those lines uses a bad syntax or specifies  a non existant path.

          • 2. Re: Vagrant/Virtualbox Migrated machine doesn't work: Error: Unknown Error
            coogle Lurker

            Unfortunately that isn't it. I checked the .vmx and I don't have any shared folder entries at all -- they seem to be added at run time by vagrant perhaps?

             

            Regardless of vagrant however, when I just run the 'vmrun' commmand without vagrant I still get the error.

             

            I've also logged into the VM and re-ran vmware-config-tools and that ran without errors..

             

            Looking at my vmware.log file during the boot up process I see this:

             

            2019-02-07T14:06:40.421-05:00| vmx| I125: GuestRpcSendTimedOut: message to toolbox timed out.

            2019-02-07T14:06:50.334-05:00| vcpu-1| I125: Guest: toolbox: Version: build-562307

            2019-02-07T14:06:50.334-05:00| vcpu-1| W115: GuestRpc: application toolbox, changing channel 65535 -> 0

            2019-02-07T14:06:50.334-05:00| vcpu-1| I125: GuestRpc: Channel 0, guest application toolbox.

            2019-02-07T14:06:50.334-05:00| vcpu-1| I125: DEPLOYPKG: ToolsDeployPkg_Begin: state=0 err=0, msg=null

            2019-02-07T14:06:50.334-05:00| vcpu-1| I125: Tools: [AppStatus] Last heartbeat value 0 (never received)

            2019-02-07T14:06:50.368-05:00| vcpu-1| I125: Tools: Changing running status: 0 => 2.

            2019-02-07T14:06:50.368-05:00| vcpu-1| I125: Tools: [RunningStatus] Last heartbeat value 0 (never received)

            2019-02-07T14:06:50.368-05:00| vcpu-1| I125: Tools: Removing Tools inactivity timer.

            2019-02-07T14:06:50.369-05:00| vcpu-1| I125: TOOLS Received tools.set.version rpc call, version = TOOLS_VERSION_UNMANAGED, type is unknown

            2019-02-07T14:06:50.369-05:00| vcpu-1| I125: TOOLS Setting toolsVersionStatus = TOOLS_STATUS_UNMANAGED

            2019-02-07T14:06:50.369-05:00| vcpu-1| I125: Tools_SetVersionAndType did nothing; new tools version (2147483647) and type (0) match old Tools version and type

            2019-02-07T14:06:50.385-05:00| vcpu-10| I125: TOOLS state change 3 returned status 1

            2019-02-07T14:06:50.385-05:00| vcpu-10| I125: Vix: [mainDispatch.c:4150]: VMAutomationReportPowerStateChange: Reporting power state change (opcode=2, err=0).

            2019-02-07T14:06:50.385-05:00| vcpu-10| I125: Tools: Changing running status: 2 => 1.

            2019-02-07T14:06:50.385-05:00| vcpu-10| I125: Tools: [RunningStatus] Last heartbeat value 0 (never received)

            2019-02-07T14:06:50.385-05:00| vmx| I125: SOCKET 36 (254) recv detected client closed connection

            2019-02-07T14:06:50.385-05:00| vmx| I125: Vix: [mainDispatch.c:2828]: VMAutomation: Connection Error (4) on connection 33.

            2019-02-07T14:06:52.589-05:00| vmx| I125: SOCKET 37 (255) recv detected client closed connection

            2019-02-07T14:06:52.589-05:00| vmx| I125: Vix: [mainDispatch.c:2828]: VMAutomation: Connection Error (4) on connection 34.

            2019-02-07T14:06:54.799-05:00| vmx| I125: SOCKET 38 (256) recv detected client closed connection

            2019-02-07T14:06:54.799-05:00| vmx| I125: Vix: [mainDispatch.c:2828]: VMAutomation: Connection Error (4) on connection 35.

            • 3. Re: Vagrant/Virtualbox Migrated machine doesn't work: Error: Unknown Error
              wila Guru
              User ModeratorsvExpertCommunity Warriors

              Hi,

               

              As you have figured out already, this is a vmware tools issue.

               

              I seem to recall that the shared folder feature in open vmware tools in ubuntu 16.04 had problems.

              VMware fixed it, but ubuntu never merged that fix into their repository.

              Which version of VMware Tools are you running?

               

              If open vmware tools, then purge that via  apt-get and try installing the bundled vmware tools instead.

               

              --

              Wil

              | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
              | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
              | More info at https://www.vimalin.com
              | Twitter @wilva
              | VMware Wiki at http://www.vi-toolkit.com
              • 4. Re: Vagrant/Virtualbox Migrated machine doesn't work: Error: Unknown Error
                coogle Lurker

                Okay

                 

                I uninstalled open-vm-tools and open-vm-dkms and ran the installer from the tarball in linux.iso (I had to scp it into the machine)... everything seems like it installed correctly.

                 

                Now when I try vmrun enableSharedFolders for the .VMX it just hangs and seems to do nothing at all until I CTRL-C out of it?

                 

                Thoughts?

                • 5. Re: Vagrant/Virtualbox Migrated machine doesn't work: Error: Unknown Error
                  wila Guru
                  Community WarriorsUser ModeratorsvExpert

                  Hi,

                   

                  What I did for all of my ubuntu VM's was to completely skip 16.04. Had it on a few VM's and it always had various issues (not just vmware tools, also a number of systemd ones).

                  My solution was to go straight to ubuntu 18.04 and use open-vm-tools down there.

                   

                  Not sure if that's an acceptable route for you though.

                  --

                  Wil

                  | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                  | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
                  | More info at https://www.vimalin.com
                  | Twitter @wilva
                  | VMware Wiki at http://www.vi-toolkit.com
                  • 6. Re: Vagrant/Virtualbox Migrated machine doesn't work: Error: Unknown Error
                    coogle Lurker

                    Yeah unfortunately I can't really upgrade this one. It's a legacy code base development environment running on a legacy VM that would be way more trouble than it's worth to move to VMWare if we have to try to upgrade to 18.04+ to do it. Right now it works in VirtualBox (although slowly), and if we have to keep it there that's going to be the option.

                     

                    I really hope someone knowledgable however can figure out why it's freezing now and get me across the finish line!

                    • 7. Re: Vagrant/Virtualbox Migrated machine doesn't work: Error: Unknown Error
                      JessieZhang Enthusiast
                      VMware Employees

                      coogle,

                       

                      Based on your description: "Now when I try vmrun enableSharedFolders for the .VMX it just hangs and seems to do nothing at all until I CTRL-C out of it?"

                       

                      My first thought is that your tools might not be installed correctly. On my side, if tools is not installed in a 64bit Ubuntu 16.04.5 Desktop VM, when I run "vmrun enableSharedFolders" command on the VM, the command returns nothing until 5 minutes of timeout, that is, the command gave out below error after 5 minutes:

                      "Error: The VMware Tools are not running in the virtual machine: /Users/Shared/Ubuntu 64-bit 16.04.5.vmwarevm/Ubuntu 64-bit 16.04.5.vmx"

                       

                      Could you please try running the command again on your side and wait 5 minutes to see if the command returns the same error on your side? If yes, please try re-installing VMware Tools.