1 2 Previous Next 18 Replies Latest reply on Oct 15, 2019 7:33 AM by Boyan Go to original post
      • 15. Re: Windows Server 2016 Really slow on ESXI 6.5
        Boyan Enthusiast

        Did it for me, Thank you

         

        unmap.png

        • 16. Re: Windows Server 2016 Really slow on ESXI 6.5
          CraigD Novice

          This thread was very useful to me recently, but the issue has some differences with some of the situations described in other posts and in this article.  The crux is that the "DisableDeleteNotify" settings corrected the problems in both occurrences.  Therefore if you find yourself in a "Very poor file I/O performance with Windows 2016 and VMware ESXi 6.5" (any version, I say) then these commands are worth a try.

           

          First a client called us with a problem on a brand new VM that was built on their brand new VMware 6.5 platform on their brand new SAN and host hardware.  Other existing VMs (brought over from the old vSphere 5.5 system) were running fine.  However when there was any file I/O initiated from a physical machine where the file resided on this new VM, the file I/O was so poor as to be unusable.  We first confirmed the behavior from a physical machine.  We then tested from a VM and saw the same thing.  Next we migrated our test machine to be on the same host as the new, problematic server and the file I/O was great.  Interesting but not immediately helpful.  After a little more testing and a call to VMware the first thing that was suggested was to try the DisableDeleteNotify settings mentioned above in this thread.  The client's system runs Dell-customized ESXi 6.5.0 Build 8294253, which is 6.5 U2.  The article linked above describes the problem as being corrected in 6.5 U1.  Therefore I was skeptical that setting DisableDeleteNotify to 1 would correct the problem.  But it did.  After running both the NTFS and the ReFS commands and rebooting the server the file I/O problem was GONE.  It's been a couple of weeks now and the performance has been great.  VM hardware is version 13, by the way.  Windows Server OS on the problematic server is 2016.

           

          Then this past Sunday morning I installed two Microsoft updates to our primary file and print server (KB890830 – Malicious Software Removal Tool and KB4480961 – Cumulative Update from January 8).  We immediately began having file I/O problems that felt very similar to those that my client had on their system a couple weeks ago, described above.  We are on Dell-customized 6.5.0 build 8935087.  VM hardware version is 13.  Windows OS is Server 2016.  With my client's situation fresh on my mind I quickly tried applying the DisableDeleteNotify=1 settings and the problem went away immediately.

           

          Therefore my advice is that if you have any sudden file I/O issues with a new-ish Windows OS on a host running VMware ESXi 6.5 (any build), you should at least try these commands:

           

          • fsutil behavior set DisableDeleteNotify NTFS 1
          • fsutil behavior set DisableDeleteNotify ReFS 1
          • <reboot>
          • 17. Re: Windows Server 2016 Really slow on ESXI 6.5
            dobrasekwifi Lurker

            Hi, I have similar problem on 6.5.0 U2. Did you try update to U3?

             

            I have tried fsutil, but with no visible results... :/

            • 18. Re: Windows Server 2016 Really slow on ESXI 6.5
              Boyan Enthusiast

              I will date suggest that the fix works on any 6.x as I was NOT on 6.5 and it improved my performance just as expected. I am on 6.0.0 Update 3 (Build 5050593) image profile HPE-ESXi-6.0.0-Update3-iso-600.9.7.0.17 (Hewlett Packard Enterprise) on bare metal 12 CPUs x Intel(R) Xeon(R) CPU X5690 @ 3.47GHz

              1 2 Previous Next