1 2 Previous Next 17 Replies Latest reply on Jun 6, 2019 11:29 AM by Hunnywell Go to original post
      • 15. Re: ESXi 6.7 fail to enable vsan network vmkernel
        TheBobkin Virtuoso
        vExpertVMware Employees

        Hello Yammy,

         

         

        Any chance you initially added the host to vCenter with administrator@vsphere.local or some other account than root?

        I ask as the logs you posted keep stating 'Throw vim.fault.NoPermission' etc.

         

         

        Bob

        • 16. Re: ESXi 6.7 fail to enable vsan network vmkernel
          Yammy1988 Novice

          Hello, Bob

           

          When I initially added the ESXi host, I have seen that the blank for username was filled with "administrator@vsphere.local"(before I fill in the blank with "root").

          I first deleted "administrator@vsphere.local", then entered "root" as username.

          The host was successfully added.

           

          About no permission error, I wonder if the username value was "null" at that time.

          I attach why I thought such a thing from the log(though I cannot determine it is related to this issue or not..).

           

          Regards

          Yammy

          • 17. Re: ESXi 6.7 fail to enable vsan network vmkernel
            Hunnywell Lurker

            I needed to edit this because after adding some additional hosts I ran into the same issue.

             

            Something during the connection of vCenter to the ESXi host was not 100%.  I needed to disconnect the affected hosts and then ran the following PowerCLI command to force a reconnect:

             

            $connectSpec = New-Object VMware.Vim.HostConnectSpec
            $connectSpec.force = $true
            $connectSpec.userName = 'root'
            $connectSpec.password = 'SomethingHere'
            
            foreach ($VMHost in @(Get-VMHost -State Disconnected))
            {
                $connectSpec.hostName = $VMHost.name
                $VMHost.extensionData.ReconnectHost_Task($connectSpec,$null)
            }
            

             

            After reconnecting the host, everything worked great.  Hopefully this will also work for some of the affected people.

            1 2 Previous Next