5 Replies Latest reply on Jan 11, 2019 3:47 AM by continuum

    SAN LUN corrupted reverted existing Datastore to LinuxNative from VMFS and cannot mount without VMware wiping the datastore

    zoics Novice

      All, I have a Datastore that will not mount.  It is on a HP P2000 and VMware (5.5.0 u3b) on the host required a rebuild after corruption.  Note the store would not mount previously.  9 out of 10 stores mount and are visible in VMware. 

       

      I have already tried to reset the partition table - using partedUtil.  following the guidance  here - VMware Knowledge Base

      ~ # partedUtil getptbl /vmfs/devices/disks/naa.600c0ff00014c353c7c00f5001000000

      gpt

      497976 255 63 8000000000

      1 2048 7999997951 EBD0A0A2B9E5443387C068B6B72699C7 linuxNative 0

       

      getUsableSectors returned -  7999999966

       

      Current status -

      ~ # partedUtil getptbl /vmfs/devices/disks/naa.600c0ff00014c353c7c00f5001000000

      gpt

      497976 255 63 8000000000

      1 2048 7999997951 AA31E02A400F11DB9590000C2911D1B8 vmfs 0

       

      Note - have tried both 7999997951 and 7999999966 for usable sectors

       

      The drive does not show within /vmfs/volumes yet the device shows as mounted via the vSphere Client, under storage adapter, Operational State. 

       

      Errors in the kernel log show - 'No FS driver claimed device 'naa.600c0ff00014c353c7c00f5001000000:1': Not supported'

       

      Calculated value for usable sectors was - 7999984439 - and this also fails.

       

      This volume is 4TB.

       

      Any ideas?  Many thanks.