5 Replies Latest reply on Nov 13, 2018 3:40 AM by a.p.

    Disabling port-binding - grey out ticked box

    wangmurong Lurker

      I've configured an iSCSI over a dedicated connection and my setup, as far as I'm aware, does not include any port bindings. I explicitly want to avoid iSCSI port binding.

      My settings are showing it ticked but greyed out. port-binding.JPG

      Despite quite some search I cannot establish what this actually means. If it is "enabled" how do I disable it? If it is greyed out does this actually mean this option is not being used and therefore it is disabled?

      Thanks.

        • 1. Re: Disabling port-binding - grey out ticked box
          a.p. Guru
          User ModeratorsCommunity WarriorsvExpert

          iSCSI port binding is configured on the iSCSI storage adapter. Make sure that the iSCSI ports have not been added in the adapter's properties if port binding is not wanted.


          André

          • 2. Re: Disabling port-binding - grey out ticked box
            wangmurong Lurker

            André, Thanks.

            Just to clarify - the suggestion is to hit 'remove', here, in the network properties on the iSCSI initiator?

            storage adapter.png

            Sorry to be cautious - now is a particularly bad time for my VMs to go down

            • 3. Re: Disabling port-binding - grey out ticked box
              a.p. Guru
              vExpertUser ModeratorsCommunity Warriors

              You should of course be cautious. Please don't take my previous reply as a recommendation, it's more an answer to your demand "I explicitly want to avoid iSCSI port binding.".

              Port binding is usually used if iSCSI traffic is within one single subnet, where each initiator IP addresses can reach all target.IP addresses. In case you have a storage system which uses addresses in different subnets for the storage controller ports, port binding may not be appropriate.

              Maybe you can clarify why you want to avoid port binding, and how your iSCSI network setup looks like.

               

              André

              • 4. Re: Disabling port-binding - grey out ticked box
                wangmurong Lurker

                I'm running ESXI 6.0 with FreeNas 11 as the datastore. Freenas does not allow multiple connections on the same subnet so my two direct connections are configured to two seperate NICs on two VMKernel adapters. The configuration is set to round-robin with an MTU of 9000.

                The root problem I'm chasing is reports of a timeout from the FN box. (e.g., (iqn.1998-01.com.vmware:5b8bfc

                4f-89f9-4faf-6621-38d547021ae0-19a48e7b): no ping reply (NOP-Out) after 5 seconds; dropping connection). When I started getting these errors Vmware would mark the datastore as "dead or error". That no longer, happens. The datastores remain in their mounted state.

                 

                One cause of the error may be portbinding so I want to make sure it is not enabled. The confusion -- on this point -- lies with the greyed out but ticked box in VmWare. The properties states portbinding is "enabled" but is it? If so, why can't I uncheck this box?

                 

                If I've not covered something useful in the setup description please let me know.

                 

                Otherwise any help / thoughts on either the specific (port binding) or general (timeout) issue would be helpful.

                thanks! James

                • 5. Re: Disabling port-binding - grey out ticked box
                  a.p. Guru
                  User ModeratorsCommunity WarriorsvExpert

                  The properties states portbinding is "enabled" but is it? If so, why can't I uncheck this box?

                  You cannot change this in the Port Group settings, but only by removing the ports from the iSCSI Initiator settings.

                   

                  André