3 Replies Latest reply on Nov 5, 2018 1:49 AM by Wolken

    How to enable SR-IOV in ESXi using host client?

    edselaviatrix Lurker

      I'm using ESXi version - VMware ESXi 6.7.0 build-10302608 and server  HPE ProLiant DL360 Gen10 machine.  Loaded with this 10Gig card (QLogic Inc. QLogic 57810 10 Gigabit Ethernet Adapter) which uses native driver =qfle3.

      vmnic4  0000:11:00.0  qfle3   Up        Up       10000  Fulld8:9d:67:20:ed:d8  1500  QLogic Inc. QLogic 57810 10 Gigabit Ethernet Adapter


      I've set the SR-IOV enable from HP BIOS and enable the host with DRSS,RSS,rxqueue/txqueue.

      [root@localhost:~] esxcfg-module -g qfle3

      qfle3 enabled = 1 options = 'DRSS=4,4 RSS=1,1 rxqueue_nr=8,8 txqueue_nr=8,8'


      Unfortunately, I did not enable SR-IOV from vCenter/vSphere Client, hence the SR-IOV was not enabled due to the native driver qfle3.


      1. Using the host client http://ip_address/ui doesn't have the ability to enable SR-IOV under physical adapter.  Is there another way of doing it?


      2. Install a software vib with bnx2x driver to force the SR-IOV settings from ESXi host level using "max_vfs" command.  Where can i find it?