12 Replies Latest reply on Apr 23, 2018 1:07 PM by RebeccaG

    Error:STAF Ping machName = Failed

    mca38 Novice

      I keep getting the following error message during setup:

       

      Error:STAF Ping machName = Failed

       

      I am able to ping from the primeclient to the vmmark-test1 VM, and vice versus. I also updated /etc/hosts on both the primeclient and test VM. Both also reside on the same network.

       

       

      Thoughts?

        • 1. Re: Error:STAF Ping machName = Failed
          jpschnee Expert
          VMware Employees

          Where did you get the names "vmmark-test1" and "vmmark-test2"?  You should really be using the automatically created clients.  Client0,Client1... etc.

          • 2. Re: Error:STAF Ping machName = Failed
            mca38 Novice

            Okay. I changed the names from vmmark-test1 and vmmark-test2 and am still having the same issue. I created both "Client" VMs on a separate cluster, which reside on the same network as the primeclient. I can ping from the primeclient and likewise from Client0. Appreciate your assistance.

             

            [root@primeclient VMmark3]# cat /etc/hosts

             

            127.0.0.1   localhost.localdomain localhost localhost4 localhost4.localdomain4 primeclient

            ::1         localhost6 localhost6.localdomain6

            192.168.1.30    primeclient

            192.168.1.16    AuctionAppA0

            192.168.1.17    AuctionAppB0

            192.168.1.19    AuctionDB0

            192.168.1.12    AuctionLB0

            192.168.1.13    AuctionMSQ0

            192.168.1.18    AuctionNoSQL0

            192.168.1.14    AuctionWebA0

            192.168.1.15    AuctionWebB0

            192.168.1.5     DS3DB0

            192.168.1.2     DS3WebA0

            192.168.1.3     DS3WebB0

            192.168.1.4     DS3WebC0

            192.168.1.9     ElasticAppA0

            192.168.1.10    ElasticAppB0

            192.168.1.11    ElasticDB0

            192.168.1.6     ElasticLB0

            192.168.1.7     ElasticWebA0

            192.168.1.8     ElasticWebB0

            192.168.1.20    Standby0

            192.168.1.28    Client0

            192.168.1.29    Client1

             

            [root@primeclient VMmark3]# ping Client0

            PING Client0 (192.168.1.28) 56(84) bytes of data.

            64 bytes from Client0 (192.168.1.28): icmp_seq=1 ttl=64 time=0.512 ms

            64 bytes from Client0 (192.168.1.28): icmp_seq=2 ttl=64 time=0.302 ms

            ^C

            --- Client0 ping statistics ---

            2 packets transmitted, 2 received, 0% packet loss, time 1000ms

            rtt min/avg/max/mdev = 0.302/0.407/0.512/0.105 ms

             

             

            • 3. Re: Error:STAF Ping machName = Failed
              jpschnee Expert
              VMware Employees

              Hello,

               

              I'm not sure I'm following you but I would suggest deleting the old vmmark-test1 and vmmark-test2 and redeploying them.

              • 4. Re: Error:STAF Ping machName = Failed
                mca38 Novice

                Based on your reply, I think I figured out the issue. The clients need the same version of STAF as the workload VMs, per the user guide. Correct? However, I did not see anything in the user guide which documents how to push STAF to the client VMs. This would explain why I cannot ping client0, client1, etc.

                • 5. Re: Error:STAF Ping machName = Failed
                  daonemaster Novice

                  What JP is suggestion is better to redeploy and it worked for me.

                  • 6. Re: Error:STAF Ping machName = Failed
                    mca38 Novice

                    Did you just redeploy the VMs through vCenter? One of the things I am trying to understand is how to get STAF installed on the clients. The user guide states "all clients and all workload virtual machines are running the same version of STAF". However, there is nothing in the guide that states how it gets installed. How did you deploy your clients?

                    • 7. Re: Error:STAF Ping machName = Failed
                      mca38 Novice

                      I was able to get past the issue with communicating between the primeclient and client0. Unfortunately the documentation does not tell you that the STAF agent needs to be installed on the client. I downloaded it from the link given in the user guide and am now able to execute a "STAF local PING PING" and get a "PONG" response.

                      • 8. Re: Error:STAF Ping machName = Failed
                        jpschnee Expert
                        VMware Employees

                        The correct process is to have the provisioning service create the clients from the vmmark-template.  This way all VMs (prime client, clients, and workload VMs) all have the same STAF.

                        • 9. Re: Error:STAF Ping machName = Failed
                          mca38 Novice

                          Got it. For some reason the clients did not get deployed at the same time as the workload VMs. Do I have to delete all of the workload VMs to re-deploy the clients? When I run java -jar tools/VMmark3Service.jar -c VMmark3.properties to redeploy I get the following error:

                           

                          2018-04-18T16:53:01.322 [main] ERROR MAIN : Provisioning Validation FAILED

                          2018-04-18T16:53:01.330 [main] ERROR MAIN : Exception Caught: Provisioning Validation FAILEDReview Log For Details : exitSetting true

                          2018-04-18T16:53:01.330 [main] INFO  MAIN : EmailString: VMmark3Service_v1.0.0 Finished

                           

                          Summary::

                          /root/VMmark3/provisioning-output/vmmark3-output/

                          Provisioning Validation FAILED :: Error Detail (if applicable): Review Log For Details

                          Error Output:: Found 1 Errors

                          TimeElapsed: 3 (secs)

                          2018-04-18T16:53:01.330 [main] INFO  MAIN : Emailing

                          2018-04-18T16:53:01.334 [main] INFO  EMAIL : emailTo '' emailFrom 'mike@vmmark.com' emailSMTP '' emailSubject 'VMmark3Service_v1.0.0 : primeclient

                          : provision: ExceptionFound

                          ' attachmentWithFullPath 'null' emailPort '25' emailMessage 'VMmark3Service_v1.0.0 Finished

                           

                          Summary::

                          /root/VMmark3/provisioning-output/vmmark3-output/

                          Provisioning Validation FAILED :: Error Detail (if applicable): Review Log For Details

                          Error Output:: Found 1 Errors

                          TimeElapsed: 3 (secs)'

                          2018-04-18T16:53:01.453 [main] INFO  EMAIL :  VMmark3Service_v1.0.0 : Sendmail Finished Successfully

                          2018-04-18T16:53:01.453 [main] INFO  MAIN : Ending Early

                          • 10. Re: Error:STAF Ping machName = Failed
                            jpschnee Expert
                            VMware Employees

                            You can deploy them separately by modifying the VMmark3.properties file provisioningDatastores variable.  See the user's guide for full details.

                            • 11. Re: Error:STAF Ping machName = Failed
                              mca38 Novice

                              As an FYI to everyone on this blog, the error turned out to be a communication issue between the primeclient and the cluster where client0 was trying to be deployed. I resolved that issue and successfully deployed client0.

                               

                              Thanks for your help.

                              • 12. Re: Error:STAF Ping machName = Failed
                                RebeccaG Hot Shot
                                VMware Employees

                                Thank you for updating us on the resolution.