1 Reply Latest reply on Apr 11, 2018 2:35 PM by sconley

    Long Login Time With AppStacks Attached

    sconley Novice

      I am in the process of testing App Volumes 2.13.3 using Windows 10 build 1703.  With no AppStacks connected I see login times in the 20 - 30 second range.  With a single AppStack connected the login time jumps to 50 - 60 seconds.  I am pulling these login times from the Horizon Helpdesk Tool.  I have tried multiple AppStacks and the result is the same with each.  I realize that App Volumes will add some overhead to the login process, but is this normal?  Is there any optimization that I might be missing?

       

      As a test I changed from user assignment to machine assignment with no change.

       

      Message was edited by: Sean Conley

        • 1. Re: Long Login Time With AppStacks Attached
          sconley Novice

          I have done a bit more research into this and came across these entries in the svservice.log file:

           

          [2018-04-11 21:28:50.964 UTC] [svservice:P1324:T3792] Waiting for 1 new volumes before resetting order (1 processed, waited 2 second(s) so far)

          [2018-04-11 21:29:05.781 UTC] [svservice:P1324:T4212] OnStartShell called (Session ID 1, Handle 0000017E340FC6D0, Params 00000014210FED78, Context 0000000000000000)

           

          If I am reading this correctly, the service is blocking loading the user's shell for 15 seconds in this case.  I also notice a CPU spike on the VM as the user logs on.  What exactly is going on at this point, and is there anything I can do to optimize it?