1 Reply Latest reply on Feb 12, 2018 4:49 AM by tanurkov

    load Balancer session timeout

    RamSThakur Lurker

      VMware NSX version: 6.3.5.7119875

      NSX Edges version: 6.3.5

      There is one NSX server and two High Available Edge servers used for load balancing only. L7 load balancing is enabled.

      vCenter server appliance version: 6.0.0 7037393

      ESXi servers version: ESXi 6.0.0 6921384

       

      The problem appeared in customer’s application where the end users were disconnected because of session timeout. when checked, found that the persistence expiration which was 5 minutes (the default). So changed it to 7200 seconds.

       

      But when checked the edge server CLI command “show service load-balancer session l7” the output is different

       

      - the “exp=” is maximum 5 minutes for any session.

       

      Question:

      Is the above setting for persistence expiration applied or not? And how can we verify it?

        • 1. Re: load Balancer session timeout
          tanurkov Enthusiast

          HI RAmSThakur

           

          Please check if your LB Edges in HA are not in split brain.

          Please use API to change values for persistence.

           

          value 5 minutes indicated that there is no updated info on Edges from NSX UI.

          Verify what UI shows in sessions

          verify with API what sessions is actually

          Compare them . 

          using API can avoid UI issues and Split brain scenarios.

          easy to do just query LB config , change the value of persistence and put t back  

           

          Regards Dmitri