1 2 3 4 Previous Next 48 Replies Latest reply on Nov 16, 2017 1:09 AM by IntegratorP Go to original post
      • 45. Re: Cannot upgrade VCSA 6.0 to 6.5 - Internal error occurs during Export of vSphere ESX Agent Manager
        Dudleydoggg Lurker

        Bouda0175     Mar 30, 2017 11:04 PM    (in response to TomKalabis) Bouda0175

        I followed Bouda0175 Steps and got past the Agent Manager Issue.

        Alleged Update  completed Successfully.

         

        • 46. Re: Cannot upgrade VCSA 6.0 to 6.5 - Internal error occurs during Export of vSphere ESX Agent Manager
          Jbir Novice

          Following this discussion. I upgraded my test VCSA 6.0U3 last week to 6.5.0d and didn't experience any issues (luckily). I am now about to do ESXi and happened to look at the compatibility chart only to find to my horror that this upgrade path is not supported! I will probably do the test system anyway just for the hell of it, but i cannot do production or our Horizon environment until it is supported. I contacted VMware technical support who were not helpful at all. According to them there may be an update 1 due out in July or August but would not confirm if an upgrade to this from 6.0U3 would be supported

          • 47. Re: Cannot upgrade VCSA 6.0 to 6.5 - Internal error occurs during Export of vSphere ESX Agent Manager
            Mr G Grant Enthusiast

            This product just seems to be getting worse its like they are not even doing proper QA anymore! How does something like this get released without testing things like that? So now we are all just stuck at 6.0U3 until VMware decide to release another patch for this? Its just as well cloud computing is really taking off now and I cant wait to move off this platform. No more dodgy upgrades

             

            I hate to even leave these kind of posts and I apologise for not offering any useful information in this post but this is really annoying!

            • 48. Re: Cannot upgrade VCSA 6.0 to 6.5 - Internal error occurs during Export of vSphere ESX Agent Manager
              IntegratorP Lurker

              I,ve just upgraded from 6.0 U3a to 6.5.0U1c and had to follow the exact same steps.

               

               

               

              (Jnewton03's original post) ---

              I was able to get this working yesterday with 6.5a.  I have not yet tried 6.5b.

               

              Here is what I did:

               

              To remove unwanted plug-ins from the available plug-in list:

              1. In a web browser, navigate to http://vCenter_Server_name_or_IP/mob.

                Where vCenter_Server_name_or_IP/mob is the name of your vCenter Server or its IP address.

              2. Click Content.
              3. Click ExtensionManager.
              4. Select and copy the name of the plug-in you want to remove from the list of values under Properties. For a list of default plug-ins, see the Additional Information section of this article.
              5. Click UnregisterExtension. A new window appears.
              6. Paste the key of the plug-in and click Invoke Method. This removes the plug-in and results in void.  (I used com.vmware.vim.eam)
              7. Close the window.
              8. Refresh the Managed Object Type:ManagedObjectReference:ExtensionManager window to verify that the plug-in is removed successfully.

              I then stopped the VMWare-EAM service on the source appliance by doing the following:

               

               

              1.  SSH into the source appliance

              2.  Go into shell

              3.  issue a  service-control --stop vmware-eam

               

              I then re-ran the upgrade and was successful.  Note that doing just one or the other of the above steps may have worked, but I have not tested it.

              1 2 3 4 Previous Next